[Fujitsu LifeBook T4410] Touchscreen unusual in multi-head system

Bug #666604 reported by vik on 2010-10-26
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
xserver-xorg-input-evdev (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: xorg

I'm using a touchscreen laptop (fujitsu T4410). Touchscreen works fine, but when I plug an (non-touchscreen) external monitor in and go dual-head, the touch functionality 'stretches' across the multiple screens. e.g. I have the external monitor above the laptop monitor. When I touch the bottom of the touchscreen, the touch is (almost) correct. When I touch the top of the touchscreen, the pointer goes to the top of the external monitor. Same situation in the vertical dimension.

What should happen is that touch events only occur on the touchscreen monitor

This may be tricky, as the touch driver (for this particular machine) is wacom, so the machine probably sees the touch device as a wacom pen tablet.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: xorg 1:7.5+6ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-22.34-generic-pae 2.6.35.4
Uname: Linux 2.6.35-22-generic-pae i686
Architecture: i386
DRM.card0.DisplayPort.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.DisplayPort.2:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.DisplayPort.3:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.HDMI_Type_A.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.HDMI_Type_A.2:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1280x800
 edid-base64:
DRM.card0.VGA.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1920x1080 1680x1050 1280x1024 1280x1024 1152x864 1024x768 1024x768 800x600 800x600 640x480 640x480 720x400
 edid-base64: AP///////wAebQBXvUoEAAIUAQNqMx146smlpFZLnSUSUFSlSwCzAIGAgY9xTwEBAQEBAQEBAjqAGHE4LUBYLEUA/iIRAAAeITmQMGIaJ0BosDYA2igRAAAcAAAA/QA4Sx5TDwAKICAgICAgAAAA/ABXMjM0MwogICAgICAgAO0=
Date: Tue Oct 26 14:17:25 2010
InstallationMedia: Ubuntu-Netbook 10.10 "Maverick Meerkat" - Release i386 (20101007)
MachineType: FUJITSU LifeBook T4410
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-22-generic-pae root=UUID=aadfad4a-c647-4ca1-9162-e2547bab3df1 ro quiet splash
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: xorg
dmi.bios.date: 03/19/2010
dmi.bios.vendor: FUJITSU // Phoenix Technologies Ltd.
dmi.bios.version: Version 1.08
dmi.board.name: FJNB206
dmi.board.vendor: FUJITSU
dmi.chassis.type: 10
dmi.chassis.vendor: D42310E90A6A1101
dmi.modalias: dmi:bvnFUJITSU//PhoenixTechnologiesLtd.:bvrVersion1.08:bd03/19/2010:svnFUJITSU:pnLifeBookT4410:pvr:rvnFUJITSU:rnFJNB206:rvr:cvnD42310E90A6A1101:ct10:cvr:
dmi.product.name: LifeBook T4410
dmi.sys.vendor: FUJITSU
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 codename: maverick
 architecture: i686
 kernel: 2.6.35-22-generic-pae
---
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
DRM.card0.DP.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.DP.2:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.DP.3:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.HDMI.A.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.HDMI.A.2:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1280x800
 edid-base64:
DRM.card0.VGA.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1920x1080 1680x1050 1280x1024 1280x1024 1152x864 1024x768 1024x768 800x600 800x600 640x480 640x480 720x400
 edid-base64: AP///////wAebQBXvUoEAAIUAQNqMx146smlpFZLnSUSUFSlSwCzAIGAgY9xTwEBAQEBAQEBAjqAGHE4LUBYLEUA/iIRAAAeITmQMGIaJ0BosDYA2igRAAAcAAAA/QA4Sx5TDwAKICAgICAgAAAA/ABXMjM0MwogICAgICAgAO0=
DistUpgraded: Fresh install
DistroCodename: natty
DistroRelease: Ubuntu 11.04
DistroVariant: ubuntu
GdmLog2:

GraphicsCard:
 Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07) (prog-if 00 [VGA controller])
   Subsystem: Fujitsu Limited. Device [10cf:1458]
   Subsystem: Fujitsu Limited. Device [10cf:1458]
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
MachineType: FUJITSU LifeBook T4410
Package: xserver-xorg-input-evdev 1:2.6.0-1ubuntu12
PackageArchitecture: i386
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Renderer: Unknown
Tags: natty ubuntu compiz-0.9
Uname: Linux 2.6.38-8-generic i686
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 09/30/2009
dmi.bios.vendor: FUJITSU // Phoenix Technologies Ltd.
dmi.bios.version: Version 1.05
dmi.board.name: FJNB206
dmi.board.vendor: FUJITSU
dmi.chassis.type: 10
dmi.chassis.vendor: D42310E90A6C1101
dmi.modalias: dmi:bvnFUJITSU//PhoenixTechnologiesLtd.:bvrVersion1.05:bd09/30/2009:svnFUJITSU:pnLifeBookT4410:pvr:rvnFUJITSU:rnFJNB206:rvr:cvnD42310E90A6C1101:ct10:cvr:
dmi.product.name: LifeBook T4410
dmi.sys.vendor: FUJITSU
version.compiz: compiz 1:0.9.4+bzr20110415-0ubuntu2
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

vik (askvictor) wrote :
matt (matthiasgies) wrote :

Same thing with touchscreen from different brand on a packard bell butterfly touch.

My screens are not on top of each other, but besides one another. On the touchscreen i'd like to navigate through a PDF, while writing on a text file on the regular screen. Doesn't work, since the coordinates of the touchscreen seem to be spread relatively over the whole xscreen (both physical screens)...

This seems to be a feature request I guess...
But an important feature I'd say, since theres no use of a single touchscreen in a dual head environment with the present setting.

affects: xorg (Ubuntu) → xserver-xorg-input-evdev (Ubuntu)
Vsevolod Velichko (torkvemada) wrote :

Same for me on HP TouchSmart tm2 with wacom touchscreen.

bugbot (bugbot) wrote :

Hey vik,

Hi, have you had a chance to test if this bug is still present in natty?

If it does (and if you're the original reporter), please boot into natty
and run the command:

  apport-collect <bug-number>

which will update the bug with fresh logs and tag the bug as affecting
natty. (It is best to run this right after reproducing the problem.)

Changed in xserver-xorg-input-evdev (Ubuntu):
status: New → Incomplete
vik (askvictor) wrote : BootDmesg.txt

apport information

tags: added: apport-collected compiz-0.9 natty ubuntu
description: updated

apport information

apport information

apport information

vik (askvictor) wrote : GdmLog.txt

apport information

vik (askvictor) wrote : GdmLog1.txt

apport information

vik (askvictor) wrote : Lspci.txt

apport information

vik (askvictor) wrote : Lsusb.txt

apport information

apport information

apport information

apport information

vik (askvictor) wrote : UdevDb.txt

apport information

vik (askvictor) wrote : UdevLog.txt

apport information

apport information

vik (askvictor) wrote : XorgLog.txt

apport information

apport information

vik (askvictor) wrote : Xrandr.txt

apport information

vik (askvictor) wrote : locale.txt

apport information

apport information

apport information

apport information

vik (askvictor) wrote : xdpyinfo.txt

apport information

vik (askvictor) wrote : xinput.txt

apport information

vik (askvictor) wrote : xkbcomp.txt

apport information

Download full text (3.6 KiB)

Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: kwin
DRM.card0.DP.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.DP.2:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.DP.3:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.HDMI.A.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.HDMI.A.2:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1366x768
 edid-base64: AP///////wAGr1wgAAAAAAESAQOAGg54CpmFlVVWkigiUFQAAAABAQEBAQEBAQEBAQEBAQEBlhlWKFAACDAYECQAAJAQAAAYAAAADwAAAAAAAAAAAAAAAAAgAAAA/gBBVU8KICAgICAgICAgAAAA/gBCMTE2WFcwMiBWMCAKAPg=
DRM.card0.VGA.1:
 status: connected
 enabled: enabled
 dpms: Off
 modes: 1280x1024 1024x768 1024x768 1024x768 1024x768 800x600 800x600 800x600 640x480 640x480 640x480 720x400
 edid-base64: AP///////wAGCRyXTQAAAAMJAQEMHxex6OsuolVHmSUPR0+kzgBFWYGAMVlhWQEBAQEBAQEBAAAA/gBNb25pdG9yCiAgICAgAAAA/gBNb25pdG9yCiAgICAgAAAA/gBNb25pdG9yCiAgICAgAAAA/gBNb25pdG9yCiAgICAgALc=
DistUpgraded: Fresh install
DistroCodename: natty
DistroRelease: Ubuntu 11.04
DistroVariant: kubuntu
DkmsStatus:
 fglrx, 8.840, 2.6.38-8-generic, x86_64: installed
 virtualbox-ose, 4.0.4, 2.6.38-8-generic, x86_64: installed
 nvidia-current, 270.41.06, 2.6.38-8-generic, x86_64: installed
EcryptfsInUse: Yes
GraphicsCard:
 Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07) (prog-if 00 [VGA controller])
   Subsystem: Acer Incorporated [ALI] Device [1025:029d]
   Subsystem: Acer Incorporated [ALI] Device [1025:029d]
InstallationMedia: Kubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110202)
MachineType: Packard Bell ENBFT
Package: xserver-xorg-input-evdev 1:2.6.0-1ubuntu12
PackageArchitecture: amd64
ProcEnviron:
 LANGUAGE=de_DE
 LANG=de_DE.utf8
 LC_MESSAGES=de_DE.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=53ebb458-7483-4e1e-a774-df4c57d530d3 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Renderer: Unknown
Tags: natty kubuntu patch
Uname: Linux 2.6.38-8-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 04/23/2010
dmi.bios.vendor: INSYDE
dmi.bios.version: V1.3127
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: SJM12-MS-CAP
dmi.board.vendor: Packard Bell
dmi.board.version: Base Board Version
dmi.chassis.type: 10
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnINSYDE:bvrV1.3127:bd04/23/2010:svnPackardBell:pnENBFT:pvrV1.3127:rvnPackardBell:rnSJM12-MS-CAP:rvrBaseBoardVersion:cvnChassisManufacturer:ct10:cvrChassisVersion:
dmi.product.name: ENBFT
dmi.product.version: V1.3127
dmi.sys.vendor: Packard Bell
version.compiz: compiz N/A
version.ia32-libs: ia32-libs 20090808ubuntu13
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7....

Read more...

tags: added: kubuntu patch

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Launchpad Janitor (janitor) wrote :

[Expired for xserver-xorg-input-evdev (Ubuntu) because there has been no activity for 60 days.]

Changed in xserver-xorg-input-evdev (Ubuntu):
status: Incomplete → Expired
matt (matthiasgies) on 2011-07-28
Changed in xserver-xorg-input-evdev (Ubuntu):
status: Expired → New
Marcelo (mmtsales) wrote :

This can be adjusted by modifying the coordinates transformation matrix for the touchscreen using xinput. However, other problems arise after doing that.
See this bug for more details:
https://bugs.freedesktop.org/show_bug.cgi?id=50664

There are at least three other bugs about this problem registered in launchpad too, but I don't have their numbers right now. However, they've been reported against xorg, without specifying the evdev package.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-input-evdev (Ubuntu):
status: New → Confirmed

vik, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p xserver-xorg-input-evdev REPLACE-WITH-BUG-NUMBER

Please note, given that the information from the prior release is already available, doing this on a release prior to the development one would not be helpful.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

tags: removed: kubuntu
Changed in xserver-xorg-input-evdev (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete

ApportVersion: 2.13.1-0ubuntu2
Architecture: amd64
CasperVersion: 1.336ubuntu1
DistUpgraded: Fresh install
DistroCodename: trusty
DistroRelease: Ubuntu 14.04
DistroVariant: ubuntu
LiveMediaBuild: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140127.1)
MachineType: Packard Bell ENBFT
Package: xserver-xorg-input-evdev 1:2.8.2-1ubuntu1
PackageArchitecture: amd64
ProcEnviron:
 LANGUAGE=en
 TERM=xterm
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: noprompt cdrom-detect/try-usb=true file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
ProcVersionSignature: Ubuntu 3.13.0-5.20-generic 3.13.0
Tags: trusty ubuntu single-occurrence reproducible
Uname: Linux 3.13.0-5-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 04/23/2010
dmi.bios.vendor: INSYDE
dmi.bios.version: V1.3127
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: SJM12-MS-CAP
dmi.board.vendor: Packard Bell
dmi.board.version: Base Board Version
dmi.chassis.type: 10
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnINSYDE:bvrV1.3127:bd04/23/2010:svnPackardBell:pnENBFT:pvrV1.3127:rvnPackardBell:rnSJM12-MS-CAP:rvrBaseBoardVersion:cvnChassisManufacturer:ct10:cvrChassisVersion:
dmi.product.name: ENBFT
dmi.product.version: V1.3127
dmi.sys.vendor: Packard Bell
version.compiz: compiz 1:0.9.10+13.10.20131011-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.52-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.0.1-1ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.0.1-1ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.14.5-1ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.2.0-0ubuntu11
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.907-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu1
xserver.bootTime: Mon Jan 27 21:03:11 2014
xserver.configfile: default
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 12370
 vendor SEC
xserver.version: 2:1.14.5-1ubuntu2

tags: added: reproducible single-occurrence trusty

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in xserver-xorg-input-evdev (Ubuntu):
status: Incomplete → Confirmed

Bug is reproducable on current ubuntu development release!
It is also present on Kubuntu 13.10, which is what I work with at the moment.

I think this bug should get some priority, since touchscreens are pretty common these days. The current state just makes the touchscreen of my laptop useless, as soon as I attach an external screen an switch to dualhead...

matt, thank you for your comment. So your hardware and problem may be tracked, could you please file a new report by executing the following in a terminal:
ubuntu-bug xorg

Please ensure you have xdiagnose installed, and that you click the Yes button for attaching additional debugging information.

For more on this, please see the official Ubuntu documentation:
Ubuntu X.Org Team, Ubuntu Bug Control, and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report will delay your problem being addressed as quickly as possible.

Thank you for your understanding.

tags: removed: reproducible single-occurrence trusty
Changed in xserver-xorg-input-evdev (Ubuntu):
status: Confirmed → Incomplete
summary: - Touchscreen unusual in multi-head system
+ [Fujitsu LifeBook T4410] Touchscreen unusual in multi-head system
vik (askvictor) wrote :

I have recently installed 'normal' ubuntu 13.10 on a Fujitsu T5010 tablet (which is almost identical to the T4410 I initially reported this bug on). The touchscreen and stylus inputs work as they should even with an external display connected. Which is good news for me. I might try this on a T4410 soon. But from my perspective this bug has been fixed; not certain if kubuntu uses a different driver or configuration?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.