Cando touch screen is detected as touch pad

Bug #604097 reported by Tom Francart on 2010-07-10
56
This bug affects 10 people
Affects Status Importance Assigned to Milestone
xserver-xorg-input-evdev (Ubuntu)
Undecided
Unassigned
Nominated for Maverick by saMar

Bug Description

Binary package hint: xserver-xorg-input-evdev

The cando touch screen of my Acer Aspire 1825ptz is detected as a touch pad, causing erratic behaviour such as relative movements instead of absolute
This can be solved by patching evdev.c from

if (num_buttons || TestBit(BTN_TOOL_FINGER, pEvdev->key_bitmask)) {

to

if (TestBit(BTN_TOOL_FINGER, pEvdev->key_bitmask)) {

as indicated on
https://bugzilla.redhat.com/show_bug.cgi?id=518494

best regards,
Tom

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: xserver-xorg-input-evdev 1:2.3.2-5ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-4.5~lucid1-generic 2.6.35-rc3
Uname: Linux 2.6.35-4-generic i686
Architecture: i386
Date: Sat Jul 10 21:43:19 2010
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
MachineType: Acer Aspire 1825PTZ
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-4-generic root=UUID=4efddf37-2721-4ee8-8632-4797c712b503 ro quiet splash
ProcEnviron:
 PATH=(cususername, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: xserver-xorg-input-evdev
dmi.bios.date: 03/01/2010
dmi.bios.vendor: INSYDE
dmi.bios.version: V1.3118
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: JM12-MS-CAP
dmi.board.vendor: Acer
dmi.board.version: Base Board Version
dmi.chassis.type: 10
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnINSYDE:bvrV1.3118:bd03/01/2010:svnAcer:pnAspire1825PTZ:pvrV1.3118:rvnAcer:rnJM12-MS-CAP:rvrBaseBoardVersion:cvnChassisManufacturer:ct10:cvrChassisVersion:
dmi.product.name: Aspire 1825PTZ
dmi.product.version: V1.3118
dmi.sys.vendor: Acer
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 codename: lucid
 architecture: i686
 kernel: 2.6.35-4-generic

Tom Francart (francart) wrote :
Karsten Schwinne (kschwinne) wrote :

bug is also present in Ubuntu 10.10

matt (matthiasgies) on 2010-10-22
Changed in xserver-xorg-input-evdev (Ubuntu):
assignee: nobody → matt (matthiasgies)
assignee: matt (matthiasgies) → nobody
matt (matthiasgies) wrote :

bug fixed in natty 11.04
fix for 10.10 coming?

Marius B. Kotsbak (mariusko) wrote :

This works properly in the released Natty.

Changed in xserver-xorg-input-evdev (Ubuntu):
status: New → Fix Released
matt (matthiasgies) wrote :

works as touchscreen in natty, but still no multitouch.
afaik, screen should recognize at least two fingers...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers