Karmic mouse and keyboard delays

Bug #468223 reported by Zeniff on 2009-11-01
44
This bug affects 8 people
Affects Status Importance Assigned to Milestone
xserver-xorg-input-evdev (Ubuntu)
Undecided
Unassigned

Bug Description

Mouse clicks and keyboard presses seem randomly delayed for 3 to 5 seconds. As I type this, sometimes text won't show for a while. Also, sometimes the mouse icon would not change when, for example, I tried clicking or dragging something. It would usually still move, but the icon and action performed by the click would not take place until after the delay.

So far, I may have only experienced this in Firefox, but I doubt that's causing it, because I don't know of any reason Firefox would cause delays. Also, I'm not running any extra programs.

I just updated from Jaunt 9.04 to Karmic 9.10 yesterday. I never had any problems like this in Jaunty, and the frequency of them seems to be increasing. I have an Acer Aspire 5515 with 3GB of RAM, so I don't understand why I would have such long delays running just one program.

I have not installed any new software since then (except reinstalled SCIM, which the upgrade removed, but I experienced this problem before that reinstall, I think.).

Thank you for your time~ Have a great day!!! ^_^

ProblemType: Bug
Architecture: i386
Date: Sun Nov 1 03:03:02 2009
DistroRelease: Ubuntu 9.10
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: Acer Aspire 5515
NonfreeKernelModules: wl
Package: xorg 1:7.4+3ubuntu7
ProcCmdLine: root=UUID=10259b28-e8a9-411b-be18-b244ecc60c6b ro quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu7
 libgl1-mesa-glx 7.6.0-1ubuntu4
 libdrm2 2.4.14-1ubuntu1
 xserver-xorg-video-intel 2:2.9.0-1ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090929.7968e1fb-0ubuntu1
SourcePackage: xorg
Uname: Linux 2.6.31-14-generic i686
dmi.bios.date: 12/03/2008
dmi.bios.vendor: Acer
dmi.bios.version: V1.00
dmi.board.name: Nile
dmi.board.vendor: Acer
dmi.board.version: N/A
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAcer:bvrV1.00:bd12/03/2008:svnAcer:pnAspire5515:pvrV1.00:rvnAcer:rnNile:rvrN/A:cvnAcer:ct10:cvrN/A:
dmi.product.name: Aspire 5515
dmi.product.version: V1.00
dmi.sys.vendor: Acer
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.31-14-generic

Zeniff (zeniffmartineau) wrote :
John Kerenyi (jkerenyi123) wrote :

I'm having the same problem. I've noticed it mainly in Firefox where it's extremely annoying. I also noticed it picking stuff along the Gnome toolbar across the top of the screen, but that seems to have gone away.

The problem has no effect on my keyboard, unlike the original bug reporter. But what I see is, attempting to click on a link in Firefox causes the cursor to change to an up arrow. Then when I move the mouse it drags the link. So I guess it's just like if I had held the mouse button down. But of course that's not what I did. I'm now also seeing another manifestation which is, I clicked on the scroll bar to scroll up, and now the mouse keeps scrolling the screen even though the mouse button is not down.

I think it's a bug because this same computer worked exceptionally well with Ubuntu 9.04 and the only change to the system was the distribution upgrade to 9.10 on Friday (i.e. release version).

The computer I am using is a Dell Latitude D600. If more information is needed I'd be happy to provide.

I'm going to try re-booting (I'm pretty sure I've tried this before but I'll do it again to be sure) and I'll also connect a USB mouse to test that. I'll post the results.

John Kerenyi (jkerenyi123) wrote :

A reboot did not cure, but connecting an external mouse did. I've been clicking around on Web sites with the external USB mouse and I've been having no problems. So it must be related to the touchpad driver. By the way, it doesn't matter how I try to click with the touchpad: there are two left mouse buttons and you can also tap the touchpad, and all three have the same effect.

Here's something else: Operating the touchpad while having the USB mouse connected still causes the bug to manifest itself. Also, any of the three clicking techniques can cause the left-button mouse lock-down, and for me the lockdown is not cleared over time; but pressing a different button from the one that locked the mouse down will clear the click. So for example, if I cause a left-button mouse lockdown with the buttons right under the spacebar, I can clear it with a tap on the touchpad or a tap on the buttons below the touchpad. But I can never clear it by pressing the same button again. I also can't clear it by pressing the mouse button on the external mouse.

Zeniff (zeniffmartineau) wrote :

I'm also using a touchpad. My problem seems to be a delay of any action, but for me I don't think I've had any clicks where it thought the button was still down. However, my problem is similar in that if the delay is caused by tapping, clicking the touchpad button (I think) will make a faster response.

Also, thanks for reminding me about the Gnome toolbar, I also have complete mouse freezing which doesn't stop I think until I use the keyboard to access toolbar menus. So far, it happened everytime after booting when I clicked on nm-applet to connect to the Internet.

I'll also try a USB mouse and see if the delays go away.

pablisco (pabs87) wrote :

I have the same problem, but I am in a desktop (Phenom II x4) I have both a PS/2 and a usb wireless mouse and get the problem with both of them. On top of the metioned problems I also get trouble with Eclipse and with file-roller.

Please someone mark this as important since it breaks the system.

Timo Jyrinki (timo-jyrinki) wrote :

This is possibly https://bugs.freedesktop.org/show_bug.cgi?id=25020 (fixed) - please add to the bug report if you can confirm it helping.

Anyway, for anyone pondering, this bug is separate from bug #444674 (unfortunately, as it affects me).

John Kerenyi (jkerenyi123) wrote :

The bug Mr. Jyrinki references sounds like mine. Any advice for how to upgrade one module of X? Or should I just wait for Ubuntu to get around to updating their package.

Changed in ubuntu:
status: New → Confirmed
CylnZ (cylnzz) wrote :

Do a google for "xorg mouse problem" search pattern "past week" This isnt just an Ubuntu problem, it's platform wide. Looks like somebody did a booboo in the xorg that's currently smiting the Linux world. Fedora, OpenSuse, Mint, Ubuntu, etc. All talking about basically the same issue. The pointer isnt behaving correctly.

seph (seph) wrote :

I'm on a dell d600, and having this problem as well. I tried updating the the newer X packages in the edgers ppa, and though that includes the newer evdev, it did not fix the problem.

I also notice I'm having this problem both with evdev, and without evdev.

Can you test Lucid or Maverick and see if this bug is still present? Thanks!

affects: ubuntu → xorg (Ubuntu)
Changed in xorg (Ubuntu):
status: Confirmed → Incomplete
Bryce Harrington (bryce) on 2010-08-30
affects: xorg (Ubuntu) → xserver-xorg-input-evdev (Ubuntu)
Bryce Harrington (bryce) on 2010-08-30
tags: added: karmic
John Kerenyi (jkerenyi123) wrote :

I am pleased to report that this bug is completely resolved for me in Maverick. Thanks very much, it's nice to have my buttons back!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.