Ubuntu

device key_bitmask has changed

Reported by Steve Langasek on 2009-09-27
92
This bug affects 20 people
Affects Status Importance Assigned to Milestone
xserver-xorg-input-evdev (Ubuntu)
Medium
Peter Hutterer

Bug Description

Binary package hint: xserver-xorg-input-evdev

Today, with no immediate trigger I was able to discern, my keyboard became unresponsive shortly after I unlocked my screen. Xorg.0.log shows this:

  (EE) AT Translated Set 2 keyboard: device key_bitmask has changed
  (EE) AT Translated Set 2 keyboard: Device has changed - disabling.

That's really not a good reason to disable the main keyboard...

ProblemType: Bug
Architecture: amd64
Date: Sun Sep 27 15:15:20 2009
DistroRelease: Ubuntu 9.10
MachineType: LENOVO 6371CTO
Package: xserver-xorg-input-evdev 1:2.2.5-1ubuntu1
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: root=/dev/mapper/hostname-root ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-10.35-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu5
 libgl1-mesa-glx 7.6.0~git20090817.7c422387-0ubuntu5
 libdrm2 2.4.13-1ubuntu1
 xserver-xorg-video-intel 2:2.8.1-1ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090825.fc74e119-0ubuntu2
SourcePackage: xserver-xorg-input-evdev
Uname: Linux 2.6.31-10-generic x86_64
dmi.bios.date: 12/27/2006
dmi.bios.vendor: LENOVO
dmi.bios.version: 7IET23WW (1.04 )
dmi.board.name: 6371CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr7IET23WW(1.04):bd12/27/2006:svnLENOVO:pn6371CTO:pvrThinkPadT60:rvnLENOVO:rn6371CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 6371CTO
dmi.product.version: ThinkPad T60
dmi.sys.vendor: LENOVO
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: x86_64kernel: 2.6.31-10-generic

Steve Langasek (vorlon) wrote :
Changed in xserver-xorg-input-evdev (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Bryce Harrington (bryce) on 2009-10-09
tags: added: karmic
Kjell Braden (afflux) wrote :

Had the same symptoms immediately after VT switching:

(EE) AT Translated Set 2 keyboard: device key_bitmask has changed
(EE) AT Translated Set 2 keyboard: Device has changed - disabling.

Looks similar to bug 327175 though that one has been closed after they added a more descriptive error message (the key_bitmask one).

Dylan Smith (dylan-ah-smith) wrote :

I have also had the same symptoms, I stop receiving keyboard events in X after a VT switch, and I get the same errors in Xorg log. I started getting this bug when upgrading to karmic from jaunty, however, the live cd environment or a clean install in a separate partition isn't able to reproduce the bug.

The bug seems to depend on when gdm starts. For instance, if I let gdm start automatically like normal, then I will have the keyboard disabled in X on a VT switch. Logging out and logging back in will workaround the problem, and then I can do as much VT switching as I want without losing the keyboard. I can also completely avoid the bug by delaying gdm to start at rc.local, for instance by adding "initctl emit startdm" to my /etc/rc.local script and adding to "and startdm" to the "start on" upstart condition in /etc/init/gdm.conf.

The bug also only seems to affect my keyboard when plugged in as a PS/2 keyboard. I have a PS/2 to USB adaptor that lets me plug in the keyboard into a usb slot, and then I will not get this issue anymore.

I hope that helps.

Jens Gustedt (jens-gustedt) wrote :

Hello,
 the bug is also present here, very annoying. After hibernation
(which switches console) my X becomes unresponsive and I have to reboot.
Jens

Enrico Battocchi (lopo) wrote :

This happens to me too with Karmic on an Asus EeePC 1000H netbook : if I switch to VT (CTRL+ALT+F1) and then back to X (ALT+F7) then the netbook keyboard doesn't work anymore, unlike the USB keyboard which I also have. No problem with touchpad or USB mouse.

By the end of Xorg.0.log, after three switch-to-VT-then-back-to-X's, I found the attached lines. As you can see, there is always a series of "reopening" of the devices, but while all the others succeed, the builtin keyboard fails:

(--) ETPS/2 Elantech Touchpad: touchpad found
(II) Asus EeePC extra buttons: Device reopened after 1 attempts.
(II) Power Button: Device reopened after 1 attempts.
(II) Video Bus: Device reopened after 1 attempts.
(II) USB Keyboard: Device reopened after 1 attempts.
(II) USB Keyboard: Device reopened after 1 attempts.
(II) Sleep Button: Device reopened after 1 attempts.
(II) Power Button: Device reopened after 1 attempts.
(EE) AT Translated Set 2 keyboard: device key_bitmask has changed
(EE) AT Translated Set 2 keyboard: Device has changed - disabling.
(II) Macintosh mouse button emulation: Device reopened after 1 attempts.
(II) Logitech Optical USB Mouse: Device reopened after 1 attempts.

Enrico Battocchi (lopo) wrote :

I confirm also that this seems to be happening only when you are in X for the first time since booting the PC: after the above problems, I quit the session, gdm restarts, I can type the password with the netbook keyboard, then if I switch to VT and then back to X, the same keyboard now works like a charm, and Xorg.0.log now displays these lines instead of those above:

(--) ETPS/2 Elantech Touchpad: touchpad found
(II) Asus EeePC extra buttons: Device reopened after 1 attempts.
(II) Power Button: Device reopened after 1 attempts.
(II) Video Bus: Device reopened after 1 attempts.
(II) USB Keyboard: Device reopened after 1 attempts.
(II) USB Keyboard: Device reopened after 1 attempts.
(II) Sleep Button: Device reopened after 1 attempts.
(II) Power Button: Device reopened after 1 attempts.
(II) AT Translated Set 2 keyboard: Device reopened after 1 attempts.
(II) Macintosh mouse button emulation: Device reopened after 1 attempts.
(II) Logitech Optical USB Mouse: Device reopened after 1 attempts.

As you can see, now there's no "device key_bitmask has changed" and "Device has changed - disabling."

Hope this helps whomever the bug will be assigned to.

atany (ye-gorshkov) wrote :

I confirm this on Karmic, Dell XPS M1330.

It was constantly happening to me on Jaunty too up until the latest updates (I did not report the bug then because I was running kernel from mainline-ppa). I have found a workaroud: switchkerboard to raw mode with magic sysrq key in order to switch to console, login, restart hal, switch back to X and put keyboard back into normal mode with "kbd_mode -s"

Unfortunately, this workaround no longer helps on fresh Karmic install with the latest updates.

There is another similar bug https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-evdev/+bug/327175
which is marked as fixed.

Tony Lill (ajlill) wrote :

I was thinking about Dylan Smith's comment that this seems to be dependent on when gdm starts, and I realized that this problem seemed to go away for me when I got my wireless networking sorted out to start automatically on boot, and it just bit me again when when I booted up in an unfamiliar wireless hotspot, and had to start the network manually after I logged in. Might be co-incidence.

Christian Ramseier (cramseier) wrote :

The latest available version of evdev still contains the code producing the bug (http://cgit.freedesktop.org/xorg/driver/xf86-input-evdev / Version 2.3.2).

However, in this discussion on the xorg mailinglist, the upstream developers are talking about a patch that will be merged in before 2.4.0. See this post and follow-ups for more details: http://lists.x.org/archives/xorg-devel/2009-October/002919.html

Christian Ramseier (cramseier) wrote :

Just compiled and tested the latest nightly-build of xf86-input-evdev from their git repository - suspending works like a charm now ;) Hope the new version will be available in the Ubuntu repositories soon...

Changed in xserver-xorg-input-evdev (Ubuntu):
assignee: nobody → Peter Hutterer (peter-hutterer)

this should have been fixed in the following commit (evdev 2.3.1 is the
first one to contain this one)

commit 175af93bdb5928236e5c402a77d164313497d72a
Author: Dmitry Torokhov <email address hidden>
Date: Mon Nov 2 23:11:55 2009 -0800

    Relax checks when reopening devices

Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi Steve,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 437862

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 437862 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/437862

Changed in xserver-xorg-input-evdev (Ubuntu):
status: Triaged → Incomplete
tags: added: needs-retested-on-lucid-by-june
Robert Hooker (sarvatt) wrote :

evdev 2.3.2 with the fix is in both lucid and maverick, please reopen this bug if you can still reproduce it.

Changed in xserver-xorg-input-evdev (Ubuntu):
status: Incomplete → Fix Released
D (dj-lp) wrote :

ok, that was easy, I just applied the patch to karmic's version. try this if you're still in karmic as I am...
http://drop.io/tkzi7vp/asset/xserver-xorg-input-evdev-2-2-5-1ubuntu6-i386-linuxtipps2-deb

To post a comment you must log in.