Wrong keyboard settings are restored after resume

Bug #372612 reported by Martin Pohlack on 2009-05-06
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
xserver-xorg-input-evdev (Ubuntu)
Undecided
Unassigned

Bug Description

I use a custom script for configuring my keyboard layout on login in order to have a portable solution on all machines and desktop systems (kde, gnome, ...):
.xprofile
----------------------------------------------------------------------
...
    setxkbmap -layout de -model pc105 -variant "nodeadkeys" -option "ctrl:nocaps,compose:rwin,alt_win:menu"
    xkbset m || true
    xmodmap -e "keysym Menu = Pointer_Button2" || true
...
----------------------------------------------------------------------

Essentially, CapsLock is modified to be an additional control key and the right menu key is my middle mouse button (as my laptop lacks this button).

I call .xprofile from my .profile if $DISPLAY is set sufficiently.

Problem is, that after "resume from ram" the keyboard is restored to default settings *sometimes*.

I expect the xkb state of the X server to be preserved across suspend / resume cycles.

I have the strong suspicion that the bug is triggered by delayed USB recognition in my docking station. I could create a similar reset by unplugging my external keyboard and replugging it. Is there a way to prevent this magic from happening?

$ lsb_release -rd
Description: Ubuntu 9.04
Release: 9.04

All packages are current.

Maybe related to bugs #287215 and #295990.

Scott Howard (showard314) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage. I have classified this bug as a bug in xserver-xorg-input-evdev.
For future reference you might be interested to know that a lot of applications have bug reporting functionality built in to them. This can be accessed via the Report a Problem option in the Help menu for the application with which you are having an issue. You can learn more about this feature at https://wiki.ubuntu.com/ReportingBugs.

affects: ubuntu → xserver-xorg-input-evdev (Ubuntu)
Bryce Harrington (bryce) on 2009-09-02
tags: added: jaunty

This gets me most often when I "switch user" to my wife's acct; when I come back my customizations are gone. I also see it when I CTRL-ALT-F3 to get to a tty. Problem didn't exist in intrepid, first showed up in jaunty, still present in karmic.

Oliver Joos (oliver-joos) wrote :

I have the same problem. And I found, how to reproduce this effect with Karmic and an external keyboard. I am not sure, if it's the same bug. But some keyboards might try to hold delay/rate settings, and loose them if sleep-resume takes too long or something. This would explain why *sometimes* they are lost after a resume.

To reproduce reliably:
1 start gnome-keyboard-properties and set a low keyboard delay
2 test it in a gnome-terminal
3 unplug and re-plug your external keyboard
4 test it again in the gnome-terminal
=> internal keyb is unchanged, external keyb delay is reset to default!

What I would expect:
Whenever a keyboard is detected (after resume, plug-in, ...) keyboard delay and rate should be reestablished.

Oliver Joos (oliver-joos) wrote :

I am not sure if my comment above targets the same issue as this bug. This bug is about wrong settings after RESUME. If unplug and re-plug the keyboard does also trigger this bug, then my previous comment is valid and we could mark this bug as duplicate of Bug #427168.

Oliver Joos (oliver-joos) wrote :

Now it's clear: this bug is *not* a duplicate of bug #427168. This one is about key binding being reset, 427168 is about keyboard rate/delay being reset.

The same confusion was on gnome.org while discussing both fixes (https://bugzilla.gnome.org/show_bug.cgi?id=610245). Meanwhile chances are good that this bug is also fixed in latest Lucid daily build. So please check and comment if you are affected.

Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi Martin,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 372612

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 372612 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/372612

Changed in xserver-xorg-input-evdev (Ubuntu):
status: New → Incomplete
tags: added: needs-retested-on-lucid-by-june
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.