[Jaunty] X.Org repeatedly report "press and release" while I'm holding a key

Bug #369880 reported by Jonas Alves on 2009-04-30
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xserver-xorg-input-evdev (Ubuntu)

Bug Description

Ubuntu 9.04 (Jaunty) and 9.10 (Karmic)

My javascript application (http://www.stopwatch.com.br/) triggers a function when the spacebar is RELEASED (onKeyUp).
It does work as expected in Intrepid Ibex (8.10) and Windows Vista, both running the latest Firefox 3.5 release.


What I expected to happen:
It should trigger the onKeyUp event only when I RELEASE the spacebar.

What happened instead:
Under Jaunty and Karmic, that onKeyUp event is triggered repeteadly while i'm HOLDING the spacebar...

Jonas Alves (jonasfa) on 2009-05-05
Changed in ubuntu:
status: New → Confirmed
bobince (bobince) wrote :

Occurs for me too, both under Jaunty i386 Firefox 3.0 and Karmic beta amd64 Firefox 3.5.

Doesn't happen under Windows with Firefox 3.0 or 3.5, or under Slax with Firefox 3.5 and KDE 3.5: maybe it's a GNOME problem. I'm running a UK keyboard layout with no IME (on Karmic ibus is installed, but not running) and no xorg.conf.

See http://unixpapa.com/js/testkey.html for a test case. When a non-shifting key is held, Firefox produces:


Most other browsers produce:


(Some produce:


but this is a well-known variation which is easily coded around. The current Firefox behaviour, on the other hand, cannot be worked around as the key event stream is indistinguishable from a user hammering repeatedly on the key. This breaks in-browser games quite badly.

Judging by this post:


The same problem may be visible from Flash.

bobince (bobince) wrote :

Chromium uses GTK+ and produces the same misbehaviour. Opera and Konqueror don't. Firefox on KDE-based distros doesn't.

It appears that GTK+ may be to blame.

bobince (bobince) wrote :

The problem appears to be quite widespread in Flash games. Some discussion at http://ubuntuforums.org/showthread.php?t=1304066

Kamus (kamus) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage , so I have classified this bug as a bug in firefox package.

affects: ubuntu → firefox (Ubuntu)
Micah Gersten (micahg) wrote :

Moving to Firefox 3.0 for triage. Does this occur with Firefox 3.5 as well?

affects: firefox (Ubuntu) → firefox-3.0 (Ubuntu)
Jonas Alves (jonasfa) wrote :

Yes, it still occurs in Firefox 3.5.
It also affects other browsers, such as Google Chrome.

Jonas Alves (jonasfa) wrote :

Removing "firefox" from the package field, since the problem affects many browsers.

affects: firefox-3.0 (Ubuntu) → ubuntu
Jonas Alves (jonasfa) wrote :

This issue still occurs in the most recent Ubuntu release, Karmic Koala.

description: updated
Jonas Alves (jonasfa) on 2010-01-05
affects: ubuntu → xorg (Ubuntu)
Bryce Harrington (bryce) on 2010-01-06
affects: xorg (Ubuntu) → xserver-xorg-input-evdev (Ubuntu)
Jonas Alves (jonasfa) on 2010-01-06
tags: added: gtk karmic
Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi Jonas,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:


If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 369880

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 369880 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:


Changed in xserver-xorg-input-evdev (Ubuntu):
status: Confirmed → Incomplete
tags: added: needs-retested-on-lucid-by-june
Jonas Alves (jonasfa) wrote :

Hello Bryce Harrington,

This issue doesn't occurs in Lucid.
In Lucid, the onKeyUp event works as expected.

Thank you.

bobince (bobince) on 2010-07-26
Changed in xserver-xorg-input-evdev (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers