3Dconnexcion SpacePilot works like a mouse (TrackPoint in laptop)

Bug #297264 reported by kwant on 2008-11-12
8
Affects Status Importance Assigned to Milestone
xserver-xorg-input-evdev (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xorg

After connection SpacePilot it starts to act as a mouse (TrackPoint), however, it souldn't. SpacePilot is automatically recognized as a mouse. There is no any configuration in /etc/xorg.conf (see Attachment), however found the following line in /var/log/Xorg.0.log (see Attachment):

(II) config/hal: Adding input device 3Dconnexion SpacePilot
(**) 3Dconnexion SpacePilot: always reports core events
(**) 3Dconnexion SpacePilot: Device: "/dev/input/event6"
(II) 3Dconnexion SpacePilot: Found x and y relative axes
(II) 3Dconnexion SpacePilot: Found 21 mouse buttons
(II) 3Dconnexion SpacePilot: Configuring as mouse
(II) XINPUT: Adding extended input device "3Dconnexion
SpacePilot" (type: MOUSE)
(**) 3Dconnexion SpacePilot: YAxisMapping: buttons 4 and 5
(**) 3Dconnexion SpacePilot: EmulateWheelButton: 4, EmulateWheelInertia:
10, EmulateWheelTimeout: 200
(WW) 3Dconnexion SpacePilot: unable to handle keycode 265

I suspect, HAL did it, see Attachment (lshal.txt). Since I'm using spacenavd from http://spacenav.sourceforge.net/, SpacePilot can't be configured in my X server - see FAQ: http://spacenav.sourceforge.net/faq.html.

How can I condigure 3Dconnexion SpacePilot in order to xorg ignore it???

Kwant!
[lspci]
00:00.0 Host bridge [0600]: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub [8086:2a00] (rev 0c)
     Subsystem: Lenovo Device [17aa:20b1]
01:00.0 VGA compatible controller [0300]: nVidia Corporation Quadro NVS 140M [10de:0429] (rev a1)
     Subsystem: Lenovo Device [17aa:20d8]

kwant (kwant) wrote :
kwant (kwant) wrote :
kwant (kwant) wrote :
Bryce Harrington (bryce) wrote :

[This is an automated message]

Hi kwant,

Please attach the output of `lspci -vvnn` too.

Changed in xserver-xorg-input-evdev:
status: New → Incomplete
kwant (kwant) wrote :
kwant (kwant) wrote :

Hi!

With the help of X.org mailing list (thanks for Dan Nicholson!!!) the problem has been resolved. One should add the following file to the system and restart HAL.

$cat /etc/hal/fdi/policy/no-3dconnexion-trackpoint.fdi
<?xml version="1.0" encoding="ISO-8859-1"?>
<deviceinfo version="0.2">
        <device>
                <match key="info.product" contains="3Dconnexion">
                        <remove key="input.x11_driver"/>
                </match>
        </device>
</deviceinfo>

After that, SpacePilot is ignored by X server (not used as a TrackPoint), however, it works with spacenavd driver. I didn't test it with the proprietary driver deliver by 3dconnexion.com.

Kwant!

Bryce Harrington (bryce) wrote :

Thanks for following up!

Changed in xserver-xorg-input-evdev:
importance: Undecided → Medium
status: Incomplete → In Progress
Bryce Harrington (bryce) on 2009-01-17
description: updated
Florian Boesch (pyalot) wrote :

I have the same problem. However I use this device via evdev, please do not break evdev while fixing this bug.

Henri Tuhola (henri-tuhola) wrote :

I also have this with my spacenavigator.

Henri Tuhola (henri-tuhola) wrote :

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-evdev/+bug/297264/comments/6 Didn't pretty much helped me. After adding that file I restarted my machine, but xorg still doesn't let go off from my dev.

Henri Tuhola (henri-tuhola) wrote :

Ignore the last message, I got it to work with the second try. I assume it was me that did something wrong.

Silly question (I'm trying to get a SpaceNavigator to work with Ubuntu 8.10 and Second Life on an AMD64 platform)

Can someone explain the workaround in newbie terms. (Also - does it work in a vanilla 8.04? Only running 8.10 as 9.04 had boot errors on my system so happy to run the LTS version).

Where do I add the code (I presume somewhere in xorg.conf?)

$cat /etc/hal/fdi/policy/no-3dconnexion-trackpoint.fdi
<?xml version="1.0" encoding="ISO-8859-1"?>
<deviceinfo version="0.2">
        <device>
                <match key="info.product" contains="3Dconnexion">
                        <remove key="input.x11_driver"/>
                </match>
        </device>
</deviceinfo>

( a similar issue refers to the 2nd Jan post here http://www.fox-toolkit.org/ not sure how/if it relates )

thanks in advance and apologies again for my ignorance!

Dnia 2009-08-19, śro o godzinie 09:48 +0000, Chris Francis pisze:
> Silly question (I'm trying to get a SpaceNavigator to work with Ubuntu
> 8.10 and Second Life on an AMD64 platform)
>
> Can someone explain the workaround in newbie terms. (Also - does it work
> in a vanilla 8.04? Only running 8.10 as 9.04 had boot errors on my
> system so happy to run the LTS version).
>
> Where do I add the code (I presume somewhere in xorg.conf?)
>
> $cat /etc/hal/fdi/policy/no-3dconnexion-trackpoint.fdi
> <?xml version="1.0" encoding="ISO-8859-1"?>
> <deviceinfo version="0.2">
> <device>
> <match key="info.product" contains="3Dconnexion">
> <remove key="input.x11_driver"/>
> </match>
> </device>
> </deviceinfo>
>
> ( a similar issue refers to the 2nd Jan post here http://www.fox-
> toolkit.org/ not sure how/if it relates )
>
> thanks in advance and apologies again for my ignorance!

Hi!

Create file
/etc/hal/fdi/policy/no-3dconnexion-trackpoint.fdi
and put the following lines into this file.

<?xml version="1.0" encoding="ISO-8859-1"?>
<deviceinfo version="0.2">
        <device>
                <match key="info.product" contains="3Dconnexion">
                        <remove key="input.x11_driver"/>
                </match>
        </device>
</deviceinfo>

After xorg restart it stop treat SpacePilot as a TrackPoint, however, I
don't known is it sufficient to get work SpaceNavigator with Second
Life.

Kwant!

Thanks Kwant - that's fixed it. Now works perfectly.

(Well after I found the enable spacenavigator check box in the application!)

Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi kwant,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 297264

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 297264 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/297264

Changed in xserver-xorg-input-evdev (Ubuntu):
status: In Progress → Incomplete
tags: added: needs-retested-on-lucid-by-june
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xserver-xorg-input-evdev (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers