middle-button scroll disabled on trackpoint

Bug #292047 reported by Robert Persson on 2008-11-01
50
This bug affects 5 people
Affects Status Importance Assigned to Milestone
xserver-xorg-input-evdev (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg

My hardware is a Thinkpad R61i with the touchpad disabled in bios settings so that the trackpoint is the primary pointer device.

I had middle-button scrolling working in Hardy after following the instructions at http://www.thinkwiki.org/wiki/How_to_configure_the_TrackPoint on modifying your xorg.conf. On upgrading to Intrepid this stopped working. I found that the mouse section I had added had been commented out, but uncommenting it did not restore the middle-button scroll.

What ought to happen, of course, is that the trackpoint should be configured correctly automatically without user intervention. Failing that, there should be a way to fix this simply from the GUI. As an absolute last resort, there should be some simple instructions somewhere on how to make sure that changes you make to xorg.conf in the current version of X11 are not ignored.

Elias K Gardner (zorkerz) wrote :

Yes this is a problem thanks for taking the time to report it. I thought there was another bug to the same effect as this but I am now unable to find it. It would be optimal if by default middle-button scrolling was turned on for thinkpads. I also would like to learn a new workaround for this as it has been an issue for a long time and does not seem to be likely to get attention.

Changed in xorg:
status: New → Confirmed
Robert Persson (ireneshusband) wrote :

The most simple workaround would be simply to know what to paste into xorg.conf to get this working. I would have done this already except that I am confused by the changes to the way X configures itself with automatic hardware detection.chaumont-gistoux

In the past I edited my xorg.conf file an discussed on the thinkwiki site
http://www.thinkwiki.org/wiki/How_to_configure_the_TrackPoint

My understanding is that with the release of intrepid the xorg.conf file is
nearly unused. I don't know if this means that you can no longer edit
xorg.conf as in the past. When I get time I will try and see if it works.

My last comment ends bizarrely with the name of a place in Belgium. This is due to a cut-and-paste error. Sorry.

Elias K Gardner (zorkerz) wrote :

Sorry for the clutter.
I was rereading the thinkwiki page from above and noticed that it now has a section at the bottom for scrolling in intrepid. I have just tested both the old xorg.conf workaround and the newly posted intrepid one and did not get either to work.

VS (storvann) wrote :

http://www.thinkwiki.org/wiki/How_to_configure_the_TrackPoint#TrackPoint_under_Ubuntu_8.10_using_HAL works for me (you may have to modify the <match key="info.product" string="TPPS/2 IBM TrackPoint"> line so that it matches your laptop's trackpoint)v

Robert Persson (ireneshusband) wrote :

The above solution worked for me for a few days, but now it's broken again. I'm presuming a package upgrade did it because I haven't changed anything else to my knowledge. Have rebooted since, but still not working.

David Jaša (dejv) wrote :

Copy & paste from dupe:

My Ubuntu Intrepid installation recognizes correctly trackpoint, but sets option "EmulateWheelButton" to non-existing button 4:

(II) config/hal: Adding input device TPPS/2 IBM TrackPoint
(**) TPPS/2 IBM TrackPoint: always reports core events
(**) TPPS/2 IBM TrackPoint: Device: "/dev/input/event10"
(II) TPPS/2 IBM TrackPoint: Found x and y relative axes
(II) TPPS/2 IBM TrackPoint: Found 3 mouse buttons
(II) TPPS/2 IBM TrackPoint: Configuring as mouse
(II) XINPUT: Adding extended input device "TPPS/2 IBM TrackPoint" (type: MOUSE)
(**) TPPS/2 IBM TrackPoint: YAxisMapping: buttons 4 and 5
(**) TPPS/2 IBM TrackPoint: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200

It can be easily corrected by this piece of xml in /etc/hal/fdi/policy/:

<?xml version="1.0" encoding="UTF-8"?>
<deviceinfo version="0.2">
  <device>
    <match key="info.product" string="TPPS/2 IBM TrackPoint">
      <merge key="input.x11_options.EmulateWheel" type="string">true</merge>
      <merge key="input.x11_options.EmulateWheelButton" type="string">2</merge>
      <merge key="input.x11_options.ZAxsisMapping" type="string">4 5</merge>
      <merge key="input.x11_options.Emulate3Buttons" type="string">true</merge>
    </match>
  </device>
</deviceinfo>

And Xorg.0.log then reports:

(II) config/hal: Adding input device TPPS/2 IBM TrackPoint
(**) TPPS/2 IBM TrackPoint: always reports core events
(**) TPPS/2 IBM TrackPoint: Device: "/dev/input/event10"
(II) TPPS/2 IBM TrackPoint: Found x and y relative axes
(II) TPPS/2 IBM TrackPoint: Found 3 mouse buttons
(II) TPPS/2 IBM TrackPoint: Configuring as mouse
(II) XINPUT: Adding extended input device "TPPS/2 IBM TrackPoint" (type: MOUSE)
(**) Option "Emulate3Buttons" "true"
(II) TPPS/2 IBM TrackPoint: Forcing middle mouse button emulation.
(**) Option "EmulateWheel" "true"
(**) Option "EmulateWheelButton" "2"
(**) TPPS/2 IBM TrackPoint: YAxisMapping: buttons 4 and 5
(**) TPPS/2 IBM TrackPoint: EmulateWheelButton: 2, EmulateWheelInertia: 10, EmulateWheelTimeout: 200

Robert Persson (ireneshusband) wrote :

I said a few comments back that the the solution from thinkwiki worked for a while and then stopped working, but it now looks more complicated than that. Middle button scrolling seems to come and go. I'm not yet sure what triggers this, but I think it might have something to do with suspend-resume cycles.

VS (storvann) wrote :

Suspend/resume is known to break scrollwheel emulation, have a look here: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-evdev/+bug/282387

Elias K Gardner (zorkerz) wrote :

@ Vegar -> above you mentioned the <match key="info.product" string="TPPS/2 IBM TrackPoint"> line must match my laptop's trackpoint.

How do I know what my laptop's trackpoint is?

VS (storvann) wrote :

Elias: run 'xinput list --short' and see if you can find it in the list.
On my laptop the trackpoint line looks like this:

"TPPS/2 IBM TrackPoint" id=3 [XExtensionPointer]

You want the string inside the quotation marks.

Thanks unfortunately it appears my string is correct as is but scrolling
does not work.

here is the output of 'xinput list --short'

"Virtual core keyboard" id=0 [XKeyboard]
"Virtual core pointer" id=1 [XPointer]
"Macintosh mouse button emulation" id=2 [XExtensionPointer]
"TPPS/2 IBM TrackPoint" id=3 [XExtensionPointer]
"AT Translated Set 2 keyboard" id=4 [XExtensionKeyboard]
"Video Bus" id=5 [XExtensionKeyboard]

It does not work for me, either - but the properties are set:

hanno@sputnik2:~$ xinput list-props 3
Device 'TPPS/2 IBM TrackPoint':
 Device Enabled: 1
 Middle Button Emulation: 1
 Middle Button Timeout: 50
 Wheel Emulation Inertia: 10
 Wheel Emulation: 1
 Wheel Emulation X Axis: 6, 7
 Wheel Emulation Y Axis: 4, 5
 Wheel Emulation Timeout: 200
 Wheel Emulation Button: 2
 Drag Lock Buttons: 0

FYI: I am running 8.10 amd64 edition. I am already using the fdi file approach as mentioned above and as you see the properties are set. Evdev seems to ignore them. Might this be a 64bit only problem?

Well I'm running this on a 64-bit system. Then again, how long have these
devices been around? Is anyone actually using one on a 32-bit machine?

Elias K Gardner (zorkerz) wrote :

Im running 64 bit intrepid and also have been unable to make this work. My
impression is that most people are running 32 bit os variants even if they
have 64 bit cpu architecture.

Trackpoint scrolling works with the 32 bit Version of Intrepid. However the same setup with amd64 fails.

Lars Volker (lv) wrote :

I can confirm, that the offered solution does not work on Intrepid amd64.

The issue regarding 64 bit systems seems to have been fixed with the latest kernel updates.
Not sure whether the fdi file is still needed.

Can somebody else confirm that trackpoint scrolling is now working on 64 bit system with the above mentioned fix in place?

What kernel updates are you referring to?

My updated 8.10 installation is not scrolling with the fdi file in place, I
can't restart now so have not tried without the file. Im running a 64bit
jaunty guest in virtualbox and it does not scroll with or without the fdi
file although I suppose this could be due to virtualbox.

Elias K Gardner schrieb:
> What kernel updates are you referring to?

The updates from the intrepid-updates repository. (aka "recommended
updates")

hanno@sputnik2:~$ uname -a
Linux sputnik2 2.6.27-11-generic #1 SMP Thu Jan 29 19:28:32 UTC 2009
x86_64 GNU/Linux

> My updated 8.10 installation is not scrolling with the fdi file in place, I
> can't restart now so have not tried without the file.

Ok. Then I don't know why it suddenly works for me... I had
intrepid-proposed enabled some time ago because of standby issues. But
my kernel is from the normal updates.
Maybe I have some other libs still in a newer version from proposed.

Scrolling in virtualized environments is dependent on the virtual
hardare and how the virtualization environment translates events from
the host system.
Example: With VMWare Workstation I have scrolling via wheel on an
external mouse under Ubuntu and XP as a host with XP as guest, however
scrolling via touchpad only works using Ubuntu as host.
(But this is an entirely different topic not related to this bug...)

Greetings,

Hanno

It stopped working for me again. I don't know what caused it to work for some time.

I tested the version from jaunty and it seems to work there. (I backported xserver-xorg-input-evdev - however it leads to instabilities, so this is not a solution.) Can somebody confirm with a Live-CD?

However I could not find a single commit upstream that specifically addresses the issue. Upstream log can be found here: http://cgit.freedesktop.org/xorg/driver/xf86-input-evdev/log/?h=evdev-2.1-branch

Maybe a temporary solution is described here: https://bugs.freedesktop.org/show_bug.cgi?id=4147#c13

I have found the problem with the backported version of the evdev driver and fixed it. You can download the updated driver
from my ppa (https://launchpad.net/~hanno-stock/+archive/ppa).
I also have attached a bzr branch with my changes.

Note: This is a backported driver from Jaunty. You should only install it if you need the added functionality as it might introduce other issues. However it runs fine on my amd64 Intrepid system so far.

(You might still need the .fdi file mentioned above.)

Antti P Miettinen (apm) wrote :

I've been fighting with disabling touchpad and making middle button scrolling work on my Dell Latitude E4300 for a couple of days now. One problem for me was the fact that sometimes the kernel mouse driver lost sync:

psmouse.c: DualPoint TouchPad at isa0060/serio1/input0 lost sync at byte 1

This caused the pointer devices to dissappear and reappear with different names, e.g. "PS/2 Generic Mouse", "DualPoint Stick", "AlpsPS/2 ALPS DualPoint TouchPad", "PS/2 ALPS DualPoint TouchPad" and the mouse pointer occasionally jumping around when I accidentally touched the touchpad while typing. The sync problem got apparently cured for me with this: http://lkml.org/lkml/2008/12/8/182

A reliable way to cause sync errors for me is to keep moving the pointer with the pointing stick and simultaneously keep tapping the touchpad.

I'm running 64 bit Intrepid.

@Antti: This seems like an entirely different bug to me. Could you please file a new bug against the "linux" package?

Antti P Miettinen (apm) wrote :

Additionally, I still lose middle button scroll/mouse wheel emulation even with the mentioned patch applied :-(

Yes - seems that the root cause of the middle button issue is different.

Antti P Miettinen (apm) wrote :

There is a bug against "linux" where the ALPS kernel patch is mentioned: https://bugs.launchpad.net/ubuntu/+bug/296610

Robert Persson (ireneshusband) wrote :

Hanno's backported driver works for me too. Thanks, Hanno :)

Elias K Gardner (zorkerz) wrote :

As an update making the .fdi file from these directions http://www.thinkwiki.org/wiki/How_to_configure_the_TrackPoint#TrackPoint_under_Ubuntu_8.10_using_HAL also linked above han worked for me in Jaunty beta x86-64. Is there any chance it works without the .fdi file on a fresh install? That seems to be the ideal solution where third-mouse button scrolling is enabled by default on a new install. What would it take to have that happen in future releases?

Benjamin von Engelhardt (bve) wrote :

Is it a bug that one has to disable the touchpad to get trackpoint scrolling? For me, it looks like that because I do not see any reason for that behaviour. Should I open a new bug? The heading seems to fit, though. This seems to be the case for all system, but I'm running ubuntu jaunty on a Lenovo X300, with amd64 and I tried to enable it through hal.

$ xinput list-props 6
Device 'DualPoint Stick':
        Device Enabled (109): 1
        Evdev Axis Inversion (247): 0, 0
        Evdev Reopen Attempts (244): 10
        Evdev Axis Calibration (245):
        Evdev Axes Swap (246): 0
        Evdev Middle Button Emulation (248): 1
        Evdev Middle Button Timeout (249): 50
        Evdev Wheel Emulation (250): 1
        Evdev Wheel Emulation Axes (251): 6, 7, 4, 5
        Evdev Wheel Emulation Inertia (252): 10
        Evdev Wheel Emulation Timeout (253): 200
        Evdev Wheel Emulation Button (254): 2
        Evdev Drag Lock Buttons (255): 0

I don't know if thats related or not. I don't have a trackpad and scrolling
is not enabled by default.

Bryce Harrington (bryce) on 2009-09-02
tags: added: intrepid
Hao Wen (wenhao) wrote :

I also had this problem. Here is my condition:
1. Ubuntu 9.04;
2. Try to follow the instruction here: http://www.thinkwiki.org/wiki/How_to_configure_the_TrackPoint
3. Followed the Gnome set up routine.
4. Installed configure-trackpoint;

However, when I try to run it, it reports the error:
TrackPoint is not detected. Please checkk your kernel and TrackPoint driver.

Benjamin von Engelhardt (bve) wrote :

I think this is fixed with kernel 2.6.30 (from karmic) - no need to disable the touchpad any more. Now I can scroll with the middle-button and the trackpoint.

Hao Wen (wenhao) wrote :

bve, do you still have to follow the hal routine to make it work?
I will wait until the official release of Karmic though.

Elias K Gardner (zorkerz) wrote :

I can not scroll with the middle mouse button in karmic and I have not tried
to follow the thinkwiki procedure since installing karmic.

Benjamin von Engelhardt (bve) wrote :

@hao (#35): Yes, I think you have to add the hal-thing. I just updated to the karmic-kernel on jaunty, so my hal-rules didn't change and I had added it before. Find out with xinput how the trackpoint is called and add the appropriate hal-rule (it's not calle IBM...). I assume the missing hal-rule is the reason for comment #36 too.

David Jaša (dejv) wrote :

This .fdi file in /etc/hal/fdi/policy/ works for me including horizontal scrolling. It survives resume from suspend/hibernation OK.

Please, add this configuration to Lucid Lynx so it can be tested during its development and eventually shipped!

David Jaša (dejv) wrote :
Alan LaMielle (alan.lamielle) wrote :

I've been using an fdi file that is very similar in Karmic and noted the workaround on my blog: http://alan.lamielle.net/2009/10/07/thinkpad-trackpoint-scrolling-in-ubuntu-karmic-koala It's worked for me since Jaunty and continues to work in Karmic. Consider this a second for including a similar fdi file in Lucid.

Timo Aaltonen (tjaalton) wrote :

You can just use gpointing-device-settings to set the feature. Not a driver bug.

Changed in xserver-xorg-input-evdev (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.