Emulate3Buttons is enabled by default

Bug #291694 reported by Medar on 2008-10-31
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xserver-xorg-input-evdev (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-input-evdev

Currently Emulate3Buttons seems to be always enabled in Ubuntu's default configuration, even if the mouse has 3 or more buttons. This is especially painful because as far as I know there is no way to change the setting on runtime, so only way is to manually add InputDevice section to xorg.conf and include Emulate3Buttons option there.

Looking at the code the problem seems to be that emulate setting is set to AUTO, but it works exactly like ENABLED. That is because EvdevMBEmuEnable is never called. It should probably be called when middle mouse button is pressed or maybe when more than 2 buttons have been detected.
[lspci]
00:00.0 Host bridge [0600]: Intel Corporation 82P965/G965 Memory Controller Hub [8086:29a0] (rev 02)
     Subsystem: Intel Corporation 82P965/G965 Memory Controller Hub [8086:29a0]
01:00.0 VGA compatible controller [0300]: nVidia Corporation G70 [GeForce 7600 GT] [10de:0391] (rev a1)
     Subsystem: Micro-Star International Co., Ltd. Device [1462:7235]

Revision history for this message
Bryce Harrington (bryce) wrote :

Hi pekka-lampila,

Please attach the output of `lspci -vvnn`, and attach your /var/log/Xorg.0.log file from after reproducing this issue. If you've made any customizations to your /etc/X11/xorg.conf please attach that as well.

Changed in xserver-xorg-input-evdev:
status: New → Incomplete
Revision history for this message
Medar (pekka-lampila-deactivatedaccount) wrote :
Revision history for this message
Medar (pekka-lampila-deactivatedaccount) wrote :
Revision history for this message
Medar (pekka-lampila-deactivatedaccount) wrote :

My xorg.conf shouldn't have anything to do with this bug, there is no mouse options present, but here it is anyway.

Revision history for this message
Medar (pekka-lampila-deactivatedaccount) wrote :

Still a problem in jaunty with xserver-xorg-input-evdev (1:2.1.0-0ubuntu1)

Carey Underwood (cwillu) on 2009-01-04
Changed in xserver-xorg-input-evdev:
status: Incomplete → New
Bryce Harrington (bryce) on 2009-01-09
Changed in xserver-xorg-input-evdev:
status: New → Confirmed
Bryce Harrington (bryce) on 2009-01-23
description: updated
Revision history for this message
Paul Bransford (draeath) wrote :

This may be related. Should I file this separately?

This is on intrepid.

It appears that, when multiple mice are configured, Emulate3Buttons is not respected if you set it false - meaning that all my mice behave as if it was true, regardless of my override.

Please see my attached xorg.conf - and note that both the internal mouse (Mouse0) and my external (Mouse1) behave as if Emulate3Buttons is true. This xorg.conf is based off of "Xorg -configure"

Revision history for this message
sub.mesa (sub-mesa) wrote :

It's enabled by default, the way to shut it off has changed and the old method no longer works. So if anyone needs to disable this 'feature' - it likely requires hours of their time googling to fix it. Very smart move!

To fix this issue:

sudo nano /etc/hal/fdi/policy/disable-emulate3buttons.fdi

and enter:

<?xml version="1.0" encoding="ISO-8859-1"?>
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.mouse">
        <merge key="input.x11_driver" type="string">mouse</merge>
        <merge key="input.x11_options.Emulate3Buttons" type="string">no</merge>
        <merge key="input.x11_options.ZAxisMapping" type="integer">4 5</merge>
    </match>
  </device>
</deviceinfo>

It requires a reboot or logout/login to activate. After activating, Ubuntu users playing World of Warcraft can finally move their character forward again! Hurray.

Devs: do you think making this silly option on by default is wise? Do you think its easy for your users to turn it off? I've had a look at the mouse options in the System > Preferences menu, and it has shitloads of useless options. Not adding this option to the existing GUI is a profound mistake. Many users may think its a wine bug and have to rely on keyboard input instead. FIX THIS.

Revision history for this message
sub.mesa (sub-mesa) wrote :

Hm this bug still appears to be prevalent for those using a KVM switch. After i switch to another pc and back again, it appears the Emulate3Buttons feature is turned on again, even with the .fdi file present. Apparantly the fdi file is a one-time configuration and whenever a device disconnects and connects again, it doesn't get used. The only fix would be hacking the sourcecode and recompiling a custom Xorg.

This is really starting to get on my nerves. Its the only reason World of Warcraft doesn't work well on Ubuntu, and its not even Wine's fault...

Revision history for this message
Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi Medar,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 291694

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 291694 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/291694

Changed in xserver-xorg-input-evdev (Ubuntu):
status: Confirmed → Incomplete
tags: added: needs-retested-on-lucid-by-june
Revision history for this message
Medar (pekka-lampila-deactivatedaccount) wrote :

The automatic Emulate3Buttons disabling works as intended now (the first time you press the middle mouse button, it gets disabled). Also with the new xinput improvements, you can change the settings on runtime.

Changed in xserver-xorg-input-evdev (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers