numlock key not functioning on Thinkpad X24

Bug #182421 reported by Rolf Leggewie on 2008-01-12
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-input-evdev (Ubuntu)
Medium
Unassigned

Bug Description

not sure what package this bug is really in. All I know is that it is very annoying for me.

Ever since I upgraded to gutsy has the numlock key on the internal keyboard of my Thinkpad X24 lost its function while in Gnome. gdm login is still fine, but once login is complete, numlock is on and cannot be turned off without the help of numlockx or an external keyboard. Numlock on an external keyboard works fine. Shift + ScrollLock on the internal keyboard does not, which is very unfortunate while on the road.

I unsuccessfully tried xmodmap and "keycode 77 = Num_Lock" in ~/.Xmodmap. I also tried gconfeditor to suppress it remembering numlock state, but if I recall correctly that only worked for a few days. tpb is installed and running, /etc/tpbrc contains no uncommented entries.

Information as listed on https://wiki.ubuntu.com/LaptopTestingTeam/HotkeyResearch

$ sudo dmidecode -s system-manufacturer && sudo dmidecode -s system-product-name&& sudo dmidecode -s system-version
IBM
2662MQG
Not Available

output from launching xev and then pressing the Numlock key on the external keyboard, followed by Shift + ScrollLock:

KeyPress event, serial 27, synthetic NO, window 0x4200001,
    root 0x61, subw 0x0, time 1880224165, (380,107), root:(385,158),
    state 0x0, keycode 77 (keysym 0xff7f, Num_Lock), same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False

PropertyNotify event, serial 30, synthetic NO, window 0x4200001,
    atom 0x13d (XKLAVIER_STATE), time 1880224171, state PropertyNewValue

KeyRelease event, serial 30, synthetic NO, window 0x4200001,
    root 0x61, subw 0x0, time 1880224297, (380,107), root:(385,158),
    state 0x10, keycode 77 (keysym 0xff7f, Num_Lock), same_screen YES,
    XLookupString gives 0 bytes:
    XFilterEvent returns: False

KeyPress event, serial 30, synthetic NO, window 0x4200001,
    root 0x61, subw 0x0, time 1880226308, (380,107), root:(385,158),
    state 0x10, keycode 62 (keysym 0xffe2, Shift_R), same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False

KeyPress event, serial 30, synthetic NO, window 0x4200001,
    root 0x61, subw 0x0, time 1880226849, (380,107), root:(385,158),
    state 0x11, keycode 78 (keysym 0xff14, Scroll_Lock), same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False

KeyRelease event, serial 30, synthetic NO, window 0x4200001,
    root 0x61, subw 0x0, time 1880226948, (380,107), root:(385,158),
    state 0x11, keycode 78 (keysym 0xff14, Scroll_Lock), same_screen YES,
    XLookupString gives 0 bytes:
    XFilterEvent returns: False

KeyRelease event, serial 30, synthetic NO, window 0x4200001,
    root 0x61, subw 0x0, time 1880227355, (380,107), root:(385,158),
    state 0x11, keycode 62 (keysym 0xffe2, Shift_R), same_screen YES,
    XLookupString gives 0 bytes:
    XFilterEvent returns: False
[lspci]
00:00.0 Host bridge [0600]: Intel Corporation 82830 830 Chipset Host Bridge [8086:3575] (rev 04)
     Subsystem: IBM ThinkPad A/T/X Series [1014:021d]
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc Radeon Mobility M6 LY [1002:4c59] (prog-if 00 [VGA controller])
     Subsystem: IBM ThinkPad X22/X23/X24 [1014:0239]

Rolf Leggewie (r0lf) wrote :

> output from launching xev and then pressing the Numlock key on the external keyboard, followed by Shift + ScrollLock:

Shift + ScrollLock is supposed to be the Numlock key on the internal keyboard of the X-series Thinkpad as you can see from the attached screenshot. Sorry, if that was unclear initially. If I understand the output of xev correctly, the keycode emitted is 78 instead of the expected 77. The combination with the shift key is not taken into account.

The problem still exists on hardy.

Rolf Leggewie (r0lf) wrote :

For anybody else having this annoying problem here is the way I usually help myself.

* open terminal
* type n - TAB, bash-completion will respond with a list of command starting with n
* copy numlockx and paste it into the console twice with a space in between
* delete everything but the o from the second occurrence and append with ff (the f key is not affected)
* you now have "numlockx off" on the console, hit enter and numlock will turn off

There are of course more elegant methods, but this should work every time in case you have no other options

HTH

Rolf Leggewie (r0lf) wrote :

I don't think this is a dupe. First of all, bug #197589 is not laptop-specific. The workarounds also seem to do nothing.

Bryce Harrington (bryce) wrote :

Hi r0lf,

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with the latest development release of Ubuntu? (ISOs are available from cdimage.ubuntu.com)

If it remains an issue, could you also attach a new /var/log/Xorg.0.log?
Thanks in advance.

The output of lspci -vvnn would also be worth having.

Changed in xserver-xorg-input-keyboard:
status: New → Incomplete
Rolf Leggewie (r0lf) wrote :

verified to be still present in intrepid by creating a bootable usb device and rebooting from that

Changed in xserver-xorg-input-keyboard:
status: Incomplete → New
Rolf Leggewie (r0lf) wrote :

It looks like numlock being on by default was either a user setting or some other bug that was fixed in the meantime.

The numlock key on the internal keyboard has no function, it works fine on an external keyboard. This is still unresolved.

Bryce Harrington (bryce) wrote :

[This is an automated message]

Hi r0lf,

Thanks for including an image to demonstrate the issue. Could you also please attach the output of `lspci -vvnn`, and attach your /var/log/Xorg.0.log file from after reproducing this issue. If you've made any customizations to your /etc/X11/xorg.conf please attach that as well.

Changed in xserver-xorg-input-keyboard:
status: New → Incomplete
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xserver-xorg-input-keyboard:
status: Incomplete → Invalid
Rolf Leggewie (r0lf) wrote :

still an issue, reopening

Changed in xserver-xorg-input-keyboard:
status: Invalid → New
Rolf Leggewie (r0lf) wrote :
Rolf Leggewie (r0lf) wrote :
Rolf Leggewie (r0lf) wrote :
Bryce Harrington (bryce) on 2009-01-09
Changed in xserver-xorg-input-keyboard:
importance: Undecided → Medium
status: New → Confirmed
Bryce Harrington (bryce) on 2009-01-17
description: updated
Rolf Leggewie (r0lf) wrote :

I added some kind of tweak so that this would not bother me every single login. Looks like this tweak does not work for Jaunty. At any rate, this annoying and highly problematic bug is still present in Jaunty.

Bryce Harrington (bryce) wrote :

Rolf, can you re-test with the "evdev" driver instead of "kbd"? A quick way to test this would be to boot Jaunty with your xorg.conf moved aside.

Indeed, both "mouse" and "kbd" are deprecated now in favor of "evdev".

If the issue still exists with "evdev", this bug should be moved to the xserver-xorg-input-evdev package.

Changed in xserver-xorg-input-keyboard:
status: Confirmed → Incomplete
Rolf Leggewie (r0lf) wrote :

Bryce, thank you for your support.

I moved /etc/X11/xorg.conf out of the way and rebooted the computer. I think the situation is basically unchanged. Adjusting affected package as you suggested.

It should be noted however that numlock now isn't always turned on. It seems to depend on the account signed in as well as the order in which accounts were signed in. For example, I think my main user usually has the numlock turned on when signed in as first user. Another user usually has it turned off. But if I sign in with my secondary account first and then use "switch user" for the primary account, numlock is turned off there as well. At least I think that pattern holds.

In any case, it is not possible to change from the initial numlock state with the designated keys on this Thinkpad. I have to use the numlockx program for that.

Changed in xserver-xorg-input-keyboard:
status: Incomplete → New
Bryce Harrington (bryce) on 2009-03-06
Changed in xserver-xorg-input-evdev:
status: New → Confirmed
Rolf Leggewie (r0lf) wrote :

This is the output from xev and trying to activate the Numlock under Karmic. This is still unfixed, let me know if I can provide any additional information.

KeyPress event, serial 31, synthetic NO, window 0x4e00001,
    root 0xf7, subw 0x0, time 56551189, (89,78), root:(192,347),
    state 0x0, keycode 50 (keysym 0xffe1, Shift_L), same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False

KeyPress event, serial 34, synthetic NO, window 0x4e00001,
    root 0xf7, subw 0x0, time 56553091, (89,78), root:(192,347),
    state 0x1, keycode 77 (keysym 0xfef9, Pointer_EnableKeys), same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False

Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi Rolf,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 182421

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 182421 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/182421

Changed in xserver-xorg-input-evdev (Ubuntu):
status: Confirmed → Incomplete
tags: added: needs-retested-on-lucid-by-june
Rolf Leggewie (r0lf) wrote :

I can probably not test this before the end of June

Timo Aaltonen (tjaalton) wrote :

a year has passed, closing the bug as expired.

Changed in xserver-xorg-input-evdev (Ubuntu):
assignee: Ubuntu Laptop Team (ubuntu-laptop) → nobody
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers