horizontal scrolling with middle trackpoint button broken

Bug #1597984 reported by Jim Cline on 2016-07-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-input-evdev (Ubuntu)
Undecided
Unassigned

Bug Description

Horizontal scrolling with the middle trackpoint button on Thinkpad X260 does not work as expected.
I noticed the problem in nedit, where holding the middle button while dragging the cursor over the text to be copied is a fast way of copying text. But the cursor does not move, so this feature does not work. In chromium, scrolling works with the cursor in place, but this is not the same functionality as with a real mouse, which is what is supposed to be emulated. This all worked perfectly in Ubuntu 10.10 (what I have been using until now).

The difference between scrolling with the middle button of a real mouse and the broken emulation
is that with a real mouse, xev sees a ButtonPress event (button 2) followed by MotionNotify events, followed by a ButtonRelease event, whereas with the trackpoint it sees a series of ButtonPress and ButtonRelease events (buttons 4,5,6,7) with no MotionNotify events. Completely different behavior from what an application is expecting. Since this worked in a previous release, is there some
work-around?

Jim Cline (jcline-physics) wrote :

Sorry, I withdraw this bug. The solution is to turn off Evdev Wheel Emulation. But maybe some other confused person can benefit from this.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers