Touchpad not always enabled after a suspend

Bug #1569880 reported by Egbert van der Wal on 2016-04-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-input-evdev (Ubuntu)
Undecided
Unassigned

Bug Description

On my laptop (Clevo P650RA) the touchpad is not always enabled after a suspend. I have worked around this by creating /etc/systemd/system/trackpad.service that runs a script in /etc/pm/sleep.d/ that re-enables the trackpad by doing:

DISPLAY=:0.0 /bin/su <myusername> -c '/usr/bin/xinput set-prop "SynPS/2 Synaptics TouchPad" "Device Enabled" 1' >> /var/log/touchpad.log

For some reason, the 'Device Enabled' flag is set to 0 during suspend, and it sometimes is not automatically re-enabled (but then again, sometimes it is).

I tried reporting this using 'ubuntu-bug xserver-xorg-input-evdev' like instructed, but unfortunately, ubuntu-bug seems to segfault while attempting to report the bug.
---
ApportVersion: 2.20.1-0ubuntu1
Architecture: amd64
DistroRelease: Ubuntu 16.04
InstallationDate: Installed on 2016-04-12 (1 days ago)
InstallationMedia: Kubuntu 16.04 LTS "Xenial Xerus" - Beta amd64 (20160323)
NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
Package: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
PackageArchitecture: amd64
ProcEnviron:
 LANGUAGE=
 TERM=xterm
 PATH=(custom, no user)
 LANG=nl_NL.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 4.4.0-18.34-generic 4.4.6
Tags: xenial
Uname: Linux 4.4.0-18-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

_MarkForUpload: True

apport information

tags: added: apport-collected
description: updated

apport information

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers