middle-mouse-click on titlebars to send window to bottom of the stack fails occasionally

Bug #1489640 reported by Seth Arnold on 2015-08-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-input-evdev
New
Undecided
Unassigned
xserver-xorg-input-evdev (Ubuntu)
Low
Unassigned

Bug Description

I use unity 7 as a pseudo-tiling window manager: I slide terminals and firefox to the sides of the screen to get them to automatically expand to fill half of the screen space, similar to the Windows 7 feature.

I stack a firefox over urxvt on one side of the screen and use middle-click on the title bar to send the top window to the bottom of the stack.

This has failed twice in the last few weeks.

Thanks

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: unity 7.2.5+14.04.20150603-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-57.95-generic 3.13.11-ckt21
Uname: Linux 3.13.0-57-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.12
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CurrentDesktop: Unity
Date: Thu Aug 27 15:13:27 2015
InstallationDate: Installed on 2012-10-18 (1043 days ago)
InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120823.1)
SourcePackage: unity
UpgradeStatus: Upgraded to trusty on 2014-04-12 (502 days ago)
---
ApportVersion: 2.14.1-0ubuntu3.13
Architecture: amd64
CurrentDesktop: Unity
DistUpgraded: 2014-04-11 18:01:51,931 DEBUG enabling apt cron job
DistroCodename: trusty
DistroRelease: Ubuntu 14.04
DistroVariant: ubuntu
InstallationDate: Installed on 2012-10-18 (1068 days ago)
InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120823.1)
MachineType: LENOVO 2359CTO
Package: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
PackageArchitecture: amd64
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-57-generic root=UUID=7b8c2e1b-d2e6-47d9-9030-c078e9701a1d ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.13.0-57.95-generic 3.13.11-ckt21
Tags: trusty ubuntu
Uname: Linux 3.13.0-57-generic x86_64
UpgradeStatus: Upgraded to trusty on 2014-04-12 (527 days ago)
UserGroups: adm cdrom dip libvirtd lpadmin plugdev sambashare sbuild sudo
_MarkForUpload: True
dmi.bios.date: 09/13/2012
dmi.bios.vendor: LENOVO
dmi.bios.version: G4ET62WW (2.04 )
dmi.board.asset.tag: Not Available
dmi.board.name: 2359CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Defined
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvrG4ET62WW(2.04):bd09/13/2012:svnLENOVO:pn2359CTO:pvrThinkPadT530:rvnLENOVO:rn2359CTO:rvrNotDefined:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 2359CTO
dmi.product.version: ThinkPad T530
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.11.3+14.04.20150313-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.60-2~ubuntu14.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.1.3-0ubuntu0.4
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.1.3-0ubuntu0.4
version.xserver-xorg-core: xserver-xorg-core 2:1.15.1-0ubuntu2.7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3.0-1ubuntu3.1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.910-0ubuntu1.6
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
xserver.bootTime: Mon Jul 20 08:30:24 2015
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 16562
 vendor LEN
xserver.version: 2:1.15.1-0ubuntu2.7

Seth Arnold (seth-arnold) wrote :
Fabio Marconi (fabiomarconi) wrote :

Hallo
Are you sure isn't the mouse having problems ?
Can you check with onother one ?
reassigning to X, so please reproduce the bug and run in terminal:
apport-collect -p 1489640
Best regards

affects: unity (Ubuntu) → xserver-xorg-input-evdev (Ubuntu)
affects: unity → evdev
Changed in xserver-xorg-input-evdev (Ubuntu):
status: New → Incomplete
importance: Undecided → Medium
importance: Medium → Low

apport information

tags: added: apport-collected ubuntu
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in xserver-xorg-input-evdev (Ubuntu):
status: Incomplete → New
Seth Arnold (seth-arnold) wrote :

Fabio, I'm confident that the mouse isn't to blame, middle-click worked fine on other windows to send-to-bottom and to paste from the selection buffer when this happened, and restarting the clients in question allowed it to work on them again.

I've run the apport-collect command, though the intervening three weeks might have been enough time to overwrite anything that might have been useful from the time of this bug report.

Thanks

To post a comment you must log in.