Horizontal scrolling on Thinkpad USB Keyboard with Trackpoint

Bug #1439948 reported by gdi2k on 2015-04-03
64
This bug affects 12 people
Affects Status Importance Assigned to Milestone
xserver-xorg-input-evdev (Ubuntu)
Undecided
Unassigned

Bug Description

I have a Lenovo ThinkPad Compact USB Keyboard with TrackPoint - this is an external USB keyboard with integrated TrackPoint that is based on the keyboard from the Thinkpad X230/T430/T530.

Lenovo part number is: 0B47190

Vertical scrolling works fine out of the box on Ubuntu 14.04 (fully updated), but horizontal scrolling does not work.

I have it connected to a Thinkpad X200, also with integrated Trackpoint, where horizontal works fine.

If I run xev, vertical scrolling up / down outputs button 4 / 5 as expected, but horizontal scroll has no output.

I have an open thread about it here:
http://ubuntuforums.org/showthread.php?t=2270926

Here is an Amazon reviewer on Archlinux (likely more knowledgeable than me) with the same issue:
http://www.amazon.com/review/R2Z5HAU91QRW7S/ref=cm_cr_dp_cmt?ie=UTF8&ASIN=B00F3U4TQS&nodeID=541966&store=pc

On a Windows machine horizontal scroll worked fine using the same device.

gdi2k@x200:~$ lsb_release -rd
Description: Ubuntu 14.04.2 LTS
Release: 14.04

gdi2k@x200:~$ apt-cache policy xserver-xorg-input-evdev-lts-utopic
xserver-xorg-input-evdev-lts-utopic:
  Installed: 1:2.9.0-1ubuntu2~trusty1
  Candidate: 1:2.9.0-1ubuntu2~trusty1
  Version table:
 *** 1:2.9.0-1ubuntu2~trusty1 0
        500 http://ph.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
        100 /var/lib/dpkg/status

gdi2k (gdi2k) wrote :

Attaching Xorg.0.log

gdi2k (gdi2k) wrote :

Attaching output from lsusb

gdi2k (gdi2k) wrote :

Attaching output from xinput list --long

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-input-evdev (Ubuntu):
status: New → Confirmed
Chow Loong Jin (hyperair) wrote :

Could you check the output of "xinput list-props 14"? (change 14 to match whatever the ID should be from the pointer section. 14 is based on your xinput output above).

Chow Loong Jin (hyperair) wrote :

By the way, I use this config with my Trackpoint:

hyperair@thinkpwn:/etc/X11/xorg.conf.d% cat 50-trackpoint-acceleration.conf
Section "InputClass"
        Identifier "trackpoint"
        MatchProduct "TPPS/2 IBM TrackPoint"
        Option "AccelerationProfile" "2"
        Option "AccelerationNumerator" "25"
        Option "AccelerationDenominator" "10"
        Option "VertScrollDelta" "8"
        Option "HorizScrollDelta" "8"
EndSection

Section "InputClass"
        Identifier "trackpoint-usb"
        MatchProduct "Lite-On Technology Corp. ThinkPad USB Keyboard with TrackPoint"
        Option "AccelerationProfile" "2"
        Option "AccelerationNumerator" "25"
        Option "AccelerationDenominator" "10"
        Option "VertScrollDelta" "8"
        Option "HorizScrollDelta" "8"
EndSection

Note that HorizScrollDelta is set in this.

gdi2k (gdi2k) wrote :
Download full text (3.3 KiB)

Since upgrading to Xubuntu 15.10, neither vertical nor horizontal scrolling work with this keyboard.

ID is now 21:

gdi2k@x250:~$ xinput list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ TPPS/2 IBM TrackPoint id=13 [slave pointer (2)]
⎜ ↳ Razer Razer DeathStalker id=15 [slave pointer (2)]
⎜ ↳ Razer Razer DeathStalker id=16 [slave pointer (2)]
⎜ ↳ Logitech M705 id=18 [slave pointer (2)]
⎜ ↳ Lenovo ThinkPad Compact USB Keyboard with TrackPoint id=21 [slave pointer (2)]
⎜ ↳ SynPS/2 Synaptics TouchPad id=10 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Sleep Button id=8 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=9 [slave keyboard (3)]
    ↳ ThinkPad Extra Buttons id=11 [slave keyboard (3)]
    ↳ Integrated Camera id=12 [slave keyboard (3)]
    ↳ Razer Razer DeathStalker id=14 [slave keyboard (3)]
    ↳ C-Media USB Audio Device id=17 [slave keyboard (3)]
    ↳ UVC Camera (046d:0821) id=19 [slave keyboard (3)]
    ↳ Lenovo ThinkPad Compact USB Keyboard with TrackPoint id=20 [slave keyboard (3)]

gdi2k@x250:~$ xinput list-props 21
Device 'Lenovo ThinkPad Compact USB Keyboard with TrackPoint':
 Device Enabled (139): 1
 Coordinate Transformation Matrix (141): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
 Device Accel Profile (263): 0
 Device Accel Constant Deceleration (264): 1.000000
 Device Accel Adaptive Deceleration (265): 1.000000
 Device Accel Velocity Scaling (266): 10.000000
 Device Product ID (257): 6127, 24647
 Device Node (258): "/dev/input/event23"
 Evdev Axis Inversion (370): 0, 0
 Evdev Axes Swap (372): 0
 Axis Labels (373): "Rel X" (149), "Rel Y" (150), "Rel Horiz Wheel" (582), "Rel Vert Wheel" (583)
 Button Labels (374): "Button Left" (142), "Button Middle" (143), "Button Right" (144), "Button Wheel Up" (145), "Button Wheel Down" (146), "Button Horiz Wheel Left" (147), "Button Horiz Wheel Right" (148), "Button Side" (709), "Button Extra" (710), "Button Unknown" (369), "Button Unknown" (369), "Button Unknown" (369), "Button Unknown" (369)
 Evdev Scrolling Distance (375): 1, 1, 1
 Evdev Middle Button Emulation (376): 1
 Evdev Middle Button Timeout (377): 50
 Evdev Third Button Emulation (378): 0
 Evdev Third Button Emulation Timeout (379): 1000
 Evdev Third Button Emulation Button (380): 3
 Evdev Third Button Emulation Threshold (381): 20
 Evdev Wheel Emulation (382): 1
 Evdev Wheel Emulation Axes (383): 6, 7, 4, 5
 Evdev Wheel Emulation Inertia (384): 10
 Evdev Wheel Emulation Timeout (385): 200
 Evdev Wheel Emulation Button (386): 2
 Evdev Drag Lock Butto...

Read more...

Mike Oliver (n-mike-u) wrote :

Any updates regarding this bug? I'm still experiencing this on 15.10 (Unity). Can we at least get is assigned?

Chris Baynes (binaryexp) wrote :

This is a great keyboard in combination with a Thinkpad laptop, and it's a real shame that neither horizontal nor vertical scrolling work in 15.10 anymore.

Does anyone have a fix of any kind for this?

Thanks

Eddie (edward-pimentel) wrote :

I'm on Kubuntu 16.04.1 on 4.4.0-51.72 kernel. I noticed after a kernel update that it was working both horizontally and vertically with the trackpoint on the Lenovo Thinkpad USB keyboard model number KU-1255. I figured this group had already been notified.

If others can confirm, I think this bug can be marked as FIXED.

Eddie (edward-pimentel) wrote :

In case anyone is curious. I'm on xserver-xorg-input-evdev 1:2.10.1-1ubuntu2

Chris Baynes (binaryexp) wrote :

Confirmed - horizontal and vertical scrolling is working again in 16.04.

Thanks guys!

laci357 (laci357) wrote :

Neither horizontal, nor vertical scrollowing works for me on Thinkpad USB keyboard in Ubuntu 16.04, kernel 4.4.0.59-generic.

laci357 (laci357) wrote :

*scrolling

Maximilian Bachl (muxamilian) wrote :

I experienced the same bug. I could only scroll horizontally but not vertically. However, when I connected the keyboard over USB 3 and not USB 2 everything worked as expected.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers