the evdev driver of Xorg ignore the swap axes optiopn for N-trig multitouch

Bug #1103723 reported by lukyluke on 2013-01-23
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
xserver-xorg-input-evdev (Ubuntu)
Low
Unassigned

Bug Description

I have just received my dell xt3
I use kubuntu 12.04.1 fully update, with kde from the ppa backport repository.

When I turn the screen into the tablet mode, I can rotate both the screen and the pen-eraser that are controlled by the Wacom driver.

The multitouch screen is controlled by the evdev driver and does not rotate, in particular I am not able to swap the axis,
one of the necessary step of the rotation process the
xinput set-prop 12 "Evdev Axes Swap" 1
does not produce any effect.

where the output of is xinput

⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ N-Trig Pen stylus id=11 [slave pointer (2)]
⎜ ↳ N-Trig MultiTouch id=12 [slave pointer (2)]
⎜ ↳ N-Trig Touchscreen id=13 [slave pointer (2)]
⎜ ↳ DualPoint Stick id=15 [slave pointer (2)]
⎜ ↳ AlpsPS/2 ALPS DualPoint TouchPad id=16 [slave pointer (2)]
⎜ ↳ N-Trig Pen eraser id=18 [slave pointer (2)]
⎜ ↳ N-Trig Pen pad id=19 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Power Button id=8 [slave keyboard (3)]
    ↳ Sleep Button id=9 [slave keyboard (3)]
    ↳ Laptop_Integrated_Webcam_HD id=10 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=14 [slave keyboard (3)]
    ↳ Dell WMI hotkeys id=17 [slave keyboard (3)]

lukyluke (luca-tagliacozzo) wrote :

All versions of the programs are inside the Xorg log file

lukyluke (luca-tagliacozzo) wrote :

All versions of the programs are inside the Xorg log file

wasu (i-launchpad-net-j) wrote :

I have the same problem. Dell ST22202T touchscreen and an eGalaxTouch Touchscreen, both tested on Ubuntu 12.04 and 12.10.
edev seems to ignore all set-prop commands. I tried:
xinput set-prop 10 "Evdev Axes Swap" 1
xinput set-prop 10 "Evdev Axis Inversion" 1 1
xinput set-prop 10 "Evdev Axis Calibration" 30 1902 25 1078
All commands have no effect.

edev also seems to ignore all Option commands set in
/usr/share/X11/xorg.conf.d/10-evdev.conf
Section "InputClass"
      Identifier "evdev touchscreen catchall"
      MatchIsTouchscreen "on"
      MatchDevicePath "/dev/input/event*"
      Driver "evdev"
      Option "InvertX" "1"
      Option "InvertY" "1"
      Option "Calibration" "30 1902 25 1078"
      Option "SwapAxes" "1"
EndSection

wasu (i-launchpad-net-j) wrote :

Find the parts of /var/log/Xorg.0.log after I plug in the USB cable of the Touchscreen in the attachment. It shows:
[ 80.799] (**) Option "InvertX" "1"
[ 80.799] (**) Option "InvertY" "1"
[ 80.799] (**) Option "SwapAxes" "1"

I can verify that these values were set by executing the following (10 is the id of my touchscreen):
xinput list-props 10
...
Evdev Axis Inversion (263): 1, 1
Evdev Axis Calibration (264): 30, 1902, 25, 1078
Evdev Axes Swap (265): 1
...

but as described above, no effect. evdev seems to ignore all of these options.

wasu (i-launchpad-net-j) wrote :

sorry in the comment one before it should say "evdev" not "edev"

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-input-evdev (Ubuntu):
status: New → Confirmed
bugbot (bugbot) on 2013-01-24
tags: added: kubuntu
Heikki Niiranen (heikki-z) wrote :

Hi,

just to add that I have the same problem with Elo TouchSystems 2515 IntelliTouch Plus USB Touchmonitor. When running xinput list-props options are correctly listed, but they do not take effect.

Running 12.04.1

Hi,

I have the same problem with a eGalaxTouch screen,
I need to set the calibration, in /usr/share/X11/xorg.conf.d/10-evdev.conf, e.g.:
Option "Calibration" "40 1600 50 1200"
The calibration is ignored by evdev.
xinput set-props ... is also ignored.
Please help, I need this urgently for a business project!!

System: Ubuntu 12.04.

Amit Uttamchandani (amit-uttam) wrote :

I built the latest evdev from:

http://cgit.freedesktop.org/xorg/driver/xf86-input-evdev/

and it fixes the issue mentioned in this bug.

elleP (pelle-quicknet) wrote :

I also had this bug, it is fixed upstream in xf86-input-evdev in commit bb9b4146cb828bd366675e8736fc145e92c9269a

Until this is fixed in the repositories I've rebuilt the package as described here: https://help.ubuntu.com/community/UpdatingADeb, using the patch from here: http://cgit.freedesktop.org/xorg/driver/xf86-input-evdev/diff/?id=bb9b4146cb828bd366675e8736fc145e92c9269a

This fixes the swapaxes being ignored on my system.
The invertX and invertY still seem to be ignored, but this can be worked around by changing the calibration from "0 1024 0 1024" to "1024 0 1024 0"

Anton Anikin (anton-anikin) wrote :

Same problem with Acer W700 tablet

Anton Anikin (anton-anikin) wrote :

I have found that it is possible to rotate the axes in this way:
https://wiki.ubuntu.com/X/InputCoordinateTransformation
For example, to rotate right:
xinput set-prop 10 "Coordinate Transformation Matrix" 0 1 0 -1 0 1 0 0 1
It works fine for me

Milan Draca (milan-draca) wrote :

Thanks Anikin. If I ever see you I will get You all the beers you can drink and what ever you wont!!!!!!!!!
Works fine!

lukyluke, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p xserver-xorg-input-evdev REPLACE-WITH-BUG-NUMBER

Please note, given that the information from the prior release is already available, doing this on a release prior to the development one would not be helpful.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Changed in xserver-xorg-input-evdev (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for xserver-xorg-input-evdev (Ubuntu) because there has been no activity for 60 days.]

Changed in xserver-xorg-input-evdev (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions