Ubuntu

Screen brightness is not affected by keys ("MacBook Pro")

Reported by Leonhard Küper on 2012-05-30
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xserver-xorg-input-evdev (Ubuntu)
Low
Unassigned

Bug Description

Hello.

===== Expected Behavior =====
The funktion-keys on "F1" and "F2" should change brightness of the screen.

===== Instead =====
  * The Screenbrightness is not affected.
  * From time to time after waking up from standby the brightness is changed. The only rebooting helps. I am not sure how to reproduce this, sorry.

===== System =====
$ lsb_release -rd
Description: Ubuntu 12.04 LTS
Release: 12.04

Further infromation I will gladly include. Just ask.

I forgot: I am working on a "MacBook Pro" but don't know the exact hardware. How do I find out? At least lspci:

$ lspci
00:00.0 Host bridge: NVIDIA Corporation MCP79 Host Bridge (rev b1)
00:00.1 RAM memory: NVIDIA Corporation MCP79 Memory Controller (rev b1)
00:03.0 ISA bridge: NVIDIA Corporation MCP79 LPC Bridge (rev b3)
00:03.1 RAM memory: NVIDIA Corporation MCP79 Memory Controller (rev b1)
00:03.2 SMBus: NVIDIA Corporation MCP79 SMBus (rev b1)
00:03.3 RAM memory: NVIDIA Corporation MCP79 Memory Controller (rev b1)
00:03.4 RAM memory: NVIDIA Corporation Device 0a98 (rev b1)
00:03.5 Co-processor: NVIDIA Corporation MCP79 Co-processor (rev b1)
00:04.0 USB controller: NVIDIA Corporation MCP79 OHCI USB 1.1 Controller (rev b1)
00:04.1 USB controller: NVIDIA Corporation MCP79 EHCI USB 2.0 Controller (rev b1)
00:06.0 USB controller: NVIDIA Corporation MCP79 OHCI USB 1.1 Controller (rev b1)
00:06.1 USB controller: NVIDIA Corporation MCP79 EHCI USB 2.0 Controller (rev b1)
00:08.0 Audio device: NVIDIA Corporation MCP79 High Definition Audio (rev b1)
00:09.0 PCI bridge: NVIDIA Corporation MCP79 PCI Bridge (rev b1)
00:0a.0 Ethernet controller: NVIDIA Corporation MCP79 Ethernet (rev b1)
00:0b.0 IDE interface: NVIDIA Corporation MCP79 SATA Controller (rev b1)
00:0c.0 PCI bridge: NVIDIA Corporation MCP79 PCI Express Bridge (rev b1)
00:10.0 PCI bridge: NVIDIA Corporation MCP79 PCI Express Bridge (rev b1)
00:15.0 PCI bridge: NVIDIA Corporation MCP79 PCI Express Bridge (rev b1)
00:16.0 PCI bridge: NVIDIA Corporation MCP79 PCI Express Bridge (rev b1)
03:00.0 VGA compatible controller: NVIDIA Corporation C79 [GeForce 9400M] (rev b1)
04:00.0 Network controller: Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller (rev 01)
05:00.0 FireWire (IEEE 1394): LSI Corporation FW643 PCI Express 1394b Controller (PHY/Link) (rev 07

I could reproduce:

If I change brightness, than set to stand by and than woke up the notebook again, the change of brightness has been applyed.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1006453/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
wvengen (wvengen) wrote :

Hi, thanks for your bug report. Depending on your specific MacBook model, there could be a directory in /sys/devices/virtual/backlight/ , for example called apple_backlight. If so, you can try to write to the file 'brightness' in there and see if your backlight changes, like this:
  $ echo 8 | sudo tee /sys/devices/virtual/backlight/apple_backlight/brightness
if your backlight changes, the mechanism to change it works but the keys don't. If not, then it's more a driver/hardware issue.

See also: https://wiki.ubuntu.com/Kernel/Debugging/Backlight

Thanks for the feedback. As discribed, the brightness file exits and is effected by the keys. Since the Keys work under OSX I assume the driver is not working correct. How do I find out what the used driver/module is? Where do I report the bug for the driver?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Onno Steenbergen (osteenbergen) wrote :

Having the same issues with a MacBookPro 4.1.

Have tried the suggested commands but the brightness doesn't change. I can change the brightness during login and during the first +-10 seconds after login. After this the birghtness is fixed until reboot. Suspending the machine results in maximum brightness and still no control.

The apple_bl module is loaded and reloading the module also doesn't solve the issue.

Previous versions of ubuntu didn't have this problem

Macbook6-1 (GeForce 9400M)
Ubuntu 12.04
nvidia-current 295.40-0ubuntu1.1

Works perfectly without nvidia driver (nouveau driver).

Attached values of /sys/devices/virtual/backlight.
Write random values to any of that files, didn't destroy the machine neither did nothing.

Modifications to the default command line arguments to the kernel where made in grub:

* reboot=pci # To make the computer restart (before, shutdown -r now just hangs for ever after system shutdown)
* acpi_backlight=vendor (Tested with and without without any change).

Found a solution:

Following the instructions found in [1] Adding the line

    Option “RegistryDwords” “EnableBrightnessControl=1″

to /etc/X11/xorg.conf make it.

Looking for a way to make permanent the change.

[1] http://www.addictivetips.com/ubuntu-linux-tips/fix-laptop-brightness-toggle-issues-in-ubuntu-10-10-and-11-04-tip/

Found a permanent solution with nvidia graphic card.

Just create a file in /etc/X11/xorg.conf.d/50-nvidia.conf with the following content:

Section "Device"
    Option "RegistryDwords" "EnableBrightnessControl=1"
    Identifier "Device0"
EndSection

From now on, you have brightness control.

affects: ubuntu → xorg (Ubuntu)
bugbot (bugbot) on 2012-10-25
tags: added: precise

also happens in ubuntu 12.10

bugbot (bugbot) on 2012-10-25
affects: xorg (Ubuntu) → xserver-xorg-input-evdev (Ubuntu)
Hohle Frucht (hohle-frucht88) wrote :

Hey Guys

The everwere posted workarounds with the /etc/X11/xorg.conf or /etc/X11/xorg.conf.d/50-nvidia.conf and than adding
Section "Device"
    Option "RegistryDwords" "EnableBrightnessControl=1"
    Identifier "Device0"
EndSection

doesnt seem to work for me :(. I had running backlight control in the past, but sadly I dont remember how it worked...
Does somebody know something new about it buy now?

Leonhard Küper, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p xserver-xorg-input-evdev REPLACE-WITH-BUG-NUMBER

Please note, given that the information from the prior release is already available, doing this on a release prior to the development one would not be helpful.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Changed in xserver-xorg-input-evdev (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for xserver-xorg-input-evdev (Ubuntu) because there has been no activity for 60 days.]

Changed in xserver-xorg-input-evdev (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers