building nvidia module against 2.6.33 fails

Bug #511272 reported by mokabar on 2010-01-22
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
Undecided
Unassigned
xserver-xorg-driver-nv (Ubuntu)
Undecided
Unassigned

Bug Description

trying to compile the nvidia module with dkms fails:

dkms build -m nvidia -v 190.53 -k 2.6.33-rc2 --kernelsourcedir /usr/src/linux-headers-2.6.33-rc2/

DKMS make.log for nvidia-190.53 for kernel 2.6.33-rc2 (x86_64)
Mon Jan 4 23:54:22 CET 2010
If you are using a Linux 2.4 kernel, please make sure
you either have configured kernel sources matching your
kernel or the correct set of kernel headers installed
on your system.

If you are using a Linux 2.6 kernel, please make sure
you have configured kernel sources matching your kernel
installed on your system. If you specified a separate
output directory using either the "KBUILD_OUTPUT" or
the "O" KBUILD parameter, make sure to specify this
directory with the SYSOUT environment variable or with
the equivalent nvidia-installer command line option.

Depending on where and how the kernel sources (or the
kernel headers) were installed, you may need to specify
their location with the SYSSRC environment variable or
the equivalent nvidia-installer command line option.

*** Unable to determine the target kernel version. ***

make: *** [select_makefile] Error 1

mokabar (tim-klingt) wrote :

the attached patch fixes the issue ... for details:

http://www.nvnews.net/vbulletin/showthread.php?p=2159458

mokabar (tim-klingt) wrote :

untested patch for 190.53

Noel J. Bergman (noeljb) on 2010-02-03
Changed in xserver-xorg-driver-nv (Ubuntu):
status: New → Invalid
Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi mokabar,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 511272

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 511272 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/511272

Changed in nvidia-graphics-drivers (Ubuntu):
status: Confirmed → Incomplete
tags: added: needs-retested-on-lucid-by-june
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in nvidia-graphics-drivers (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions