Ubuntu

java app gui is blank in xgl and java6

Reported by hanasaki on 2006-06-04
This bug report is a duplicate of:  Bug #118983: compiz & java windows always grey. Edit Remove
34
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xserver-xgl (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xserver-xgl

Run the xgl server / gnome and install Java5 package from sun - from restricted formats .deb

install netbeans - i used 6/01/2006 and 6/02 platform independant and unziped.

Run netbeans/bin/netbeans

the License dialog comes up w/o text or buttons.

run the regular xorg7 and gnome session and the gui is fine.

mcc (mcc-mytrashmail) wrote :

importance medium ???
I have to work with it....
please, fix it

This problem occures with all java swing application.

Lauri Kainulainen (luopio) wrote :

I can confirm this on edgy. Using XGL and Sun Java5 the frostwire window is blank, but inside normal Xorg, there are no problems. This of course affects things like applets as well.

machaval (achaval) wrote :

There is a patch that i found that make this problem fix. Can any one patch the repository so that we all can enjoy for java APP. This also happens whit IntelliJ App.

Chris Hermansen (c-hermansen) wrote :

I'm using 7.04 released and this problem still exists: NetBeans 5.5, Java SDK 5, installed as per the packages available in Synaptic.

When desktop effects are enabled, the NetBeans screens are blank. When desktop effects are disabled, the NetBeans screens look OK.

Given that there appears to be a known problem and a known patch, could this bug not be fixed?

Thanks in advance!

Emmet Hikory (persia) wrote :

Thanks for finding this patch. I've added the patch tag to collet the attention of packagers. I've unsubscribed ubuntu-universe-sponsors, as this does not represent a new revision candidate (patch is not a debdiff). If a debdiff is later prepared for this issue, and sponsorship is required for upload, please resubscribe ubuntu-universe-sponsors.

Changed in xserver-xgl:
status: Unconfirmed → Confirmed
gabo (gabotrotamundos) wrote :

I found the solution here: http://ubuntuforums.org/archive/index.php/t-362821.html

The problem is with Beryl.

Works like a charm, also for other apps like Limewire

Chris Halse Rogers (raof) wrote :

There have been a number of new Compiz and Xgl versions since this bug was filed. I believe that this bug is fixed in Gutsy. Is anyone able to confirm this bug in latest Gutsy, and if so can you confirm that this behaviour occurs when desktop effects are disabled?

Changed in xserver-xgl:
status: Confirmed → Incomplete
Artur Brodowski (bzd) wrote :

Bug still affects java apps in latest Gutsy updates - on a laptop with Xgl + fglrx java windows are empty, on an old dektop without desktop effects everything runs fine. This needs to be fixed before Gutsy goes stable.

Emmet Hikory (persia) wrote :

Does the issue persist when desktop effects are temporarily disabled for the laptop on which you experience the blank GUI?

eljefe6 (jesse-anderson) wrote :

I am running the Compiz backport for Feisty and the Java GUI apps are working fine. I am also running Java 1.6. There is a plugin for workaround that has a Java checkbox. Its in the CompizConfig Settings->Workaround->Java Window Fix. I did not have to enable this plugin for my computer.

italomaia (italo-maia) wrote :

CompizFusion on Gutsy RC plus Java application = Blank window, still : /.
I tested yesterday.

Fabian Frank (schnitz) wrote :

same problem here. the java workaround from fusion doesn't work for me but
export AWT_TOOLKIT="MToolkit"
did the trick for me. this happened to me when trying to run java studio enterprise 8.1 with sun-java5-jdk.

Adrian Petrescu (apetresc) wrote :

Gutsy has now been released for almost a week, but this bug remains unfixed.
Luckily, exporting AWT_TOOLKIT fixes the problem for me as well, but nevertheless if a patch has been made, why not commit this upstream? Does this patch break something else?

Just curious, thanks :)

Travis Watkins (amaranth) wrote :

The fix is to use java 6. This is a java bug.

Changed in xserver-xgl:
status: Incomplete → Invalid
Adrian Petrescu (apetresc) wrote :

Sorry, I should have been more specific; and in fact I realize now that the bug report refers specifically to Java 5, so my mistake, but:

this bug happens on Gutsy WITH Java 6. I assume it is the exact same bug because the exact same workaround (export AWT_TOOLKIT="MToolkit") fixes it. But the bug does happen on Gutsy with the latest version of everything. I can provide a screenshot if required.

Should I open a new bug about it, specifically mentioning Gutsy and Java 6? (And dropping the reference to Netbeans, since this bug in fact applies to all Swing/AWT apps on and off as far as I can tell)

Changed in xserver-xgl:
status: Invalid → Confirmed
davie (daviemoston) wrote :

this looks like a duplicate of bug #124562, which has a link to a sun java bug, but no patch (http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6632124).

davie (daviemoston) wrote :

also see bug #118983

MountainX (dave-mountain) wrote :

I am seeing this bug with Hardy beta (all updates current as of this date) and Sun Java 6. The java app in question is MoneyDance personal finance software.

The windows are drawn without content about 30% of the time. Repeatedly closing and re-opening an affected window or dialog box will eventually bring up one that has content.

This bug happens only when extra visual effects (compiz) are enabled. When no visual effects are enabled, the bug does not happen. Additionally, it appears not to happen when Metacity WM is enabled (and compiz is disabled).

Athar Waqas (athar-waqas) wrote :

Well guys completely agreed on this issue, i have tested every combination of Ubuntu with Java (all version) but in vain, im using an enterprise application at my company where my application uses java web start to execute but as soon as the application loads the background of the window is completely grey and the grey is the only thing you see inside.. only the titlebar is normal! while when compiz is off, everything is normal.. It seems like it has some problems with the swing libraries of java.
I have searched the whole of SUN and Java communities for the fix on this issue. but with every release of the new version of Ubuntu or any Java the fix is still no where to be found.

Just to add a bit of reference over here i have ported myself on to openSUSE 10.3 in which its working fine even with compiz running. I hope with the upcoming release of Ubuntu 8.04 the bug might be fixed.

Allcolor-g (allcolor) wrote :

There is a workaround :

do "export AWT_TOOLKIT=MToolkit" and it should work.

  • unnamed Edit (1.6 KiB, text/html; charset=ISO-8859-1)

Can you please guide me how to do this, it has started to piss me off badly.
Thank in advance

On Wed, Apr 23, 2008 at 3:37 PM, Allcolor-g <email address hidden> wrote:

> There is a workaround :
>
> do "export AWT_TOOLKIT=MToolkit" and it should work.
>
> --
> java app gui is blank in xgl and java6
> https://bugs.launchpad.net/bugs/48404
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Source Package "xserver-xgl" in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: xserver-xgl
>
> Run the xgl server / gnome and install Java5 package from sun - from
> restricted formats .deb
>
> install netbeans - i used 6/01/2006 and 6/02 platform independant and
> unziped.
>
> Run netbeans/bin/netbeans
>
> the License dialog comes up w/o text or buttons.
>
> run the regular xorg7 and gnome session and the gui is fine.
>

--
Athar Waqas
Manager NGN
Breezecom
Mobile: +92-321-3895127
Direct: +92-21-5823676
Landline: +92-21-5378226/7
Email: <email address hidden>
MSN ID: <email address hidden>
Fax: +92-21-5824178
Address: F-73/4, Block 4, Clifton, Karachi, Pakistan

StratosJL (stratosjl) wrote :

On 25/04/2008 03:11 μμ, Athar Waqas wrote:
> Can you please guide me how to do this, it has started to piss me off badly.
> Thank in advance

you could just add the line:

AWT_TOOLKIT="MToolkit"

in /etc/environment and see if it works!

>
> On Wed, Apr 23, 2008 at 3:37 PM, Allcolor-g <email address hidden> wrote:
>
>> There is a workaround :
>>
>> do "export AWT_TOOLKIT=MToolkit" and it should work.
>>
>> --
>> java app gui is blank in xgl and java6
>> https://bugs.launchpad.net/bugs/48404
>> You received this bug notification because you are a direct subscriber
>> of the bug.
>>
>> Status in Source Package "xserver-xgl" in Ubuntu: Confirmed
>>
>> Bug description:
>> Binary package hint: xserver-xgl
>>
>> Run the xgl server / gnome and install Java5 package from sun - from
>> restricted formats .deb
>>
>> install netbeans - i used 6/01/2006 and 6/02 platform independant and
>> unziped.
>>
>> Run netbeans/bin/netbeans
>>
>> the License dialog comes up w/o text or buttons.
>>
>> run the regular xorg7 and gnome session and the gui is fine.
>>
>
>

iMatt (anti-spam-imatt) wrote :

StratosL, your suggestion worked on my Hardy install.

> you could just add the line:
> AWT_TOOLKIT="MToolkit"
> in /etc/environment and see if it works!

Log out & back in.

Thank you very much! No more issues with blank java screens.

rkr1410 (rkr1410) wrote :

export AWT_TOOLKIT="MToolkit"
fixes the grey windows backgrounds, but makes
keyboard input in swing components impossible. After short time (maybe some alt-tabbing to other
apps) swing text components no longer accept keyboard input.

export AWT_TOOLKIT="XToolkit"
fixes the keyboard problem, but gives me the 'grey windows' problem.

Looks like a catch 22...

davie (daviemoston) wrote :

This really looks like a duplicate of #118983 which is a java bug, please see the comments there.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments