Ubuntu

FTBFS

Reported by Chris Halse Rogers on 2007-07-16
2
Affects Status Importance Assigned to Milestone
xserver-xgl (Ubuntu)
Undecided
Bryce Harrington

Bug Description

Binary package hint: xserver-xgl

Due to changes in mesa 7.0, xserver-xgl 7.2.0.git.20070224-0ubuntu3 now fails to build in Gutsy.

I'll package up a new git snapshot to fix this.

Changed in xserver-xgl:
assignee: nobody → raof
status: New → In Progress
description: updated
Changed in xserver-xgl:
assignee: raof → nobody
status: In Progress → Confirmed
Daniel Holbach (dholbach) wrote :

Michael: can you or Bryce check out this one?

Changed in xserver-xgl:
assignee: nobody → mvo
Bryce Harrington (bryce) wrote :

RAOF, can you point us at the snapshot you made?

Chris Halse Rogers (raof) wrote :

Here's a dget-able link for a source package, including the snapshot tarball: <http://cooperteam.net/xserver-xgl_1.1.99.1~git20070727-0ubuntu1.dsc>

Since Launchpad's codebrowse seems to be down, you can also check out the bzr branch this package is built from at the alternate location of <http://cooperteam.net/xserver-xgl-branch>.

Chris Halse Rogers (raof) wrote :
Bryce Harrington (bryce) wrote :

Hi Chris,

In general this looks good, but I have a few questions.

First, I notice this changeset drops the patch system in favor of using git. Since upstream uses git, and since we currently use bzr only in situations where launchpad can track the upstream vcs (i.e. svn, cvs), I'm not certain this is the right approach. Can you explain why you chose to go this route?

Second, I notice there are a number of Makefile.in and auto* files in the ubuntu diff, presumably because autogen.sh was run after creating the git snapshot. In general it seems more standard to include the autogen.sh'd files in the snapshot, rather than in the ubuntu diff. This keeps the ubuntu change simpler.

Would you mind making these changes? Then I think this would be good for upload.

Chris Halse Rogers (raof) wrote :

Thanks Bryce.

This was my first package using bzr. In hindsight, I wouldn't have done it the way it was done :).

Fortunately, that's easy to redo: «http://cooperteam.net/xserver-xgl/xserver-xgl_1.1.99.1~git20070727-0ubuntu1.dsc»

After discussion with Michael Vogt & Travis Watkins in #ubuntu-desktop, rather than shipping separate X session packages, this package now ships a file in /etc/X11/Xsession.d to start an Xgl server as a part of the normal session startup infrastructure. This means Xgl will immediately work after being installed.

Bryce Harrington (bryce) wrote :

Hi Chris,

This looks perfect and pbuilds fine for me. I can upload this, if we can get a second ack on it.

Bryce

Bryce Harrington (bryce) wrote :

Actually, since this is a new snapshot, it requires a UVF exception to be made, so we'll need motu-uvf acks first.

Bryce Harrington (bryce) wrote :

All changes are in the debian/ subdir

Bryce Harrington (bryce) wrote :

There are no changes to the ChangeLog. No NEWS file is used in this package.

pbuilder output log attached. It built cleanly.

Rationale for this upload is to fix build issues due to the mesa 7.0 upgrade for Gutsy and fix startup issues with Xgl. The following changes are included:

 * Drops patch 02-fix-glCallLists that was taken upstream
 * Adds patch 02-add-missing-gl-struct to fix build issue against mesa 7.0 and updates build-depends accordingly
 * Adds 00xserver-xgl_session-start to fix issue where Xgl does not start properly

Bryce Harrington (bryce) wrote :

Setting status back to New so motu-uvf can review

Changed in xserver-xgl:
status: Confirmed → New
Scott Kitterman (kitterman) wrote :

Ack #1.

ack #2, please upload, etc, as appropriate.

On Fri, Aug 31, 2007 at 03:17:28AM -0000, Scott Kitterman wrote:
> Ack #1.

Ack #2. I assume Bryce will be around to take care of bug reports and
such :)

 status confirmed

--
Soren Hansen
Ubuntu Server Team
http://www.ubuntu.com/

Soren Hansen (soren) on 2007-08-31
Changed in xserver-xgl:
status: New → Confirmed
Chris Halse Rogers (raof) wrote :

xserver-xgl (1:1.1.99.1~git20070727-0ubuntu1) gutsy; urgency=low

  * New git snapshot, now builds against mesa 7.0 (LP: #126255)
  * New versioning; follow upstream's new versioning
  * debian/patches/02-fix-glCallLists
    + Dropped, included in new snapshot
  * debian/patches/02-add-missing-gl-struct
    + Revert a small part of last git commit, to re-add the definition of a
      struct. Required to build against our mesa 7 packages.
  * debian/00xserver-xgl_session-start
    + Wrapper script to automatically add appropriate accel options to Xgl,
      make it fail to launch under some drivers that won't work, add
      appropriate cookie to xauth, and set DISPLAY.
    + Use xmodmap to disable shift-backspace killing Xgl
    + Install into /etc/X11/Xsession.d to automatically start Xgl (LP: 122939)
    + Start Xgl first so other session scripts such as seahorse get the right
      DISPLAY
  * debian/control:
    + Update build-depends for Mesa (>= 7.0)

 -- Christopher James Halse Rogers (RAOF) <email address hidden> Tue, 14 Aug 2007 12:17:31 +1000

Changed in xserver-xgl:
status: Confirmed → Fix Released
Bryce Harrington (bryce) wrote :

Uploaded.

Changed in xserver-xgl:
assignee: mvo → bryceharrington
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers