xsensors lacks support for coretemp module

Bug #183330 reported by Rob Pearman
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
xsensors (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xsensors

Installed xsensors from Add/Remove Applications. On launching xsensors, the window is tiny and when I expand it out the window is blank.

Running xsensors version 0.50-1ubuntu1

Ubuntu 7.10 (Gutsy) 64bit

Motherboard is an ASRock 2core1333-2.66G

Revision history for this message
Matthew Woerly (nattgew) wrote :

What do you get when you type "sensors" in a command line?

Changed in xsensors:
status: New → Incomplete
Revision history for this message
Rob Pearman (rob-pearman) wrote :

Thanks for the tip.

"sensors" gave "No sensors found!". Running "sensors-detect" and stepping through with default responses identified the following kernel drivers required:

w83627ehf
coretemp

Having loaded these I ran "sensors" again in a terminal window and got some results (although several of these are flagged as "ALARM" - I've attached the full output FYI but I guess the detail of the results is probably not in scope of this bug).

Running "xsensors" again still results in a tiny window but shows the following in the terminal output:

Sensor 'w83627ehf' not supported by xsensors!
Sensor 'coretemp' not supported by xsensors!
Sensor 'coretemp' not supported by xsensors!

Revision history for this message
Matthew Woerly (nattgew) wrote :

Well now we're getting somewhere. Thanks for the work and the information. I'll change the bug to reflect this, maybe have two, one for each of these unsupported modules.

Nanley Chery (nanoman)
Changed in xsensors:
assignee: nobody → nattgew
status: Incomplete → New
Revision history for this message
Matthew Woerly (nattgew) wrote :

From here:
http://www.linuxhardware.org/article.php?story=07/10/09/1854255&query=xsensors
X-sensors-0.60
- Added support for w83627ehf.

Revision history for this message
Matthew Woerly (nattgew) wrote :

https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/115386
Related I guess, kernel < 22 needs a patch for it.

Matthew Woerly (nattgew)
Changed in xsensors:
assignee: nattgew → nobody
Revision history for this message
Nanley Chery (nanoman) wrote :

Made a report for the new upstream version: Bug #206862

Revision history for this message
Nanley Chery (nanoman) wrote :

Reading the MOTU mailing list, I've discovered that coretemp support was added to version 0.60 of xsensors. Because an upgrade is required to fix this bug, I am marking it as a duplicate of bug 206862.

Nanley Chery (nanoman)
Changed in xsensors (Ubuntu):
assignee: nobody → Nanley Chery (nanoman)
status: New → In Progress
Revision history for this message
Nanley Chery (nanoman) wrote :

The patch for this revision comes from two files in the new upstream version (chips.h and chips.c) http://freshmeat.net/projects/xsensors/ and the author's patch for coretemp support, https://lists.ubuntu.com/archives/ubuntu-motu/2008-September/004711.html .

Changed in xsensors (Ubuntu):
assignee: Nanley Chery (nanoman) → nobody
status: In Progress → Confirmed
Revision history for this message
Benjamin Drung (bdrung) wrote :

To avoid conflict, please attach the debdiff only to one bug report and refer to this bug in the other bug reports. My comment to bug #73405 will apply here, too.

Revision history for this message
Mike Ramsey (mikejramsey) wrote :

I did sensors-detect and allowed it to add:
# Generated by sensors-detect on Tue Jan 5 11:47:32 2010
# Chip drivers
f71882fg

to /etc/modules

I restarted my box but x sensors is still minimized and blank.

I am running the latest Ubuntu 9.10 desktop. xsensors states that it is version 0.50.

I was following instructions found here: http://www.bradtrupp.com/ubuntu-cpu-temperature.html

Mike

Nanley Chery (nanoman)
Changed in xsensors (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Nanley Chery (nanoman)
Revision history for this message
Nanley Chery (nanoman) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, I am closing it because the bug has been fixed in the latest development version of Ubuntu - Lucid Lynx. https://launchpad.net/ubuntu/lucid/+source/xsensors/0.60-1

If you need a fix for the bug in previous versions of Ubuntu, please follow the instructions for "How to request new packages" at https://help.ubuntu.com/community/UbuntuBackports#request-new-packages

Changed in xsensors (Ubuntu):
assignee: Nanley Chery (nanoman) → nobody
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers