Gslideshow doesn't work, images are not read

Bug #971140 reported by Jose Manuel on 2012-04-01
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xscreensaver (Ubuntu)
Undecided
Unassigned

Bug Description

When i set a local directory with images on xscreensaver, these images are not used by gslideshow.

When i run xscreensaver-demo from the terminal, log show: "Can't locate LWP/Simple.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.14.2 /usr/local/share/perl/5.14.2 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.14 /usr/share/perl/5.14 /usr/local/lib/site_perl .) at /usr/bin/xscreensaver-getimage-file line 53.
BEGIN failed--compilation aborted at /usr/bin/xscreensaver-getimage-file line 53."
I think this is related with the problem to load images.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xscreensaver 5.15-2ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-20.33-generic-pae 3.2.12
Uname: Linux 3.2.0-20-generic-pae i686
NonfreeKernelModules: wl
ApportVersion: 1.95-0ubuntu1
Architecture: i386
Date: Mon Apr 2 00:40:20 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta i386 (20120328)
ProcEnviron:
 TERM=xterm
 LANG=es_ES.UTF-8
 SHELL=/bin/bash
SourcePackage: xscreensaver
UpgradeStatus: No upgrade log present (probably fresh install)

Jose Manuel (calajose) wrote :
Jose Manuel (calajose) wrote :

I found the following bug for "archlinux": https://bugs.archlinux.org/task/27978

Likely, it is the same bug, and is solved on xscreensaver 5.15-3.

Josef Cacek (josef-cacek) wrote :

There is a missing dependency on libwww-perl.
So workaround is to run:
sudo aptitude install libwww-perl

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xscreensaver (Ubuntu):
status: New → Confirmed
Tormod Volden (tormodvolden) wrote :

Thanks for the bug report. This was fixed in Debian with xscreensaver-5.15-3 and will be fixed in Ubuntu when that or a newer version is merged.

Changed in xscreensaver (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xscreensaver - 5.15-3ubuntu1

---------------
xscreensaver (5.15-3ubuntu1) saucy; urgency=low

  * Merge from Debian unstable. Remaining changes:
    - debian/control:
      + Add Vcs-Bzr link
      + Add/Update replaces with Ubuntu versions
      + Update package descriptions to list Ubuntu screensavers
    - debian/rules:
      + Use /usr/share/backgrounds as image directory
      + Add translation domain to .desktop files
    - debian/source_xscreensaver.py:
      + Add apport hook
    - debian/split-hacks.config:
      + Use different set of default hacks than Debian
    - debian/xscreensaver.dirs
      + Install /usr/share/backgrounds. By default, settings search in
        /usr/share/backgrounds and without it, it displays an error
    - debian/patches/53_XScreenSaver.ad.in.patch:
      + Use Ubuntu branding
    - debian/patches/60_sequential_glslideshow.patch:
      + Allow going through images sequentially rather than just at random in
        the GLSlideshow hack.
 -- Adam Conrad <email address hidden> Wed, 17 Jul 2013 13:47:29 +0100

Changed in xscreensaver (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers