xscreensaver v 4.23 has a bug, where the screensaver icon is not at >System >Prefrences >(screensaver)

Bug #86416 reported by Andrew on 2007-02-20
4
Affects Status Importance Assigned to Milestone
xscreensaver (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xscreensaver

Xscreensaver icon from >system > prefrences > (screensaver) with version 4.23 (dapper) is gone! when you FORCE to v4.21 it works fine.

Andrew (keen101) wrote :

this still seems to be the case in feisty with the latest version. I must use a custom launcher to access the options for xscreensaver.

Tormod Volden (tormodvolden) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

Please attach a screenshot if the icon is still missing.

Changed in xscreensaver:
assignee: nobody → tormodvolden
status: New → Incomplete
Andrew (keen101) wrote :

I don't really like Gnome Screensaver, so I like to uninstall it, and install xscreensaver instead. But, there is never a launcher on the panel to change the settings. Instead I have to use a custom launcher with the command "xscreensaver-demo".

Yep, this is still a problem with gutsy.

Not sure if it's just my system, because I always have weird icon issues.

Tormod Volden (tormodvolden) wrote :

I will try to fix this in the next version. The xscreensaver package actually ships /usr/share/xscreensaver/gnome-screensaver-properties.desktop but it is hidden with NoDisplay=true. It's like this in Debian because there the xscreensaver package is not split up like in Ubuntu, and therefore both xscreensaver and gnome-screensaver are installed, and the unused one must be hidden. We don't need to hide it Ubuntu.

Can you please edit /usr/share/xscreensaver/gnome-screensaver-properties.desktop and remove the NoDisplay=true line and see if it fixes your problem?

Changed in xscreensaver:
status: Incomplete → In Progress
Tormod Volden (tormodvolden) wrote :

Actually I am not sure that what I said is valid for 4.25. Anyway 5.04 is in Hardy, and once we have fixed it up a little, I hope we can make a backport for Gutsy.

Andrew (keen101) wrote :

cool.

thanks. :)

Tormod Volden (tormodvolden) wrote :

I believe I have fixed this in the new version, available for testing at https://launchpad.net/~tormodvolden/+archive (Gutsy). I would be glad if you could test it and report back, also if you see regressions of any kind.

Changed in xscreensaver:
assignee: tormodvolden → nobody
status: In Progress → Fix Committed
Andrew (keen101) wrote :

I added

deb http://ppa.launchpad.net/tormodvolden/ubuntu gutsy main

to my third party repositories, and upgraded xscreensaver.

It seems great so far! The icon is back, and nothing seems to have regressed further!

Awesome! A great Christmas present.

Thanks,

-Andrew
-keen101

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xscreensaver - 5.04-2ubuntu2

---------------
xscreensaver (5.04-2ubuntu2) hardy; urgency=low

  * 54_drivers_demogtk.patch: Patching a compile failure with
     GTK+ in Hardy
  * 28_rotate.patch: Add in the gdk pixbuf function to rotate JPEGs and
     TIFFs so that they're the right direction
  * debian/control: Increasing the GTK+ version to 2.12 for the patch
     28_rotate.patch
  * glslideshow.desktop: Changing so that it shows only one image, one
     time and no extra black on the edges.

xscreensaver (5.04-2ubuntu1) hardy; urgency=low

  * Merge from debian unstable, remaining changes: (LP: #177126)
    - Split xscreensaver into xscreensaver, xscreensaver-data
      (hacks we ship), xscreensaver-data-extra (hacks in universe).
      Split out GL hacks for universe to xscreensaver-gl-extra
    - create and install .desktop files for gnome-screensaver
    - debian/control: add Build-Depends on ubuntu-artwork
    - debian/rules: use /usr/share/backgrounds
    - 60_ubuntu-add-ant-hack.patch: bring back ant hack
    - 62_ubuntu-texturl-fridge.patch: use Ubuntu fridge for rss
    - 65_ubuntu-no-pam-conf: don't ship pam.conf
  * 70_ubuntu-xscreensaver-desktop.patch: name the xscreensaver desktop
    file for what it is to not confuse it with gnome-screensaver
  * debian/control: warn about gnome-screensaver conflict in
    xscreensaver package description (LP: #74727)
  * debian/rules: don't hide the xscreensaver desktop icon if the
    user insists on installing xscreensaver (LP: #86416)
  * 60_ubuntu-add-ant-hack.patch refreshed to include "ant" in
    application defaults (LP: #160669)
  * Fixed upstream: glhanoi assertion failure (LP: #71795)

xscreensaver (5.04-2) unstable; urgency=low

  [Tormod Volden]
  * debian/rules:
   + Moved POT generation from clean to build.
   + Now xscreensaver.svg is copied from `debian/` at build time.
  * po/xscreensaver.pot:
   + Is now deleted since it is autogenerated.
  * debian/control:
   + Added libxss-dev, libxtst-dev, libxxf86misc-dev and x-dev as
   build depends.
   + Added quilt and removed dpatch from build-depends.
  * debian/patches/00_maindiffwithorig.patch got split up in:
    - 20_hacks_Makefile.patch: add xpm libs for "maze" hack
    - 22_hacks_barcode.patch: make family-friendly
    - 23_hacks_glx_glsnake.patch: make family-friendly
    - 30_hacks_xanalogtv.patch: use logo-50-bad.xpm
    - 31_utils_images_logo-50-bad-xpm.patch: less colours
    - 50_driver_screensaver-properties-desktop.patch: use svg icon
  [Jose Luis Rivas]
  * debian/xscreensaver.files:
   + Added m6502 (without manpage at the moment) and abstractile
   hacks.
  * debian/xscreensaver-gl.files:
   + Added moebiusgears and lockward hacks. (Closes: #454601)
  * debian/control:
   + Added Tormod Volden as Uploader.
   + Updated to 3.7.3 Standards-Version, no modification needed.
  * debian/xscreensaver.install:
   + Now xscreensaver.svg is in `debian/`.

 -- Ted Gould <email address hidden> Wed, 23 Jan 2008 19:00:20 +0000

Changed in xscreensaver:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers