installing xscreensaver package prevents laptop resume

Bug #74727 reported by Jens on 2006-12-06
4
Affects Status Importance Assigned to Milestone
xscreensaver (Ubuntu)
Undecided
Unassigned

Bug Description

Hello,

when I resume from suspend to RAM or disk, or just standby, I get a password prompt. After entering this, I get a totally blank screen, not even a mouse cursor, when xscreensaver is installed. The system did not crash - i can login remotely, or force-restart the X11 server (ctrl-alt-backspace), and I once even saw a yellow Gnome notification popup about my battery being almost empty - but I don't see my desktop and I don't see a mouse pointer.

Removing this package (and the -gl package) solves this, but IMHO it's not obvious - I installed the xscreensaver package because I wanted more choice regarding the screensaver modules.

Perhaps this can be fixed, or alternatively I would propse the xscreensaver package to be removed, at least until this is resolved. Not being able to login after the screensaver activates is a serious bug, IMHO.

Jens

Oliver Grawert (ogra) wrote :

the xscreensaver packge contains the binary that replaces gnome-screensaver and isnt integrated with power management or the desktop at all, if you want additional screensaver "hacks" install the xscreensaver-data, xscreensaver-data-universe and the xscreensaver-gl/-universe packages (also rss-glx is worth a look here)

Changed in gnome-screensaver:
status: Unconfirmed → Rejected
Jens (jens-launchpad-net) wrote :

Thanks for your quick reply!
It *replaces* gnome-screensaver? Then why wasn't I warned about this? gnome-screensaver was not deleted!
This should not happen on a desktop distribution, IMHO. If xscreensaver breaks power management and effectively breaks your system, it needs to be removed, or fixed.

Changed in gnome-screensaver:
status: Rejected → Confirmed
Tormod Volden (tormodvolden) wrote :

Since gnome-screensaver works better, it is installed by default. xscreensaver is available for special cases, for instance desktops without Gnome. We could make it conflict with gnome-screensaver, but that would for instance inhibit having one user using one and another user the other.

The best we can do is putting a warning in the package description.

Changed in xscreensaver:
assignee: nobody → tormodvolden
status: Confirmed → In Progress
Tormod Volden (tormodvolden) wrote :

I have fixed the package description in the new version, available for testing at https://launchpad.net/~tormodvolden/+archive

Changed in xscreensaver:
assignee: tormodvolden → nobody
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xscreensaver - 5.04-2ubuntu2

---------------
xscreensaver (5.04-2ubuntu2) hardy; urgency=low

  * 54_drivers_demogtk.patch: Patching a compile failure with
     GTK+ in Hardy
  * 28_rotate.patch: Add in the gdk pixbuf function to rotate JPEGs and
     TIFFs so that they're the right direction
  * debian/control: Increasing the GTK+ version to 2.12 for the patch
     28_rotate.patch
  * glslideshow.desktop: Changing so that it shows only one image, one
     time and no extra black on the edges.

xscreensaver (5.04-2ubuntu1) hardy; urgency=low

  * Merge from debian unstable, remaining changes: (LP: #177126)
    - Split xscreensaver into xscreensaver, xscreensaver-data
      (hacks we ship), xscreensaver-data-extra (hacks in universe).
      Split out GL hacks for universe to xscreensaver-gl-extra
    - create and install .desktop files for gnome-screensaver
    - debian/control: add Build-Depends on ubuntu-artwork
    - debian/rules: use /usr/share/backgrounds
    - 60_ubuntu-add-ant-hack.patch: bring back ant hack
    - 62_ubuntu-texturl-fridge.patch: use Ubuntu fridge for rss
    - 65_ubuntu-no-pam-conf: don't ship pam.conf
  * 70_ubuntu-xscreensaver-desktop.patch: name the xscreensaver desktop
    file for what it is to not confuse it with gnome-screensaver
  * debian/control: warn about gnome-screensaver conflict in
    xscreensaver package description (LP: #74727)
  * debian/rules: don't hide the xscreensaver desktop icon if the
    user insists on installing xscreensaver (LP: #86416)
  * 60_ubuntu-add-ant-hack.patch refreshed to include "ant" in
    application defaults (LP: #160669)
  * Fixed upstream: glhanoi assertion failure (LP: #71795)

xscreensaver (5.04-2) unstable; urgency=low

  [Tormod Volden]
  * debian/rules:
   + Moved POT generation from clean to build.
   + Now xscreensaver.svg is copied from `debian/` at build time.
  * po/xscreensaver.pot:
   + Is now deleted since it is autogenerated.
  * debian/control:
   + Added libxss-dev, libxtst-dev, libxxf86misc-dev and x-dev as
   build depends.
   + Added quilt and removed dpatch from build-depends.
  * debian/patches/00_maindiffwithorig.patch got split up in:
    - 20_hacks_Makefile.patch: add xpm libs for "maze" hack
    - 22_hacks_barcode.patch: make family-friendly
    - 23_hacks_glx_glsnake.patch: make family-friendly
    - 30_hacks_xanalogtv.patch: use logo-50-bad.xpm
    - 31_utils_images_logo-50-bad-xpm.patch: less colours
    - 50_driver_screensaver-properties-desktop.patch: use svg icon
  [Jose Luis Rivas]
  * debian/xscreensaver.files:
   + Added m6502 (without manpage at the moment) and abstractile
   hacks.
  * debian/xscreensaver-gl.files:
   + Added moebiusgears and lockward hacks. (Closes: #454601)
  * debian/control:
   + Added Tormod Volden as Uploader.
   + Updated to 3.7.3 Standards-Version, no modification needed.
  * debian/xscreensaver.install:
   + Now xscreensaver.svg is in `debian/`.

 -- Ted Gould <email address hidden> Wed, 23 Jan 2008 19:00:20 +0000

Changed in xscreensaver:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers