screensaver icon not present in xfce4-settings-manager

Bug #603222 reported by Fabio Marconi on 2010-07-08
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xscreensaver (Ubuntu)
Low
Lionel Le Folgoc

Bug Description

Binary package hint: xfce4-settings

Opening Application -> settings -> xfce4 settings manager the icon of the screensaver is not present, just the write 'screensaver'
Version tested 20100708 amd64 Desktop

tags: added: iso-testing maverick
Lionel Le Folgoc (mrpouit) wrote :

Thanks for your bug report.

/usr/share/applications/xscreensaver-properties.desktop seems to contain "Icon=xscreensaver.svg", but afaik, it should not include the file extension (it works with "Icon=xscreensaver"). Reassigning.

affects: xfce4-settings (Ubuntu) → xscreensaver (Ubuntu)
Simon Steinbeiß (ochosi) wrote :

this bug still prevails in xubuntu maverick beta. the above solution proposed by lionel works. would be nice if someone could fix this "papercut".

Lionel Le Folgoc (mrpouit) wrote :

This behavior was added in debian/patches/50_driver_screensaver-properties-desktop.patch.
However, it seems the spec doesn't explicitely forbid to add a file extension, so I'll workaround that for maverick in xubuntu-default-settings until it is properly fixed in xscreensaver.

Tormod Volden (tormodvolden) wrote :

Thanks for your bug report, and for Lionel's analysis. A fix has been committed to Debian git and will appear in 5.11-2. For Maverick (and Lucid?) I will recommend Lionel's solution of removing the svg extension in the desktop file. This has to be done by refreshing debian/patches/50_driver_screensaver-properties-desktop.patch to not add the svg extension. Alternatively (like in Debian git) just drop that patch file altogether, since the StartupNotify setting it also adds, is of no use.

Changed in xscreensaver (Ubuntu):
status: New → Confirmed
Tormod Volden (tormodvolden) wrote :

I did not see Lionel's last comment before posting, so of course I was referring to his first solution. Also, as I commented in the Debian git log, the svg icon is not vectorized so there is not much reason to force the Desktop Environment to use it (instead of the xpm one).

Lionel Le Folgoc (mrpouit) wrote :

Thanks for the feedback, I'll upload a fixed version in maverick. For lucid, I'm afraid this doesn't meet the sru requirements though.

Changed in xscreensaver (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → Low
assignee: nobody → Lionel Le Folgoc (mrpouit)
Changed in xscreensaver (Ubuntu):
status: In Progress → Fix Committed
Lionel Le Folgoc (mrpouit) wrote :

Fixed in 5.11-1ubuntu2.

Changed in xscreensaver (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers