cpu-killer/power-eater screen savers

Bug #390308 reported by Witold Szczerba on 2009-06-21
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Unassigned
xscreensaver (Ubuntu)
Undecided
Unassigned

Bug Description

There are many screen savers installed by default which are actually CPU killers/power eaters.
I am sure majority of Ubuntu users do not have idea that the screen saver of their choice takes 100% of CPU, which leads to shorten life of laptops running on batteries, makes CPUs hot and in general eats power.

I suggest getting rid of all that stupid screen savers. One step further would be to implement extra warning message when given screen saver consumes too much resources.

description: updated
Przemek K. (azrael) wrote :

Isn't this problem contained in Bug #385850: Ship fewer screensavers by default ?

The problem I reported is about screen savers which are resource killers. It is not about the amount of them. I do not care if there are 80 or 20 screen savers as long as they do not defeat the purpose of saving resources in general.

Lightbreeze (nedhoy-gmail) wrote :

Please explicitly state which screen savers you have a problem with.

BioF, Bubble3D, Busy Spheres, Colorfire, Cyclone, Euphoria, Fiberlamp (this one takes "only" 50% of Athlon 2800+), Fieldlines, Flocks, Flux, Helios, Hufo's Smoke, Hufo's Tunnel, Hyperspace, JigglyPuff ("only 30%" CPU usage), Lattice, Lavalite, MatrixView, MetaBalls (+/- 80%), MirrorBlob (+/- 50%), Molecule (+/- 50%), Plasma, Skyrocket, Solarwinds, SpiographX, Sundancer2, XLyap (+/- 80%).

Let me count, I have 80 screen savers (this was default Ubuntu 8.04 installation upgraded to 8.10) and 27 of them should be banned because they are everything but "savers".

The system:
Ubuntu 8.10 x86-32
Athlon 2800+ (single core)
nVidia 180.11 driver
glxgears: 21332 frames in 5.0 seconds = 4263.681 FPS

Lightbreeze (nedhoy-gmail) wrote :

Thank you for bringing this bug to our attention. Unfortunately a 'paper cut' should be a small usability issue that affects many people and is quick and easy to fix. I'm afraid this bug can't be addressed as part of this project.

A 'paper cut' is a minor usability annoyance that an average user would encounter on his/her first day of using a new installation of Ubuntu 9.10.

Please see my comment on Bug #390308. I hope your suggestions are taken into account for the screensavers kept in Ubuntu 9.10.

Changed in hundredpapercuts:
status: New → Invalid
Lightbreeze (nedhoy-gmail) wrote :

Bug #385850, sorry.

 Lightbreeze wrote 12 minutes ago:
Unfortunately a 'paper cut' should be a small usability issue that affects many people and is quick and easy to fix.

This is EXACTLY why I considered this issue a perfect fit for a 'paper cut'.
It is usability issue and is extremely easy to fix, just get rid of "invalid" screen savers and the issue is fixed.

By the way: why, on Earth, have you asked me to enumerate all those screen savers, which took me a while, just to change the status to invalid after I did my job?

Lightbreeze (nedhoy-gmail) wrote :

Whether it is a paper cut or not, this is still a very real bug. I'm glad you have found it and are willing to take so much time to help identify the screensavers that have problems. I am setting this to New and will leave it to someone else to decide whether this issue is a 'paper cut'.

Changed in hundredpapercuts:
status: Invalid → New

Seriously, thank you for your time spent :)

Power saving is a very important topic. I just made it an invalid paper cut
because no screensavers are used in a default install. I'll leave it to
someone else to decide :-)

On Mon, Jun 22, 2009 at 7:14 PM, Witold Szczerba
<email address hidden>wrote:

> Lightbreeze wrote 12 minutes ago:
> Unfortunately a 'paper cut' should be a small usability issue that affects
> many people and is quick and easy to fix.
>
> This is EXACTLY why I considered this issue a perfect fit for a 'paper
> cut'.
> It is usability issue and is extremely easy to fix, just get rid of
> "invalid" screen savers and the issue is fixed.
>
> By the way: why, on Earth, have you asked me to enumerate all those
> screen savers, which took me a while, just to change the status to
> invalid after I did my job?
>
> --
> cpu-killer/power-eater screen savers
> https://bugs.launchpad.net/bugs/390308
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in One Hundred Paper Cuts: Invalid
> Status in “xscreensaver” source package in Ubuntu: New
>
> Bug description:
> There are many screen savers installed by default which are actually CPU
> killers/power eaters.
> I am sure majority of Ubuntu users do not have idea that the screen saver
> of their choice takes 100% of CPU, which leads to shorten life of laptops
> running on batteries, makes CPUs hot and in general eats power.
>
> I suggest getting rid of all that stupid screen savers. One step further
> would be to implement extra warning message when given screen saver consumes
> too much resources.
>

Witold, we will use the list you provided when deciding which screensavers to keep when fixing Bug #385850. Thank you!

The pleasure is mine :)

Tormod Volden (tormodvolden) wrote :

Witold and David, as I wrote in bug #385850, see https://wiki.ubuntu.com/X/Screensavers and please contribute your own measurements. Note that the results depend on your graphic cards and drivers.

I am closing the hundredpapercuts task since this is not trivial to fix correctly. For the xscreensaver task, I am pretty sure there already is an open bug about this issue.

Changed in hundredpapercuts:
status: New → Invalid
Joseph Rumpsa (jrumpsa) wrote :

I believe that you should keep all of the screen savers, I run a fairly decent machine and liked to show it off a bit with lattice as my screensaver. However, it has been removed in 9.10 along with many others (it seems everything using GL as its rendering?). I just think that it is up to the user to decide if they want a power hungry SS instead of just not including them. I do agree with the usage statistics in the selection of the SS to choose weather or not you want to be conservative.

Tormod Volden (tormodvolden) wrote :

Joseph, all the hacks are still shipped, you just need to install xscreensaver-data-extra and xscreensaver-gl-extra.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers