xscreensaver blank screen does not blank entire screen

Bug #308235 reported by Andrew Agno on 2008-12-15
4
Affects Status Importance Assigned to Milestone
xscreensaver (Debian)
Fix Released
Unknown
xscreensaver (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xscreensaver

I have two video cards powering three monitors. Two 1920x1200 using nvidia's twinview attached to a 9600 GT. The other monitor is 1200x1600 attached to a 7600GT. This latter monitor has been rotated using xrandr -o right. When I lock the screen (blank only, locking at 0 minutes), the 1200x1600 portrait mode screen is only blacked out in what appears to be a 1200x1200 square. The entire screen fades, but only the square gets blanked. Switching to the circuits screen saver shows that the screen saver is probably blanking out a 1600x1200 rectangle instead of 1200x1600.

This results in an information leak, given that some contents of my windows show up, even though the screen saver is active and locked.

Using:
Description: Ubuntu 8.10

xscreensaver:
  Installed: 5.07-0ubuntu3

Up-to-date as of 2008 Dec 15

WORKAROUND: Set GetViewPortIsFullOfLies True in .xscreensaver

Andrew Agno (ubuntu-agno) wrote :
Tormod Volden (tormodvolden) wrote :

Thanks for your report. Something similar (rotation on nvidia) was reported upstream in http://jwz.livejournal.com/908354.html?thread=17459266#t17459266

Can you please stop the saver daemon with "xscreensaver-command -q" then relaunch it in a terminal window with "xscreensaver -verbose" and attach the output here?

Also the output from "xwininfo -root" and "xrandr --verbose" can be useful, as well as Xorg.0.log.

Changed in xscreensaver:
status: New → Incomplete
Andrew Agno (ubuntu-agno) wrote :

Attached file for xscreensaver --verbose

Andrew Agno (ubuntu-agno) wrote :

Attached file for xwininfo --root on rotated display

Andrew Agno (ubuntu-agno) wrote :

Attached file for xrandr --verbose on rotated display

Andrew Agno (ubuntu-agno) wrote :

Attached Xorg.0.log

Andrew Agno (ubuntu-agno) wrote :

As additional information, I've attached the xwininfo and xrandr output for the non-rotated display, though I suspect it won't be needed.

Andrew Agno (ubuntu-agno) wrote :

After perusing the .xscreensaver file, I noticed there is a GetViewPortIsFullOfLies configuration. Setting that to true blanks everything. The man page says:

       GetViewPortIsFullOfLies (class Boolean)
               Set this to true if the xscreensaver window doesn’t cover the whole screen. This works around a longstanding XFree86 bug #421. See the xscreensaver FAQ for details.

Andrew Agno (ubuntu-agno) wrote :

Regarding the XFree86_bug 421, is there any way this is going to get fixed in the xorg server?

Tormod Volden (tormodvolden) wrote :

I think that bug (http://bugs.xfree86.org/show_bug.cgi?id=421) is obsolete, at least for us since we're using xorg. Does the GetViewPortIsFullOfLies setting fully resolve the issue for you?

Andrew Agno (ubuntu-agno) wrote :

Well, I'd describe it as a workaround and not a real fix, but like any good workaround, it makes the problem go away. Given the XScreenSaver FAQ, though, this seems to indicate an error in the xorg server (or possibly in the *scan_monitors functions in xscreensaver), which is what my last comment was alluding to.

Tormod Volden (tormodvolden) wrote :

The linked Debian bug discusses this problem AFAICS, although its original bug description is on another issue. http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=494267#88

Changed in xscreensaver:
status: Incomplete → Confirmed
description: updated
Andrew Agno (ubuntu-agno) wrote :

Ah, great. The patch in that attached report works for me, with xscreensaver blanking all my monitors, even when I have GetViewPortIsFullOfLies:False

Changed in xscreensaver (Debian):
status: Unknown → Fix Released
Tormod Volden (tormodvolden) wrote :

This should be fixed in lucid, which has xscreensaver 5.10. Please reopen if it is still an issue.

Changed in xscreensaver (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.