xscreensaver-gl should not Recommend xscreensaver

Bug #242495 reported by Chris Halse Rogers on 2008-06-23
24
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xscreensaver (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: xscreensaver

xscreensaver-gl currently Recommends xscreensaver:
└─(1:07:32:%)── aptitude why xscreensaver ──(Tue,Jun24)─┘
i ubuntu-desktop Depends xscreensaver-gl
pi xscreensaver-gl Recommends xscreensaver

With recommends-by-default, we don't want this behaviour; this will result in both gnome-screensaver and xscreensaver being installed, which is confusing and unnecessary. This could possibly change to xscreensaver | gnome-screensaver | some-other-screensaver.

Changed in xscreensaver:
importance: Undecided → Low
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xscreensaver - 5.05-1ubuntu2

---------------
xscreensaver (5.05-1ubuntu2) intrepid; urgency=low

  * xscreensaver-gl and xscreensaver-gl-extras Recommend xscreensaver |
    gnome-screensaver rather than merely xscreensaver, so that germinate
    won't pull xscreensaver into the desktop (LP: #242495).

 -- Colin Watson <email address hidden> Fri, 04 Jul 2008 17:18:38 +0100

Changed in xscreensaver:
status: Confirmed → Fix Released
Tormod Volden (tormodvolden) wrote :

What about KDE and kscreensaver-xsavers (or kscreensaver-xsavers-kde4)?

Reopened: looks like the fix got lost in the latest upload, they now recommend xscreensaver only again.

Tormod Volden (tormodvolden) wrote :

We fixed this to use "Suggests" in Debian, but then the Ubuntu maintainer made his own release instead...

Changed in xscreensaver:
status: Fix Released → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xscreensaver - 5.07-0ubuntu2

---------------
xscreensaver (5.07-0ubuntu2) intrepid; urgency=low

  * Restore the fix from 5.05-1ubuntu2, which was lost in the latest
    merge:
  * xscreensaver-gl and xscreensaver-gl-extras Recommend xscreensaver |
    gnome-screensaver rather than merely xscreensaver, so that germinate
    won't pull xscreensaver into the desktop (LP: #242495).

 -- Steve Langasek <email address hidden> Wed, 08 Oct 2008 23:07:41 +0000

Changed in xscreensaver:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers