syntax error in desktop file

Bug #1871797 reported by Laurent Bonnaud
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
xscreensaver (Debian)
Fix Released
Unknown
xscreensaver (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,

when I install this package, I get the following error message:

Could not parse file "/usr/share/applications/screensavers/glitchpeg.desktop": Key file contains line ?several times a second. After a while, finds a new image to corrupt. Written by Jamie Zawinski; 2018.? which is not a key-value pair, group, or comment

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: xscreensaver-data-extra 5.42+dfsg1-1ubuntu1
Uname: Linux 5.6.3-050603-generic x86_64
ApportVersion: 2.20.11-0ubuntu25
Architecture: amd64
CurrentDesktop: KDE
Date: Thu Apr 9 10:37:19 2020
SourcePackage: xscreensaver
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Laurent Bonnaud (laurent-bonnaud) wrote :
Revision history for this message
Bill McGonigle (bill-launchpad-net) wrote :

not a proper source patch, but shows the line that needs fixing to stop complaints under apt.

Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "remove spurious newline" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xscreensaver (Ubuntu):
status: New → Confirmed
Changed in xscreensaver (Debian):
importance: Undecided → Unknown
status: New → Unknown
Changed in xscreensaver (Debian):
status: Unknown → Fix Committed
Changed in xscreensaver (Debian):
status: Fix Committed → Fix Released
tags: added: groovy hirsute
Revision history for this message
Bayu Aditya H. (bayuah) wrote :

So, when the fix applied to the release? This is more than 4 months since the fix available.

I remember, maybe a month ago, I manually edit "/usr/share/applications/screensavers/glitchpeg.desktop" to remove the newline, but for some reason, the file is overwritten to the old one that broken, probably during "apt upgrade".

$ ls --full-time /usr/share/applications/screensavers/glitchpeg.desktop
-rw-r--r-- 1 root root 389 2019-01-28 04:40:05.000000000 +0700 /usr/share/applications/screensavers/glitchpeg.desktop

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.