Langton's Ant saver doesn't show up in xScreensaver list

Bug #160669 reported by Daryl Van Humbeck on 2007-11-07
4
Affects Status Importance Assigned to Milestone
xscreensaver (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xscreensaver-data-extra

Whenever I install another version of Ubuntu (or create a new user), the Langton's Ant screensaver (/usr/share/applications/screensaver/ant.desktop, or /usr/lib/xscreensaver/ant) doesn't show up in the xScreensaver configuration list and I have to add a line for it by hand with a text editor.

Is there a way for this to be in the list by default?

Tormod Volden (tormodvolden) wrote :

It should appear in the list in System->Preferences->Screensaver
Are you not using Gnome (default Ubuntu desktop)?
Which configuration file do you edit?

Changed in xscreensaver:
assignee: nobody → tormodvolden
status: New → Incomplete

Despite the fact that I'm using Xfce and not Gnome, this problem is not Xfce-specific.
I have this same problem with gnome-screensaver package as well as the xscreensaver package.

The file I edited was ~/.xscreensaver and the line I added was as follows:
        "Langton's Ant" ant -root n\

The problem sounds like it's in the default version of this file not having this line.
(and I've checked, this is the proper name for this saver)

Tormod Volden (tormodvolden) wrote :

This will be probably be fixed in the next version of xscreensaver-data-extra, at least for gnome-screensaver usage.

What happens if you delete the ~/.xscreensaver file (take a backup of it first)? This file is not shipped (or updated) with new packages, and was maybe created by an earlier version which didn't have "ant" available.

Changed in xscreensaver:
status: Incomplete → In Progress

When I rename the file to ~/.xscreensaver.old and run xscreensaver-demo, "Langton's Ant" disappears and I have to insert the above line back into the file.
(and yes, I have all xscreensaver packages installed, so that's not the problem. I do also wonder just which other savers aren't listed, though that would be for another bug and another time)

I do know that this has been/is a problem for the following versions of (X)Ubuntu: Dapper Drake (version 4.23-4ubuntu8.1), Feisty Fawn (version 4.24-5ubuntu2.1) and Gutsy Gibbon (version 4.24-5ubuntu3).
(I don't know about Edgy Eft as I skipped that one on my upgrade route)

On Feisty Fawn on a fresh account running Gnome & Gnome's screensaver tool, Langton's Ant doesn't even show up in the list and I'm not sure where to add it.

As I prefer more control over the savers used, I will be using the xscreensaver package, despite the fact that it has been depreciated in Gutsy.
As a result, any update to the gnome-screensaver package that doesn't affect any of the xscreensaver* packages won't help my problem.
(also, I filed this bug against xscreensaver, NOT gnome-screensaver. Sorry to be emphatic, but I really don't like Gnome's over-simplified version and will be avoiding it as much as possible)

Tormod Volden (tormodvolden) wrote :

Actually it seems like it has been taken away from the preferences (application defaults) in the upstream release. I will ask there. Ideally you should be able to use either xscreensaver or gnome-screensaver together with the other xscreensaver-{data,data-extra,gl} packages, although gnome-screensaver is Ubuntu's out-of-the-box selection.

Tormod Volden (tormodvolden) wrote :

I believe I have fixed this in the new version, available for testing at https://launchpad.net/~tormodvolden/+archive (Gutsy). I would be glad if you could test it and report back, also if you see regressions of any kind.

Changed in xscreensaver:
assignee: tormodvolden → nobody
status: In Progress → Fix Committed

Okay, I downloaded and installed all i386 .deb packages on my Gutsy box and it works!

I renamed my .xscreensaver file and the Langton's Ant saver comes up as just Ant, and it also found several other savers that I'd never seen before, so whatever it was that you changed must have scanned for any unlisted savers.

Is there any way to backport this to Feisty?
(the computer I use more is running Feisty, though I /might/ upgrade if I think it'll help enough of the other software)

Tormod Volden (tormodvolden) wrote :

You can always just try to install the Gutsy .debs in Feisty. If is doesn't work, you can build the package yourself for Feisty. I don't think this is important enough for any official backport though.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xscreensaver - 5.04-2ubuntu2

---------------
xscreensaver (5.04-2ubuntu2) hardy; urgency=low

  * 54_drivers_demogtk.patch: Patching a compile failure with
     GTK+ in Hardy
  * 28_rotate.patch: Add in the gdk pixbuf function to rotate JPEGs and
     TIFFs so that they're the right direction
  * debian/control: Increasing the GTK+ version to 2.12 for the patch
     28_rotate.patch
  * glslideshow.desktop: Changing so that it shows only one image, one
     time and no extra black on the edges.

xscreensaver (5.04-2ubuntu1) hardy; urgency=low

  * Merge from debian unstable, remaining changes: (LP: #177126)
    - Split xscreensaver into xscreensaver, xscreensaver-data
      (hacks we ship), xscreensaver-data-extra (hacks in universe).
      Split out GL hacks for universe to xscreensaver-gl-extra
    - create and install .desktop files for gnome-screensaver
    - debian/control: add Build-Depends on ubuntu-artwork
    - debian/rules: use /usr/share/backgrounds
    - 60_ubuntu-add-ant-hack.patch: bring back ant hack
    - 62_ubuntu-texturl-fridge.patch: use Ubuntu fridge for rss
    - 65_ubuntu-no-pam-conf: don't ship pam.conf
  * 70_ubuntu-xscreensaver-desktop.patch: name the xscreensaver desktop
    file for what it is to not confuse it with gnome-screensaver
  * debian/control: warn about gnome-screensaver conflict in
    xscreensaver package description (LP: #74727)
  * debian/rules: don't hide the xscreensaver desktop icon if the
    user insists on installing xscreensaver (LP: #86416)
  * 60_ubuntu-add-ant-hack.patch refreshed to include "ant" in
    application defaults (LP: #160669)
  * Fixed upstream: glhanoi assertion failure (LP: #71795)

xscreensaver (5.04-2) unstable; urgency=low

  [Tormod Volden]
  * debian/rules:
   + Moved POT generation from clean to build.
   + Now xscreensaver.svg is copied from `debian/` at build time.
  * po/xscreensaver.pot:
   + Is now deleted since it is autogenerated.
  * debian/control:
   + Added libxss-dev, libxtst-dev, libxxf86misc-dev and x-dev as
   build depends.
   + Added quilt and removed dpatch from build-depends.
  * debian/patches/00_maindiffwithorig.patch got split up in:
    - 20_hacks_Makefile.patch: add xpm libs for "maze" hack
    - 22_hacks_barcode.patch: make family-friendly
    - 23_hacks_glx_glsnake.patch: make family-friendly
    - 30_hacks_xanalogtv.patch: use logo-50-bad.xpm
    - 31_utils_images_logo-50-bad-xpm.patch: less colours
    - 50_driver_screensaver-properties-desktop.patch: use svg icon
  [Jose Luis Rivas]
  * debian/xscreensaver.files:
   + Added m6502 (without manpage at the moment) and abstractile
   hacks.
  * debian/xscreensaver-gl.files:
   + Added moebiusgears and lockward hacks. (Closes: #454601)
  * debian/control:
   + Added Tormod Volden as Uploader.
   + Updated to 3.7.3 Standards-Version, no modification needed.
  * debian/xscreensaver.install:
   + Now xscreensaver.svg is in `debian/`.

 -- Ted Gould <email address hidden> Wed, 23 Jan 2008 19:00:20 +0000

Changed in xscreensaver:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers