xscreensaver complains "This version of xscreensaver is VERY OLD!"

Bug #1406825 reported by Václav Haisman on 2014-12-31
122
This bug affects 27 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Medium
Unassigned
xscreensaver (Debian)
Fix Released
Unknown
xscreensaver (Ubuntu)
Medium
Unassigned

Bug Description

Early minutes of year 2015 and the xscreensaver complains that "This version of xscreensaver is VERY OLD!" in this dialog: http://i.imgur.com/VUCQfun.png?1

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: xscreensaver 5.26-1ubuntu3
ProcVersionSignature: Ubuntu 3.16.0-28.38-lowlatency 3.16.7-ckt1
Uname: Linux 3.16.0-28-lowlatency x86_64
ApportVersion: 2.14.7-0ubuntu8
Architecture: amd64
CurrentDesktop: XFCE
Date: Thu Jan 1 00:44:38 2015
InstallationDate: Installed on 2011-11-13 (1144 days ago)
InstallationMedia: Xubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
SourcePackage: xscreensaver
UpgradeStatus: Upgraded to utopic on 2014-10-25 (67 days ago)

Václav Haisman (vzeman79) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xscreensaver (Ubuntu):
status: New → Confirmed
Makoto (makotothedragon) wrote :

Found a workaround: downloading the latest version from upstream Debian solves the trick.

https://packages.debian.org/sid/amd64/xscreensaver/download

Changed in hundredpapercuts:
status: New → Confirmed
Changed in xscreensaver (Ubuntu):
importance: Undecided → Medium
Changed in hundredpapercuts:
importance: Undecided → Medium
David Lee (ramchyld) wrote :

Bug also affected me. One Mythbuntu and One Xubuntu machine so far has spewed this warning. If I had powered up up my second Lubuntu machine, I'd probably see it too.

Jamin W. Collins (jcollins) wrote :

Downloading the latest Debian build will only push this issue out. The problem is that upstream (Jamie Zawinski) has added code that checks to see if the current time is more than 12 months from when xscreensaver was compiled. I can't seem to find the current revision control repository for the Ubuntu package of xscreensaver or I'd provide links to the code in question within the repository, but here are links to the code on a github repository:

https://github.com/danfuzz/xscreensaver/blob/f9983b7c0795eacde86415ca6362af0873b1cf07/driver/prefs.c#L1654
https://github.com/danfuzz/xscreensaver/blob/f9983b7c0795eacde86415ca6362af0873b1cf07/driver/splash.c#L170
https://github.com/danfuzz/xscreensaver/blob/f9983b7c0795eacde86415ca6362af0873b1cf07/driver/splash.c#L223

Seems the current 14.10 package was compiled back on December 9th, 2013. That's what's showing up in the about dialog anyway.

Herwin Weststrate (debian-1) wrote :

This feature appears to be added because the author was getting tired of bug reports for already fixes bugs, the following is on top of the function that checks if it is too old:

> Getting very tired of bug reports of already-fixed bugs due to
> Linux distros shipping multi-year-old versions.

So basically the problems have shifted from the author to the packagers/maintainers of distros. To me, that sounds like a pretty terrible idea.

Václav Haisman (vzeman79) wrote :

> So basically the problems have shifted from the author to the packagers/maintainers of distros. To me, that sounds like a pretty terrible idea.

To me it sounds like a pretty good idea, verging with awesome.

Firas Kraïem (firas) wrote :

This is absolutely ridiculous. We need an Ubuntu patch to remove the popup code.

Václav Haisman (vzeman79) wrote :

No. We need a version update of the package.

Firas Kraïem (firas) wrote :

This is not how Ubuntu works. If you want the latest version of packages, use Arch or something.

Václav Haisman (vzeman79) wrote :

Your statement is simply false. This _is_ how Ubuntu works for some packages, e.g., PostgreSQL. Why should it not work with xscreensaver?

Daniel Richard G. (skunk) wrote :

I will point out that the postgresql package is part of Ubuntu main, whereas xscreensaver is in Ubuntu universe. The distinctions between these components of the repository are described at

    https://help.ubuntu.com/community/Repositories/Ubuntu

Universe is "Community maintained software, i.e. not officially supported software. " In practice, what this usually means is that Ubuntu doesn't touch the software; they just pull whatever Debian has from time to time. (Firas, this is why an Ubuntu patch to remove the warning is not likely.)

As it happens, Debian testing/jessie does have a newer version of xscreensaver (5.30-1+b1 versus Ubuntu's 5.26-1ubuntu3). So that could be brought in, and would squelch the warning for a time longer.

I'm afraid I don't actually know who has to be nudged to make this happen, however. The package does list "Ubuntu Developers <email address hidden>" as the maintainer, so if any of you are regulars on that list, bringing it up there may lead to some action. But that's just my best guess.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xscreensaver - 5.30-1ubuntu1

---------------
xscreensaver (5.30-1ubuntu1) vivid; urgency=medium

  * Merge from Debian unstable. (LP: #1406825) Remaining changes:
    - debian/control:
      + Breaks/Replaces: the old changes are not needed anymore, but the
        new changes the screensavers sets needs it.
    - debian/rules:
      + Use /usr/share/backgrounds as image directory.
      + Add translation domain to .desktop files.
    - debian/source_xscreensaver.py:
      + Add apport hook.
    - debian/xscreensaver.dirs:
      + Install /usr/share/backgrounds. By default, settings search in
        /usr/share/backgrounds and without it, it displays an error.
    - debian/patch/90_ubuntu-branding.patch: Use Ubuntu branding.
    - debian/patches/60_sequential_glslideshow.patch:
      + Allow going through images sequentially rather than just at random in
        the GLSlideshow hack.
    - debian/patches/91_replace-gdmflexiserver.patch:
      + Use dm-tool instead of gdmflexiserver for user-switching,
        the latter is no longer provided by lightdm.

xscreensaver (5.30-1) unstable; urgency=low

  * New upstream release 5.30
    - New hack, `winduprobot'.
    - Many improvements to `lament', including Leviathan.
    - Fixed the normals in `flyingtoasters': shading is correct now.
    - Dragging has inertia now.
    - Most hacks respond to mouse-clicks, double-taps and swipes as
      meaning "do something different now".
    - Reworked OpenGL fonts.
    - Various minor fixes.
  * Bump Standards-Version to 3.9.6 (no changes needed)
  * debian/copyright: hacks/kumppa uses X11 license

xscreensaver (5.29-1) unstable; urgency=low

  * New upstream release 5.29, changes since 5.26:
    - New hacks, `tessellimage' and `projectiveplane'.
    - Added support for pthreads, because Dave Odell is a madman.
    - Updated `webcollage' for recent changes.
    - X11: Don't assume Suspend = 0 implies "No DPMS".
    - Minor updates to `boxed' and `klein'.
    - Fixed possible crash in `apple2', `noseguy', `xmatrix', `shadebobs'.
    - Plugged some leaks.
    - Fixed some compilation problems and intermittent crashes.
    - Updated `webcollage' for recent changes.
 -- Unit 193 <email address hidden> Wed, 18 Feb 2015 02:17:23 -0500

Changed in xscreensaver (Ubuntu):
status: Confirmed → Fix Released
Charlie Whitman Jr. (cwhit42) wrote :

Firas, you seem to be under the misimpression that you need the latest version to avoid this warning message. That is not true at all. You only need a version that is not quite old. The version that you get in 14.10 was not the current version of Xscreensaver (or even close to it) when 14.10 was frozen. Of course, the real problem here is that whoever volunteers to package this for universe did not update it any time recently. It's hard to complain about volunteer work, but the fact remains that the age of the package unnecessarily created a problem even for non-LTS users (for LTS users, the age of the package would be understandable).

Unit 193 (unit193) on 2015-04-10
Changed in hundredpapercuts:
status: Confirmed → Invalid
Changed in xscreensaver (Debian):
status: Unknown → New
Mikel Ward (mikelward) wrote :

Happening now on wily.

It looks like the "fix" was just to pull a more recent version of XScreenSaver, but that doesn't really address the root cause.

Changed in xscreensaver (Debian):
status: New → Fix Released
Graham Inggs (ginggs) on 2016-04-06
Changed in xscreensaver (Ubuntu):
status: Fix Released → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xscreensaver - 5.34-2ubuntu1

---------------
xscreensaver (5.34-2ubuntu1) xenial; urgency=medium

  * Merge from Debian unstable. Remaining changes: (Really fix LP: #1406825)
    - debian/control:
      + Breaks/Replaces: the old changes are not needed anymore, but the
        new changes the screensavers sets needs it.
    - debian/rules:
      + Use /usr/share/backgrounds as image directory.
      + Add translation domain to .desktop files.
    - debian/source_xscreensaver.py:
      + Add apport hook.
    - debian/xscreensaver.dirs:
      + Install /usr/share/backgrounds. By default, settings search in
        /usr/share/backgrounds and without it, it displays an error.
    - debian/patch/90_ubuntu-branding.patch: Use Ubuntu branding.
    - debian/patches/60_sequential_glslideshow.patch:
      + Allow going through images sequentially rather than just at random in
        the GLSlideshow hack.

xscreensaver (5.34-2) unstable; urgency=medium

  * Fix sort order in hacks/Makefile (for reproducible builds)
    (Closes: #819595)
  * Disable Easter egg about "outdated" version
    (Closes: #819703)

 -- Unit 193 <email address hidden> Wed, 06 Apr 2016 17:26:23 -0400

Changed in xscreensaver (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.