package xscreensaver-data 5.15-3ubuntu1 failed to install/upgrade: trying to overwrite '/usr/lib/xscreensaver/xlyap', which is also in package xscreensaver-data-extra 5.15-3ubuntu1

Bug #1319433 reported by Fila Kolodny on 2014-05-14
38
This bug affects 5 people
Affects Status Importance Assigned to Milestone
xscreensaver (Ubuntu)
Undecided
Unassigned

Bug Description

Just ran apt-get -f upgrade afterward and it worked, problem was updating xscreensaver and xscreensave-data at same time.

ProblemType: Package
DistroRelease: Ubuntu 14.10
Package: xscreensaver-data 5.15-3ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-24.47-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
ApportVersion: 2.14.2-0ubuntu2
Architecture: amd64
Date: Wed May 14 10:44:57 2014
DuplicateSignature: package:xscreensaver-data:5.15-3ubuntu1:trying to overwrite '/usr/lib/xscreensaver/xlyap', which is also in package xscreensaver-data-extra 5.15-3ubuntu1
ErrorMessage: trying to overwrite '/usr/lib/xscreensaver/xlyap', which is also in package xscreensaver-data-extra 5.15-3ubuntu1
InstallationDate: Installed on 2014-02-24 (78 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
SourcePackage: xscreensaver
Title: package xscreensaver-data 5.15-3ubuntu1 failed to install/upgrade: trying to overwrite '/usr/lib/xscreensaver/xlyap', which is also in package xscreensaver-data-extra 5.15-3ubuntu1
UpgradeStatus: No upgrade log present (probably fresh install)

Fila Kolodny (fila) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xscreensaver (Ubuntu):
status: New → Confirmed
Cavsfan (cavsfan) wrote :

Got the same error during apt-get upgrade on xscreensaver-data_5.26-1ubuntu1_amd64.deb.
But I too ran apt-get -f upgrade afterward and it worked.

Mattia Rizzolo (mapreri) on 2014-05-18
Changed in xscreensaver (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Mattia Rizzolo (mapreri)
Mattia Rizzolo (mapreri) wrote :

ya, missed a 'r' in Replaces field....
This should fix the issue.

tags: added: patch
Changed in xscreensaver (Ubuntu):
status: In Progress → Opinion
status: Opinion → New
assignee: Mattia Rizzolo (mapreri) → nobody

The attachment "5.26-1u1_5.26-1u2.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

Martin Pitt (pitti) wrote :

Thanks Mattia!

Changed in xscreensaver (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xscreensaver - 5.26-1ubuntu2

---------------
xscreensaver (5.26-1ubuntu2) utopic; urgency=medium

  * debian/control: Fix typo in Repleaces on xscreensaver-data
    (LP: #1319433).
 -- Mattia Rizzolo <email address hidden> Sun, 18 May 2014 19:34:54 +0200

Changed in xscreensaver (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers