newly installed xscreensaver errors without /usr/share/backgrounds

Bug #129769 reported by pearlbear on 2007-08-01
18
Affects Status Importance Assigned to Milestone
xscreensaver (Ubuntu)
Low
Steve Langasek

Bug Description

Binary package hint: xscreensaver

Kubuntu Fiesty, installed xfce, and installed xscreensaver and xscreensaver-data (plus all recommended packages). When you open up the settings panel, every action results in a dialog box with the error "Directory does not exist: /usr/share/backgrounds". Creating the directory got rid of the error.

Related branches

Tormod Volden (tormodvolden) wrote :

Do you have the screensaver-default-images package installed? It is part of ubuntu-desktop and xubuntu-desktop.

For some reason screensaver-default-images depends on xscreensaver-data and not the other way around...

Changed in xscreensaver:
assignee: nobody → tormodvolden
status: New → Incomplete
Tormod Volden (tormodvolden) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in xscreensaver:
assignee: tormodvolden → nobody
status: Incomplete → Invalid
BassKozz (basskozz+ubuntu) wrote :

I had similar problems and installing 'screensaver-default-images' seems to have done the trick.
Thanks Tormod :)

Tormod Volden (tormodvolden) wrote :

Does that mean that you did not have (x)ubuntu-desktop or installed?

Tormod Volden (tormodvolden) wrote :

We should maybe let xscreensaver recommend screensaver-default-images, since we ship xscreensaver with /usr/share/background as default imageDirectory.

Changed in xscreensaver:
status: Invalid → Confirmed
infoseeker (chrisretief) wrote :

I have Intrepid (Kubuntu, beta version) installed and I, too, get this error. Installing 'screensaver-default-images' fixed the problem.

infoseeker (chrisretief) wrote :

Correction....Jaunty (Kubuntu, beta version) installed, which gives me the error.

CyberZilla (cyberzilla98) wrote :

having trouble doing this: "install screensaver-default-images". newbie with Kubuntu Intrepid (8.10). Need more clues... more info please. Much appreciated. Hard not to get frustrated when help forums blurt out "oh just do this" and then leave out half the steps needed to actually do it. thanks. Cy.

www.cyberzilla.com

Tormod Volden (tormodvolden) wrote :

CyberZilla, did you take the time to look at help.ubuntu.com, or even look through your System menu? The bug tracker is the last place you should ask for help. "apt-get install screensaver-default-images"

Actually "Bug Tracker" IS the place to ask for help. Its a bug, right? and your attitude sucks by the way.

You should be telling me the bug will be fixed by next release instead of sending sarcastic e-mails.

> Date: Sat, 25 Apr 2009 08:47:36 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 129769] Re: newly installed xscreensaver errors without /usr/share/backgrounds
>
> CyberZilla, did you take the time to look at help.ubuntu.com, or even
> look through your System menu? The bug tracker is the last place you
> should ask for help. "apt-get install screensaver-default-images"
>
> --
> newly installed xscreensaver errors without /usr/share/backgrounds
> https://bugs.launchpad.net/bugs/129769
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “xscreensaver” source package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: xscreensaver
>
> Kubuntu Fiesty, installed xfce, and installed xscreensaver and xscreensaver-data (plus all recommended packages). When you open up the settings panel, every action results in a dialog box with the error "Directory does not exist: /usr/share/backgrounds". Creating the directory got rid of the error.

CyberZilla (cyberzilla98) wrote :

Actually "Bug Tracker" IS the place to ask for help. Its a bug, right? and your attitude sucks by the way.

You should be telling me the bug will be fixed by next release instead
of sending sarcastic e-mails.

> Date: Sat, 25 Apr 2009 08:47:36 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 129769] Re: newly installed xscreensaver errors without /usr/share/backgrounds
>
> CyberZilla, did you take the time to look at help.ubuntu.com, or even
> look through your System menu? The bug tracker is the last place you
> should ask for help. "apt-get install screensaver-default-images"
>
> --
> newly installed xscreensaver errors without /usr/share/backgrounds
> https://bugs.launchpad.net/bugs/129769
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “xscreensaver” source package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: xscreensaver
>
> Kubuntu Fiesty, installed xfce, and installed xscreensaver and xscreensaver-data (plus all recommended packages). When you open up the settings panel, every action results in a dialog box with the error "Directory does not exist: /usr/share/backgrounds". Creating the directory got rid of the error.

Julien Lavergne (gilir) wrote :

Attached is a debdiff to fix the problem. It's simply create an empty /usr/share/backgrounds directory when xscreensaver is installed.

Changed in xscreensaver (Ubuntu):
importance: Undecided → Low
Colin Watson (cjwatson) wrote :

Thanks, Julien. I'll apply this, although I'm going to rename debian/dirs to debian/xscreensaver.dirs; this means the same in this case since xscreensaver is the first package in debian/control, but in a multi-binary package it makes it a bit clearer what's going on, and that's how the xscreensaver packaging does other things right now.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xscreensaver - 5.08-0ubuntu5

---------------
xscreensaver (5.08-0ubuntu5) karmic; urgency=low

  * Add debian/xscreensaver.dirs with /usr/share/backgrounds. By default,
    settings search in /usr/share/backgrounds and without it, it displays an
    error (LP: #129769)

 -- Julien Lavergne <email address hidden> Sun, 13 Sep 2009 17:28:51 +0200

Changed in xscreensaver (Ubuntu):
status: Confirmed → Fix Released
Tormod Volden (tormodvolden) wrote :

Please make sure the new version is also pushed to https://code.edge.launchpad.net/~ubuntu-desktop/xscreensaver/ubuntu

Julien Lavergne (gilir) wrote :

The changes was lost with the last merge.

Changed in xscreensaver (Ubuntu):
status: Fix Released → Confirmed
Steve Langasek (vorlon) wrote :

Uploaded to the beta freeze queue.

Changed in xscreensaver (Ubuntu):
assignee: nobody → Steve Langasek (vorlon)
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xscreensaver - 5.10-3ubuntu2

---------------
xscreensaver (5.10-3ubuntu2) lucid; urgency=low

  * Reintroduce changes lost from version 5.08-0ubuntu5:

  [ Julien Lavergne ]
  * Add debian/xscreensaver.dirs with /usr/share/backgrounds. By default,
    settings search in /usr/share/backgrounds and without it, it displays an
    error (LP: #129769)
 -- Steve Langasek <email address hidden> Tue, 06 Apr 2010 08:10:22 +0000

Changed in xscreensaver (Ubuntu):
status: Fix Committed → Fix Released
Koos (kobusco) wrote :

I am new to ubuntu and see this directory when I right click on the photo of a tree. What should i do?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers