apt-get remove xscreensaver >>> "No such file or directory"

Bug #1275015 reported by Richard Elkins on 2014-01-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xscreensaver (Debian)
Fix Released
Unknown
xscreensaver (Ubuntu)
Undecided
Unassigned

Bug Description

Running in Trusty Alpha 2 up-to-date.
Package: xscreensaver 5.15-3ubuntu1
Version of apt: 0.9.14.1ubuntu2

Subject file: /usr/bin/xscreensaver

Script:
set -x
sudo apt-get -y remove xscreensaver
sudo apt-get -y install xscreensaver
which xscreensaver
sudo apt-get -y remove xscreensaver

The execution of `which` returns the status that the file does exist. Sometime during the remove execution, some subordinate process goes looking for it after it was already removed by another subprocess.

I reported this against the package definition itself because I have never seen apt get confused before (my best guess). Please note that this is a minor issue and has no significant impact to Trusty operations.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: xscreensaver 5.15-3ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-5.20-generic 3.13.0
Uname: Linux 3.13.0-5-generic x86_64
ApportVersion: 2.13.2-0ubuntu2
Architecture: amd64
CurrentDesktop: XFCE
Date: Fri Jan 31 10:54:37 2014
InstallationDate: Installed on 2014-01-31 (0 days ago)
InstallationMedia: Xubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140126)
SourcePackage: xscreensaver
UpgradeStatus: No upgrade log present (probably fresh install)

Richard Elkins (texadactyl) wrote :
description: updated
description: updated
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1275015

tags: added: package-qa-testing
Changed in xscreensaver (Debian):
status: Unknown → Fix Released
Richard Elkins (texadactyl) wrote :

Thank you, Tormod.

This is still a (very) minor anomaly in Ubuntu Trusty on 2014-03-24 CDT. The Debian bug report (https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=681613) shows:

     Found in version xscreensaver/5.15-3
     Fixed in version xscreensaver/5.22-1

The Ubuntu Trusty versions (common) of xscreensaver is currently 5.15-3ubuntu1. So, it appears that the Debian fix has not yet been propagated to the Ubuntu repository.

Richard Elkins (texadactyl) wrote :

Marked "fix released" because I can no longer reproduce the symptom as of Xubuntu 14.04.2. Yes, it might have been fixed in an earlier release.

Changed in xscreensaver (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.