xscreensaver-settings breaks imageDirectory line if it is a URL

Bug #1116006 reported by Sven Hergenhahn on 2013-02-05
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xscreensaver (Ubuntu)
Undecided
Unassigned

Bug Description

xscreensaver 5.15 (5.15-2ubuntu1)
in Ubuntu 12.10

The URL that can be set in the GUI (Advanced->"Choose Random Image" (or imageDirectory in .xscreensaver, it doesn't matter) is broken almost immediately after having used xscreensaver-settings

For example, putting

imageDirectory: http://www.degraeve.com/flickr-rss/rss.php?tags=heidelberg&num=20

into .xscreensaver and not running xscreensaver-settings works as expected and it does show images of the RSS feed.

However, as soon as I click on the "Settings"-Button, and the "Advanced", I'm presented with an error message that the directory does not exist, and then - checking either the GUI or the .-file, the URL is broken like as follows:

imageDirectory: http:/www.degraee.coom/flickr-rss/rss.php?tags=heidelberg&num=20

In this case:
- http:// is missing the second slash
- degraeve is changed to degraee
- com becomes coom

Expected behaviour:
Write the entered URL into .xscreensaver and do not alter it

Reproducible: always

I already contacted the author of xscreensaver directly, but he refuses to even read bug reports for a two year old version (understandable...)

Maybe it would suffice to just repackage the latest version?

Thanks,
Sven

Tormod Volden (tormodvolden) wrote :

Interesting bug, but I don't see it with 5.20 on Debian.

> I already contacted the author of xscreensaver directly, but he refuses to even read bug reports for a two year old version (understandable...)

Yawn, just play along. 5.15 was his newest release only 7 months ago... The newer releases are mostly iOS fixes as far as one can tell from his changelog, but I know there was more fixed than that.

> Maybe it would suffice to just repackage the latest version?

Please try out 5.20 from my PPA: https://launchpad.net/~tormodvolden/+archive/ppa?field.series_filter=precise

Tormod

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Hi Tormod,

Am 06.02.2013 21:40, schrieb Tormod Volden:
> Please try out 5.20 from my PPA:
> https://launchpad.net/~tormodvolden/+archive/ppa?field.series_filter=precise

Thanks
>
for the reply, but you seem to only have released it for
precise, I'm on quantal.

Cheers,
Sven

- --
Sven Hergenhahn
Heidelberg.Germany.Earth.

GPG Key 0x0DCE97AB
Fingerprint E452 94A5 A426 1CA5 B321 5A71 D1AE 3696 0DCE 97AB
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iF4EAREKAAYFAlETj7wACgkQ0a42lg3Ol6sNMQEAgZFKqIp9B4Xb3OmMj8emE6Wd
qY+NVcsqhwwoj7fNYDAA/0/D9MrFcMIY6KLoX/Bo/f1CUXuC8dFRWPzKzZyREIDn
=psJf
-----END PGP SIGNATURE-----

Sven Hergenhahn (svenxy) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Hi,

Am 07.02.2013 12:27, schrieb Sven Hergenhahn:
> Am 06.02.2013 21:40, schrieb Tormod Volden:
>> Please try out 5.20 from my PPA:
>> https://launchpad.net/~tormodvolden/+archive/ppa?field.series_filter=precise
>
>>
for the reply, but you seem to only have released it for
> precise, I'm on quantal.

I can confirm that 5.20 for precise also seems to work for quantal.

Although not having made a thorough testing of the different
screensavers, the problem with the mangeled URL is gone.

Thanks a lot,
hope it makes it into Ubuntu preety soon.

Thanks,
Sven

- --
Sven Hergenhahn
Heidelberg.Germany.Earth.

GPG Key 0x0DCE97AB
Fingerprint E452 94A5 A426 1CA5 B321 5A71 D1AE 3696 0DCE 97AB
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iF4EAREKAAYFAlETkyUACgkQ0a42lg3Ol6uuGwD+PxnwSqw95i8fJZm9sRVCcBJN
XA/FJQJ0BjFFxAT9A58A/0XF2RvTztqklqvg2jaIZAfBIoU0j1UoQp2k83bbtdGD
=q6jV
-----END PGP SIGNATURE-----

Tormod Volden (tormodvolden) wrote :

Thanks for testing. I can confirm this (at least a slash is taken away) on Ubuntu 12.04.

If Ubuntu 13.04 does not get xscreensaver 5.20 (or newer) a separate bug fix for 5.15 would be possible.

Changed in xscreensaver (Ubuntu):
status: New → Confirmed
Tormod Volden (tormodvolden) wrote :

The upstream fix is correct and complete, right?

Mamoru TASAKA (mtasaka) wrote :

All the above 3 patches were already included in 5.16, i.e.
* xscreensaver-demo does truncate http:// into http:/
* xscreensaver-demo now uses memmove instead of strcpy when source and destination overlaps, which will _perhaps_ fix some strange about "degraeve" into "degraee" and so on.

For reference, the diff of demo-Gtk.c between 5.15 and 5.16 is attached.

Mamoru TASAKA (mtasaka) wrote :

> xscreensaver-demo does truncate http:// into http:/
This is xscreensaver-demo does NOT truncate http:// into http:/ (from 5.16)

The attachment "diff of demo-Gtk.c between 5.15 and 5.16" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Launchpad Janitor (janitor) wrote :
Download full text (5.4 KiB)

This bug was fixed in the package xscreensaver - 5.26-1ubuntu1

---------------
xscreensaver (5.26-1ubuntu1) utopic; urgency=low

  * Dropped Ubuntu changes:
    - Ubuntu delta to the screensavers sets.
    - Keep Debian Vcs-* links instead of the ~ubuntu-desktop team bzr
      repository: the Desktop team does not have interest any more.
    - The Ubuntu changes to the descriptions.
  * Merge from Debian unstable. (LP: #1283459) Remaining changes:
    - debian/control:
      + Breaks/Replaces: the old changes are not needed anymore, but the
        new changes the screensavers sets needs it.
    - debian/rules:
      + Use /usr/share/backgrounds as image directory.
      + Add translation domain to .desktop files.
    - debian/source_xscreensaver.py:
      + Add apport hook.
    - debian/xscreensaver.dirs:
      + Install /usr/share/backgrounds. By default, settings search in
        /usr/share/backgrounds and without it, it displays an error.
    - debian/patch/90_ubuntu-branding.patch: Use Ubuntu branding.
    - debian/patches/60_sequential_glslideshow.patch:
      + Allow going through images sequentially rather than just at random in
        the GLSlideshow hack.

xscreensaver (5.26-1) unstable; urgency=low

  * New upstream release 5.26, changes since 5.23:
    - Updated feed-loading for recent Flickr changes.
    - Updated `webcollage' for recent Google changes.
    - Added Instagram and Bing as `webcollage' image sources.
    - Updated to latest autoconf.
    - Bug fixes.
  * Drop patch applied upstream:
    - debian/patches/12_upstream_use_cppflags.patch
  * Bump Standards-Version to 3.9.5 (no changes needed)

xscreensaver (5.23-1) unstable; urgency=low

  * New upstream release 5.23 (Closes: #729311)
    - New hack, geodesic
    - More heuristics for using RSS feeds as image sources
    - Improved Wikipedia parser
    - Updated webcollage for recent Flickr changes
    - Added Android to bsod
    - Made quasicrystal work on weak graphics cards
    - Better compression on icons, plists and XML files
    - Reverted that DEACTIVATE change. Bad idea.
    - Phosphor now supports amber as well as green
  * Dropped patches applied upstream:
    - 12_upstream_quasicrystal_texture_width.patch
    - 14_upstream_hexadrop_keyboard_exit.patch
    - 15_upstream_activate_faster_nontty.patch
  * debian/patches/12_upstream_use_cppflags.patch:
    Make sure CPPFLAGS are used (fixes hardening warnings)
  * debian/control: Update VCS fields (fixes Lintian warning)

xscreensaver (5.22-1) unstable; urgency=low

  * New upstream release 5.22 (Closes: #699833), changes since 5.15:
    - XInput devices now also ignore small mouse motions
    - Loading images via RSS feeds is much improved
    - Enlarged the texture image for lament
    - Made pipes be ridiculously less efficient, but spin
    - Added better mouse control to rubik, cube21, crackberg, and julia
    - Cosmetic improvements to queens and endgame
    - sonar can now ping local subnet on DHCP
    - Most savers now resize/rotate properly
    - New version of `fireworkx'
    - Minor fixes to `distort', `fontglide', `xmatrix'
    - New MacOS crash in `bsod'
    - New mode in `lcdscrub'
    - Gnome/KD...

Read more...

Changed in xscreensaver (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers