plustek 4830p isn't detect using xsane in gimp. plustek backend doesn't work.

Bug #988760 reported by zenic62 on 2012-04-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xsane (Ubuntu)
Low
Unassigned

Bug Description

Installed sane backend and libieee1284 tested parallel port configured in ecp+epp mode at the standard address 378 respond like this:
parport_pc 32006 1
parport 36664 3 ppdev,parport_pc,lp
Using gimp xsane don't find any device.
Tested the configuration file for the backend in direct mode and not in kernel mode because i don't know how to find the source files for compiling the kernel.
Thanks in advance best Regards

Installed sane backend and libieee1284 tested parallel port configured in ecp+epp mode at the standard address 378 respond like this:
parport_pc 32006 1
parport 36664 3 ppdev,parport_pc,lp
Using gimp xsane don't find any device.
Tested the configuration file for the backend in direct mode and not in kernel mode because i don't know how to find the source files for compiling the kernel.
Thanks in advance best Regards
Question information

Language:
    English

Status:
    Open

For:
    Ubuntu xsane

Assignee:
    No assignee

Last query:
    2012-04-24

Last reply:
    2012-04-24

Related bugs

    Link existing bug

Related FAQ:

None
actionparsnip (andrew-woodhead666) said on 2012-04-24: #1

Can you give the output of:

lsb_release -a; uname -a; lsusb

Thanks
zenic62 (zenic62) said on 2012-04-24: #2

Here is the output but my plustek 4830p is a parallel port scanner

tubuntu@sevenpc0000:~$ lsb_release -a; uname -a; lsusb
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04 LTS
Release: 12.04
Codename: precise
Linux sevenpc0000 3.3.3-030303-generic #201204221956 SMP Mon Apr 23 00:04:06 UTC 2012 i686 i686 i386 GNU/Linux
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 01f3:52c0
Bus 002 Device 003: ID 046d:c001 Logitech, Inc. N48/M-BB48 [FirstMouse Plus]

Thanks
Nicola Zema

--- Mar 24/4/12, actionparsnip <email address hidden> ha scritto:

[...]
actionparsnip (andrew-woodhead666) said on 2012-04-24: #3

Parallel, hmmm. Let me search.
actionparsnip (andrew-woodhead666) said on 2012-04-24: #4

http://linux.about.com/library/cmd/blcmdl5_sane-plustek.htm

Seems you need the same-plustek package apparently. You could report a bug
actionparsnip (andrew-woodhead666) said on 2012-04-24: #5

http://manpages.ubuntu.com/manpages/precise/man5/sane-plustek.5.html
zenic62 (zenic62) said on 2012-04-24: #6

I have downloaded the plustek sane from:
The device-driver is currently not part of the SANE distribution. It has to be downloaded from:
http://www.gjaeger.de/scanner/plustek.html
I have extracted it but i don't understand where i have to place every single directory.
Before my question searching about my troubles i found from sane that the sequent files must be in this locations:

FILES
_____________________________
/etc/sane.d/plustek_pp.conf
The backend configuration file
/usr/lib/sane/libsane-plustek_pp.a
The static library implementing this backend.
/usr/lib/sane/libsane-plustek_pp.so
The shared library implementing this backend (present on systems
that support dynamic loading).
/lib/modules/<Kernel-Version>/kernel/drivers/parport/pt_drv.o
The Linux kernelmodule for kernels < 2.6.x.
/lib/modules/<Kernel-Version>/kernel/drivers/parport/pt_drv.ko
The Linux kernelmodule for kernels >= 2.6.x.

But this informations are not correponding to the extracted directories from the url http://www.gjaeger.de/scanner/plustek.html.

If you can help me more, and explain me where I fail or where is the misunderstanding.
Thank you so much

--- Mar 24/4/12, actionparsnip <email address hidden> ha scritto:

[...]
actionparsnip (andrew-woodhead666) said on 2012-04-24: #7

Try:

sudo apt-get install libsane-extras
zenic62 (zenic62) said on 2012-04-24: #8

I have installed all the packages listed in the attached file that i suppose are all is needed by sane.
So i think that all packages are installed as you can see below:
-----------------------------------------------------------------
tubuntu@sevenpc0000:~$ sudo apt-get install libsane-extras
[sudo] password for tubuntu:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
libsane-extras è già alla versione più recente.
È stato impostato libsane-extras per l'installazione manuale.
0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.
__________________________________________________________________

thank you so much

tubuntu@sevenpc0000:~$ sudo apt-get install libsane-extras
[sudo] password for tubuntu:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
libsane-extras è già alla versione più recente.
È stato impostato libsane-extras per l'installazione manuale.
0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.

--- Mar 24/4/12, actionparsnip <email address hidden> ha scritto:

Plustek 4830p paralllel scanner o.s Ubuntu 12.04 with kernel 3.3.3 all xsane and sane libraries installed included the common and extras.
Inside this directories isn't possible to find the needed files as specified in the sane web site like below:

/etc/sane.d/plustek_pp.conf
The backend configuration file
/usr/lib/sane/libsane-plustek_pp.a
The static library implementing this backend.
/usr/lib/sane/libsane-plustek_pp.so
The shared library implementing this backend (present on systems
that support dynamic loading).
/lib/modules/<Kernel-Version>/kernel/drivers/parport/pt_drv.o
The Linux kernelmodule for kernels < 2.6.x.
/lib/modules/<Kernel-Version>/kernel/drivers/parport/pt_drv.ko
The Linux kernelmodule for kernels >= 2.6.x.

Thanks in advance and excuse me if i fail or something i have done was wrong.

zenic62, thank you for reporting this and helping make Ubuntu better.

To see if this is already resolved, could you please test http://cdimage.ubuntu.com/daily-live/current/ and advise to the results?

Changed in xsane (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for xsane (Ubuntu) because there has been no activity for 60 days.]

Changed in xsane (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers