feisty xsane Canon LIDE 20/25/30 broken

Bug #87527 reported by Peter Miller on 2007-02-24
8
Affects Status Importance Assigned to Milestone
xsane (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xsane

xsane 0.99+0.991-1ubuntu2

Recognises the scanner, but it fails to turn on the light and move the scan bar. It returns an all-black image.

Forgot to mention that xsane works just fine with this scanner on Dapper.

Clay Weber (claydoh) wrote :

Same issue with a Canon Lide 25 (also using the plustek backend)

Piotr Żurek (piotrek.zurek) wrote :

I have Canon Lide 20 and the same problem.

scanimage -L returns:

device `plustek:libusb:002:004' is a Canon N670U/N676U/LiDE20 USB flatbed scanner

and
scanimage -d plustek:libusb:002:004 > scan.pnm
scans OK, but XSane doesn't work. What is the problem?

Dean Loros (autocrosser) wrote :

Please also refer to: [Bug 99802] Re: Libusb possibly causing non-scan with some scanners As per sane-developers-list

Dave Hall (skwashd) wrote :

xsane 0.99+0.991-1ubuntu2 is working fine here on i386

$ scanimage -L
device `plustek:libusb:005:009' is a Canon N670U/N676U/LiDE20 USB flatbed scanner

Let me know if you need more information to work out the differences between the environments.

Fabio Marzocca (thesaltydog) wrote :

 $ scanimage -L
device `plustek:libusb:001:006' is a Canon N1240U/LiDE30 USB flatbed scanner

 $ dpkg -l xsane
ii xsane 0.99+0.991-1ub GTK+-based X11 frontend for SANE (Scanner Ac

uname -r
2.6.20-15-generic

The scanner is still NOT working! I am getting anxious as april 19th is very close!!

Same problem here (fully reproducible) on an updated Feisty system. Everything was working previously working fine. Please tell if any additionnal info is needed.
Thanks.

Andreas Schildbach (schildbach) wrote :

I've got the same problem on Feisty and Gutsy. Scanner worked fine with Dapper.

Changed in xsane:
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers