Should always re-query xsane plugin at startup

Bug #47029 reported by fubarbundy on 2006-05-28
10
Affects Status Importance Assigned to Milestone
The Gimp
Unknown
Medium
xsane
Unknown
Unknown
gimp (Ubuntu)
Medium
Ubuntu Desktop Bugs
xsane (Ubuntu)
Undecided
Unassigned

Bug Description

If xsane isn't re-queried, any USB changes (new devices, different device addresses) are not picked up, and GIMP either doesn't show the device in file/acquire/xsane or the device's menu entry results in an error message because GIMP is trying to use the wrong/old device address.

The current workaround is to delete ~/.gimp-2.2/pluginrc after every device change.

Andrew Jorgensen (ajorg) wrote :

I've seen this problem too. I personally think it should either re-scan every time or simply not pretend it knows what devices are installed. The trouble is that scanning every time might increase startup time a lot.

Changed in gimp:
status: Unconfirmed → Confirmed
Daniel Holbach (dholbach) wrote :

The right solution would be some HAL/DBUS magic. This should probably be forwarded upstream.

Changed in gimp:
assignee: nobody → desktop-bugs
Vassilis Pandis (pandisv) wrote :

Thanks for your bug report. This particular bug has been filed
with the developers of the software. You can track this and make
comments here: http://bugzilla.gnome.org/show_bug.cgi?id=357982

Changed in gimp:
status: Unconfirmed → Unknown
Changed in gimp:
status: Unknown → Rejected
Raphaël Quinet (raphael-gimp) wrote :

As mentioned in the upstream bug report, the problems are not in gimp itself. They are caused by the incorrect usage of the gimp plug-in API by the xsane plug-in. So this should be reported to the xsane authors. See comments #2 and #5 from mitch in:
http://bugzilla.gnome.org/show_bug.cgi?id=343148

Sven Neumann (sven-gimp) wrote :

Why is this bug report still being kept on gimp? This is clearly something that can only be addressed in the xsane plug-in and GIMP provides the necessary hooks for such a fix.

Changed in gimp:
importance: Unknown → Medium
status: Invalid → Unknown

Thank you Sven Neumann I'm marking this as xsane bug.

Changed in gimp (Ubuntu):
status: Confirmed → Invalid

No I mark it as confirmed because it happens to several users. Thank you for reporting.

Changed in xsane (Ubuntu):
status: New → Confirmed
status: Confirmed → Incomplete
status: Incomplete → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.