Sane can't find Canon CanoScan N650U

Bug #361278 reported by Christoph Langner on 2009-04-14
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xsane (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xsane

I own a quite old Canon CanoScan N650U. It is fully supported by Sane and worked in every single ubuntu version out of the box. But when i try my scanner inside my up to date jaunty it can't be detected.

$ lsusb
Bus 005 Device 002: ID 04a9:2206 Canon, Inc. CanoScan N650U/N656U

show's that the scanner is found by the system. But sane

$ scanimage -L
device `v4l:/dev/video1' is a Noname BT878 video (Hauppauge (bt878)) virtual device
device `v4l:/dev/video0' is a Noname Trust 2MP Auto Focus Webcam virtual device

fails to find the scanner...

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: xsane 0.996-1ubuntu2
ProcEnviron:
 PATH=(custom, user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: xsane
Uname: Linux 2.6.28-11-generic x86_64

Christoph Langner (chrissss) wrote :
Jacques (jgiuffre+launchpad) wrote :

I have the same issue. Same CanoScan n650u, under 8.10 and now 9.04. sane-find-scanner appears to find it, and when I open xsane it looks for the scanner for a long time, then appears to find it (has name of scanner in titlebar of scan window) but then fails when trying to actually scan, saying that the I/O failed.

jacques2@domingo:~$ lsusb
Bus 003 Device 004: ID 04a9:2206 Canon, Inc. CanoScan N650U/N656U

sane-find-scanner
found USB scanner (vendor=0x12d1, product=0x1003) at libusb:001:004
found USB scanner (vendor=0x04a9, product=0x2206, chip=LM983x?) at libusb:003:004

jacques2@domingo:~$ scanimage -L

No scanners were identified.

This scanner works fine under Windows. I've also tried running scanbuttond, but it doesn't help.

Jacques (jgiuffre+launchpad) wrote :

Have you had any further luck with this Christoph? I am still scannerless unfortunately, and no fix appears to be forthcoming...

Jacques (jgiuffre+launchpad) wrote :

OK, actually I take that back. After doing an update things are a little different. Now, using XSane or gscan2pdf either will discover the scanner immediately. I then try to do a scan and get a short sound like it's about to, and then I get the following error:

<quote>Operation was cancelled.</quote>

Then, if I try again I get the following (from gscan2pdf, from XSane I just get the last part):

<quote>Unknown message: scanimage.pl: open of device plustek:libusb:001:011 failed: Error during device I/O</quote>

If I unplug the scanner and plug it back in I can get the first error again.

lsusb still gives this:
<quote>Bus 001 Device 018: ID 04a9:2206 Canon, Inc. CanoScan N650U/N656U</quote>

but scanimage -L now gives:

<quote>device `plustek:libusb:001:018' is a Canon CanoScan N650U/N656U flatbed scanner</quote>

and makes a little sound, which is promising.

But yes, then the errors...

Jason Ritzke (sha-goyjo) wrote :

I have this problem, and another problem on top of it. Running Jaunty 64 on a hp tx2000z, not only do I get the I/O error on the rare occasion when sane works, but most of the time, it just gives an invalid argument from the webcam and fails to start.

halyihev (tony-alurhsa) wrote :

Had the same problem in Jaunty with the N650U. Found this page:

http://www.ubuntugeek.com/fixing-a-scanner-broken-by-the-feisty-upgrade.html

and tried the solutions listed, and my scanner is at least now working. I believe I'll have to set scanbuttond to start up at boot, but otherwise it seems at least so far to resolve the problem.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xsane (Ubuntu):
status: New → Confirmed
Michael Nagel (nailor) wrote :

is this still an issue with recent ubuntu releases (12.04 precise and later)?

Changed in xsane (Ubuntu):
status: Confirmed → Incomplete
angus73 (angus73) wrote :

Yes it is, at least for me with 12.04 Precise.
I would be very happy to help in diagnosing and solving the problem because it would be very useful for me abandoning windoze. The scanner itself works fine in windows XP.
Let me know if I have to provide some logs, etc.

Michael Nagel (nailor) wrote :

have you tried to email sane-devel? the number of knowledgeable people around here is quite limited, and on that list there are more...

angus73 (angus73) wrote :

Thanks. I have just emailed to the list and will write here if anything interesting happens there.

Launchpad Janitor (janitor) wrote :

[Expired for xsane (Ubuntu) because there has been no activity for 60 days.]

Changed in xsane (Ubuntu):
status: Incomplete → Expired
angus73 (angus73) wrote :

This bug no longer affects me. Unfortunately, I can't say for sure what happened meantime, but it seems that my xsane has problems in recognizing the scanner if it is plugged into a usb hub. If I connect it directly to a usb port of my computer, it seems to recognize it every time.

Peter Healy (phealy3330) wrote :

I see the same thing angus73 does. I plugged my CanoScan N650U into the front port of my PC Tower and got nothing, moved it to the back ports and it worked fine.

Christoph Langner (chrissss) wrote :

@Peter, this bug is from 2009 and was related to Ubuntu 9.04... I'm pretty sure, it has nothing to do with your problems. You should open a new bug with more informations. //PS: I still own this scanner, it works fine within Ubuntu 15.10 and prior Ubuntu versions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers