Filename issues - and cut-and-paste quirks

Bug #1437423 reported by Scott Cowles Jacobs on 2015-03-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xsane (Ubuntu)
Undecided
Unassigned

Bug Description

I scanned something in, and remembered that there was a filename field in the main window, and changed it from the
name I used the last time I scanned something, to what I wanted for this scan.
I pressed return, and then went to the image window that comes up after the scan, and clicked on the green button for Save
at the leftmost position in the row of buttons at the top.
The Save window came up, with the original filename, not the one I had just entered.
I assume that Save is using the value of the field as of when Scan was clicked on, but if the user updates that field after the scan,
but prior to Save being clicked on, the Save dialog should pick up on that and use the updated info.

Next:

Well, I thought, I'll just cut the filename from the main window and paste it into the Save dialog.
I selected the relevant portion of the filename (the main window filename field includes the path), and then pressed control-c,
brought up the Save dialog and pressed control-v (the filename, sans extension, already being selected).
Nothing happened.
Huh! I thought... I must have forgotten to press control-c after selecting the filename in the main window. I dismissed the Save
dialog, went back to the main window, and found that the filename field had totally disappeared!
After some searching, I found that the top-right button now read Copy. When I clicked on it and then selected "Save",
back came the filename field, with my new name intact.
I tried the same thing, but this time noticed that the second I pressed control-c, the field disappeared and "Copy" appeared in the button.
I tried the terminal copy trick - shift-control-c, and the filename remained, but shift-control-v in the Save dialog did not replace the
old name with the new.
Ultimately, I had success with right-clicking the filename fields, and selecting "copy" or "paste" respectively.

But the standard keyboard shortcuts for copy and paste definitely do not act as expected.

[I note from the website, that my version is current, but dates from 2010.
Is this being maintained, or has it achieved (relative) perfection...?]

--------------------------------------------------------------------------------
scott@scott-ASUS-M2N68-AM-PLUS:~$ uname -a
Linux scott-ASUS-M2N68-AM-PLUS 3.16.0-33-generic #44-Ubuntu SMP Thu Mar 12 12:25:57 UTC 2015 i686 athlon i686 GNU/Linux
scott@scott-ASUS-M2N68-AM-PLUS:~$ lsb_release -dsc
Ubuntu 14.10
utopic
scott@scott-ASUS-M2N68-AM-PLUS:~$ echo $DESKTOP_SESSION
Lubuntu

scott@scott-ASUS-M2N68-AM-PLUS:~$ xsane --version
xsane-0.998 (c) 1998-2010 Oliver Rauch
  E-mail: <email address hidden>
  package xsane-0.996
  compiled with GTK-2.24.18
  with color management function
  with GIMP support, compiled with GIMP-2.8.4
  XSane output formats: jpeg, pdf(compr.), png, pnm, ps(compr.), tiff, txt

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: xsane 0.998-5ubuntu1
ProcVersionSignature: Ubuntu 3.16.0-33.44-generic 3.16.7-ckt7
Uname: Linux 3.16.0-33-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.14.7-0ubuntu8.2
Architecture: i386
CurrentDesktop: LXDE
Date: Fri Mar 27 12:34:08 2015
InstallationDate: Installed on 2014-11-01 (146 days ago)
InstallationMedia: Lubuntu 14.10 "Utopic Unicorn" - Release i386 (20141022.1)
SourcePackage: xsane
UpgradeStatus: No upgrade log present (probably fresh install)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers