Preview window from xsane works wierd

Bug #1410756 reported by Scheini72
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
xsane (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

I have an HP-LaserJet cm1312nfi to scan pictures, HPLIP is installed.

When I start xsane, without the Preview Windows enabled and want to open it, I get a windows, but nothing ist displayed on it. So, I can't use xsane to scan anything.

If I open xsane with Preview Window enabled, I see all graphics on the Window and I can work.

This procedure worked for me to reproduce the "bug":
1. start xsane, Preview window is closed
2. Press Ctrl+1 -> Preview Window opens.
3. If nothing is displayed, bug already occured.
3.1 Workaround: Press Ctrl + Q
3.2 restart xsane
3.3 xsane shall start, Preview window is already opened, with everthing on it
4 If window is displayed like it should:
4.1 Press Ctrl + 1 to close Preview window
4.2 Press Ctrl + Q to clos xsane
4.3 restart xsane
4.4 Press Ctrl +1, window shall open, bug shall occur.

Thanks for any help
scheini72

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: xsane 0.998-5ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-40.69-generic 3.13.11.10
Uname: Linux 3.13.0-40-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.6
Architecture: amd64
CurrentDesktop: Unity
Date: Wed Jan 14 08:39:49 2015
InstallationDate: Installed on 2014-04-24 (264 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
SourcePackage: xsane
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Scheini72 (protect-sch-general) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xsane (Ubuntu):
status: New → Confirmed
Revision history for this message
Skyman (sskyman) wrote :

I see the same error on a machine with Kubuntu 16.04.3 LTS with another scanner. The described workaround works.

Revision history for this message
James Daube (jadaube2) wrote :

Same problem with my machine. Nothing is displayed on the preview window (although the acquire preview button IS there - you just can't see it).
LSB Version: core-9.20160110ubuntu0.2-amd64:core-9.20160110ubuntu0.2-noarch:security-9.20160110ubuntu0.2-amd64:security-9.20160110ubuntu0.2-noarch
Distributor ID: Ubuntu
Description: Ubuntu 16.04.4 LTS
Release: 16.04
Codename: xenial

Using a Brother MFC-J885. Same workaround works.

Revision history for this message
Jose Riha (jose1711) wrote :

Another workaround that did the job for me (on Arch Linux) was running with `--sync`, so: `xsane --sync`

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers