Saving files is too slow

Bug #124879 reported by Joris van Rooij on 2007-07-09
8
Affects Status Importance Assigned to Milestone
xsane (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xsane

Xsane is really slow at saving files. The problem looks like it's caused by the high frequence of update of the progress bar. Here's a patch against 0.99+0.991-1ubuntu2 that "fixes" the problem. A patch has also been submitted upstream.
http://www.wasda.nl/~jorrizza/src/xsane-save.c.patch

Related branches

Changed in xsane:
assignee: nobody → rainct
importance: Undecided → Medium
status: New → In Progress
Siegfried Gevatter (rainct) wrote :

Here is a debdiff. But I never got xsane working so I couldn't neither confirm this issue nor check the effect of the patch.

Joris van Rooij: Thanks for the patch. Also, could you provide a link to the report upstream in order to monitor it from Launchpad?

Changed in xsane:
assignee: rainct → nobody
status: In Progress → Confirmed
Joris van Rooij (jorrizza) wrote :

I've sent an email message to the upstream developer. The only other way was the SANE mailing list, but that didn't seem the right place to report bugs to xsane.

I've sent another patch upstream (for 0.994, because xsane-save.c had too many changes to make a unified diff) and when the developer approves the patch I'll report the reaction here.

Emmet Hikory (persia) wrote :

Thanks for the patch and the debdiff wrapper. Given that the candidate revision (generated by the debdiff) has not yet been tested, I'm temporarily unsubscriibing ubuntu-universe-sponsors. Please resubscribe when there is confirmation that a package built with the supplied debdiff indeed fixes the issue.

Changed in xsane:
assignee: nobody → rainct
status: Confirmed → In Progress
Siegfried Gevatter (rainct) wrote :

-- Needs Testing --

Changed in xsane:
assignee: rainct → nobody
status: In Progress → Incomplete
Bjorn Heesakkers (bjorn-wasda) wrote :

I can confirm this patch works, speeds up saving process when scanning a lot. Especially helps with lower dpi scans.

Siegfried Gevatter (rainct) wrote :

Thanks for testing it, Bjorn.

Subscribing U-U-S again.

Changed in xsane:
status: Incomplete → Confirmed
Emmet Hikory (persia) on 2007-07-10
Changed in xsane:
assignee: nobody → persia
status: Confirmed → In Progress
Emmet Hikory (persia) wrote :

Uploaded. Thank you.

Changed in xsane:
status: In Progress → Fix Committed
Emmet Hikory (persia) wrote :

Or rather, xsane is in main. I've subscribed ubuntu-main-sponsors to request upload.

Changed in xsane:
assignee: persia → nobody
status: Fix Committed → Confirmed
Joris van Rooij (jorrizza) wrote :

Siegfried Gevatter (RainCT): Here's the communication with the upstream developer I promised:

--
Oliver Rauch:

Thanks,

I already have prepared a comparable solution.
--

And when I asked him about the comparable solution:

--
Oliver Rauch:

I don`t know when I will be able to release the next version of xsane.
Feel free to apply your patch to the debian packages.
--

So this patch will be temporary and won't be included upstream.

Siegfried Gevatter (rainct) wrote :

xsane (0.99+0.991-3ubuntu3) gutsy; urgency=low

  * debian/patches/07_save_speed.dpatch: reduce update frequency of
      the progress bar, to save files faster; patch provided by
      Joris van Rooij <email address hidden> (LP: #124879).

 -- Siegfried-Angel Gevatter Pujals (RainCT) <email address hidden> Mon, 9 Jul 2007 15:41:16 +0200

Changed in xsane:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers