scanner only works once Canon LIDE 110

Bug #1247371 reported by matze on 2013-11-02
40
This bug affects 8 people
Affects Status Importance Assigned to Milestone
xsane (Ubuntu)
Undecided
Unassigned

Bug Description

After reboot I am able to scan only once.
$ sane-find-scanner
found USB scanner (vendor=0x04a9 [Canon], product=0x1909 [CanoScan]) at libusb:002:003
scanimage -L
device `genesys:libusb:002:003' is a Canon LiDE 110 flatbed scanner

FIRST TIME scanning works

$ scanimage -vvv > bims.pnm
scanimage: scanning image of size 636x885 pixels at 8 bits/pixel
scanimage: acquiring gray frame
scanimage: min/max graylevel value = 0/255
scanimage: read 562860 bytes in total
Closing device
Calling sane_exit
scanimage: finished

SECOND TIME

$ scanimage -vvv > bims.pnm
scanimage: sane_start: Invalid argument
Closing device
Calling sane_exit
scanimage: finished

THIRD TIME

$ scanimage -vvv > bims.pnm
scanimage: no SANE devices found
Calling sane_exit
scanimage: finished

I am running "Ubuntu 13.10" x86_64.
On my Ubuntu 12.10 LTS netbook I am able to scan as often as I like with the same scanner.

matze (matthias-ruegge) wrote :

I found a workaround with the following settings in the USB configuration of the ASUS Z87-K mainboard

legacy USB support: enabled
Intel xHCI Mode: disabled
EHCI Hand-off: disabled

Now the scanner works perfect and I am not aware of negative effects. Maybe because I don't have any USB3 devices.

L.F. Moisa (florin-moisa) wrote :

Thanks "matze"!

Same here: Asrock Extreme 6 -- disabled Intel USB3.0 and Legacy USB3.0 in bios -- now works like a charm!

Mauro (mauromol) wrote :

I also have this problem. "Invalid argument" errors appear randomly while scanning a page. Retrying the operation immediately after usually fixes this, however once it happened I had to shut down the scan backend (Skanlite) and start another (XSane), because the error was happening repeatedly on every attempt.
Using Canon LiDE 110 on Linux Mint 16 KDE (based on Ubuntu 13.10) on a HP ProBook 450 G1 laptop, using an USB 2.0 port. The problem happens "randomly" both with Skanlite and XSane.

Searching on Google I found this error is quite common, but I couldn't find any serious attempt to diagnose the source of the problem. Please let me know what I can do to help.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xsane (Ubuntu):
status: New → Confirmed
Mauro (mauromol) wrote :

Please note that USB Legacy Support is already enabled in my system BIOS.

zasran (erik-zasran) wrote :

I have the same problem with Fujitsu S1300 scanner, it is recognized by sane-find-scanner anytime but only once by scanimage -L. I can scan one page using e.g. simplescan but afetrwards neither scanimage -L not simplescan recognize it. Unplugging and plugging it in again makes it work, for one scan.

moimael (moimael) wrote :

Same for me with a Canon LIDE 210.

brulaz (bruce-lazerte) wrote :

Ubuntu 14.10 and Canon Lide25
First Scanimage -L shows the scanner, but then takes a long time to close.
Second time doesn't show the scanner.
Not possible to scan anything.

Tried turning off USB3 and xHCI hand-off in UEFI Bios but that didn't help either.

brulaz (bruce-lazerte) wrote :

Version 1.025-git fixed it for me.
See: https://bugs.launchpad.net/~rolfbensch/+archive/ubuntu/sane-git/+index?field.series_filter=utopic

and do this:

sudo add-apt-repository ppa:rolfbensch/sane-git
sudo apt-get update
sudo apt-get upgrade

Tero Gusto (tero-gusto) wrote :

Thanks @brulaz, after updating the drivers I can scan more than one time with my Canon LiDE 210 scanner, and the scanner no longer "disappears". See comment #9.

matze, thank you for reporting this and helping make Ubuntu better.

As per https://wiki.ubuntu.com/Releases 13.10 is EOL as of July 17, 2014.

If this is reproducible in a supported release (ex. 16.04) please file a new report, and feel free to subscribe me to it.

Changed in xsane (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers