Scanning with Canon Lide 25 doesn't work

Bug #108153 reported by Fridtjof Busse on 2007-04-20
4
Affects Status Importance Assigned to Milestone
xsane (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xsane

Scanning worked fine on edgy, but on edgy, but on feisty xsane just sits there and locks up.
No error on the console, only dmesg shows something:
usb 7-1: usbfs: process 6767 (xsane) did not claim interface 0 before use

Willi (jens-bausa) wrote :

I have the same problems with a Canon Lide 20. On my machine dmesg gives no error message and lsusb lists the Scanner correctly:

# lsusb
Bus 005 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 005: ID 04a9:220d Canon, Inc. CanoScan N670U/N676U/LiDE 20
Bus 001 Device 001: ID 0000:0000

Is this a xsane problem or a ubuntu feisty problem?

Tim Frost (timfrost) wrote :

I have a LiDE 25 scanner that works fine in edgy with xsane. I run Windows XP in a VMware virtual machine on the Ubuntu host. Software running on the windows VM is also able to access the scanner.

When I upgraded to feisty, the scanner failed for both xsane and the windows VM. lsusb reports the scanner correctly. This suggests a possible regression in the kernel USB driver for feisty.

In edgy, which I have reverted to, lsusb reports
Bus 002 Device 002: ID 04a9:2220 Canon, Inc.

I can't confirm the problem with VMware, but with xsane the scanner still fails for me.
Definitly a regression.

Robert Hutton (robert-hutton) wrote :

I can confirm the same problem with Feisty. When I first load Sane, the scanner motor operates during initialisation (usually) but then I preview or scan, the system pauses then returns a complete black scanned page. The scanner also worked fine under Edgy (which I was using at the point of purchase).

I too am having the same issue in Feisty, but with a CanoScan N670U.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers