Flat panel resolution 1680x1050 not detected for laptop with ATI X1400

Bug #106395 reported by Olivier Mengué on 2007-04-14
4
Affects Status Importance Assigned to Milestone
xresprobe (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xresprobe

I'm testing with the 7.04 Beta live CD.

This is a Lenovo IBM ThinkPad T60 8744 laptop.
The resolution of the flat panel is 1680x1050.
The video chip is ATI Radeon Mobility X1400.

Here is the xresprobe output:

ubuntu@ubuntu:~$ sudo xresprobe ati
{many empty lines}
id:
res:
freq:
disptype: lcd/lvds
ubuntu@ubuntu:~$

The flat panel information is available in the Xorg log. Here is the relevant part:
(II) Reloading /usr/lib/xorg/modules//libddc.so
(II) VESA(0): VESA VBE DDC supported
(II) VESA(0): VESA VBE DDC Level 2
(II) VESA(0): VESA VBE DDC transfer in appr. 1 sec.
(II) VESA(0): VESA VBE DDC read successfully
(II) VESA(0): Manufacturer: IBM Model: 2887 Serial#: 0
(II) VESA(0): Year: 2005 Week: 0
(II) VESA(0): EDID Version: 1.3
(II) VESA(0): Digital Display Input
(II) VESA(0): Max H-Image Size [cm]: horiz.: 33 vert.: 21
(II) VESA(0): Gamma: 2.20
(II) VESA(0): No DPMS capabilities specified; RGB/Color Display
(II) VESA(0): First detailed timing is preferred mode
(II) VESA(0): redX: 0.596 redY: 0.347 greenX: 0.335 greenY: 0.543
(II) VESA(0): blueX: 0.158 blueY: 0.143 whiteX: 0.313 whiteY: 0.329
(II) VESA(0): Manufacturer's mask: 0
(II) VESA(0): Supported additional Video Mode:
(II) VESA(0): clock: 122.0 MHz Image Size: 331 x 207 mm
(II) VESA(0): h_active: 1680 h_sync: 1712 h_sync_end 1776 h_blank_end 1904 h_border: 0
(II) VESA(0): v_active: 1050 v_sync: 1051 v_sync_end 1054 v_blanking: 1066 v_border: 0
(II) VESA(0): Supported additional Video Mode:
(II) VESA(0): clock: 101.7 MHz Image Size: 331 x 207 mm
(II) VESA(0): h_active: 1680 h_sync: 1712 h_sync_end 1776 h_blank_end 1904 h_border: 0
(II) VESA(0): v_active: 1050 v_sync: 1051 v_sync_end 1054 v_blanking: 1066 v_border: 0
(II) VESA(0): LP154W02-TL06
(II) VESA(0): EDID (in hex):
(II) VESA(0): 00ffffffffffff00244d872800000000
(II) VESA(0): 000f0103802115780abca59858558b28
(II) VESA(0): 24505400000001010101010101010101
(II) VESA(0): 010101010101a82f90e0601a10402040
(II) VESA(0): 13004bcf10000019b72790e0601a1040
(II) VESA(0): 204013004bcf100000190000000f00b3
(II) VESA(0): 0a32b30a28140100320c0000000000fe
(II) VESA(0): 004c503135345730322d544c3036007f
(II) VESA(0): Printing DDC gathered Modelines:
(II) VESA(0): Modeline "1680x1050" 122.00 1680 1712 1776 1904 1050 1051 1054 1066 -hsync -vsync
(II) VESA(0): Modeline "1680x1050" 101.67 1680 1712 1776 1904 1050 1051 1054 1066 -hsync -vsync
(II) VESA(0): Searching for matching VESA mode(s):

Revision history for this message
Olivier Mengué (dolmen) wrote :

Here is the full Xorg.0.log.

Revision history for this message
Olivier Mengué (dolmen) wrote :

I forgot to say that the consequence of xresprobe failure is that Xorg is configured in 1280x1024 which is not the native resolution and not even the same ratio (1680x1050 is wide screen).

Revision history for this message
siggi (info-si-ho) wrote :

Same issue on a Dell Inspiron 6400 WSXGA+ Widescreen Laptop.

Revision history for this message
Olivier Mengué (dolmen) wrote :

I disagree with the "marked as duplicate of bug #136699".

My bug report is not about the VESA driver but instead the xresprobe tool.
xresprobe from the live CD seems to use the VESA driver to retrieve VESA data information, but the Xorg.conf file generated for the final desktop will be for the ATI driver.
I can understand that there is some technical limitation in VESA that limit what the VESA driver can do.
However, as the ATI driver knows ho to set a particular video mode including wide screen ones, I expect xresprobe to be able to correctly generate an Xorg.conf adapted to my hardware.

So please, have a closer look to the log I reported.

The bug is not in the VESA driver but in xresprobe which does not detect the useful information from the Xorg.log.

I expect that xresprobe detetect the resolution of my screen from the Modelines reported in the log.

Revision history for this message
Dave roi (daveroi) wrote :

I had the same problem on my generic desktop PC with nvidia FX 5200 graphics card.
Gutsy herd 5 CD.

Revision history for this message
Nicolas Arnaud-Cormos (nikikko) wrote :

Same problem with kubuntu gusty beta on an inspiron 6400. I have a resolution of 1400x1050 instead of 1680x1050.
I try to add this resolution to xorg.conf, but it didn't work.

The only way to add the good resolution is to install the restricted driver, but I have other drawbacks (mainly Kaffeine crash, bug with video...)

Bryce Harrington (bryce) on 2007-09-27
Changed in xresprobe:
status: New → Confirmed
Revision history for this message
Bryce Harrington (bryce) wrote :

Nicolas, I suspect you may be seeing 86011 rather than this bug. xresprobe tosses the highest resolution and reports only up to the second-highest in some circumstances. See my comments there.

Dave, Oliver, and siggi, can you please attach your Xorg.0.log and xorg.conf files, and the output from ddcprobe and xresprobe <driver>?

Changed in xresprobe:
status: Confirmed → Incomplete
Revision history for this message
Bryce Harrington (bryce) wrote :

May be a dupe of 27667 which now has a fix. The additional information in the previous request could help determine if this is the case. Thanks!

Revision history for this message
Olivier Mengué (dolmen) wrote :

Bryce,
Here is the output of ddcprobe on Feisty Fawn.

Revision history for this message
Olivier Mengué (dolmen) wrote :

Bryce,
Here is my fixed Xorg.conf, which works with 1680x1050.
Xorg.0.log and xresprobe output were already above.

Revision history for this message
Bryce Harrington (bryce) wrote :

Thanks for the ddcprobe info - yes this looks like it's fixed by one of the recent xresprobe changes.

Please test against Gutsy-final, and reopen the bug if it's still there. But I'm 99.9% sure you should find the new Gutsy working well with your flat panel. :-)

Changed in xresprobe:
status: Incomplete → Fix Released
Revision history for this message
Olivier Mengué (dolmen) wrote :

Bryce,

I've just upgraded to Gutsy final.
The xresprobe output is still the same (except the empty lines). So if the flat panel resolution detection is still based only on 'xresprobe' or 'ddcprobe', this is not fixed.
I've attached the new Xorg.0.log.

$ sudo xresprobe ati
id:
res:
freq:
disptype: lcd/lvds
$ sudo xresprobe fglrx
id:
res:
freq:
disptype: lcd/lvds

Revision history for this message
Bryce Harrington (bryce) wrote :

According to your Xorg.0.log, you're still using your old Feisty Xorg configuration. Try running this:

sudo dpkg-reconfigure xserver-xorg

(I think you can pretty much just accept all defaults.)

Revision history for this message
Olivier Mengué (dolmen) wrote :

What Bryce suggested worked.

This is fixed in Gutsy and Hardy.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers