keyboard unusable after logging in

Bug #320393 reported by Arno Peters on 2009-01-23
38
This bug affects 6 people
Affects Status Importance Assigned to Milestone
xrdp (Ubuntu)
Low
Unassigned
Nominated for Karmic by ItFinallyWorks

Bug Description

Binary package hint: xrdp

Using xrdp on a default Xubuntu 8.04 works flawlessly.

Using xrdp on a default Ubuntu 8.04 installation messes up the keyboard after logging in to the remote desktop. To reproduce:

On a test server, using a default Ubuntu installation:
  user@testserver:~$ sudo apt-get install xrdp tightvncserver
  user@testserver:~$ sudo /etc/init.d/xrdp start

On an other computer:
  user@client:~$ rdesktop testserver

The xrdp login screen xrdp works as expected. After I log in, I open an editor and I start to type:

qwertyuiop[] becomes on the screen: c.gvnmlzxyu
asdfghjkl;' becomes on the screen: abfhjk;'`io
zxcvbnm,. becomes on the screen: */d,s\[]
/ is the enter key
5 is the backspace key

This makes the keyboard totally unusable.

I have attached the contents of ~/.xsession-errors after logging in to this bug report.
Line 34 seems to indicate metacity as the possible culprit:
  Window manager warning: Log level 32: could not find XKB extension.

WORKAROUND:
disable the keyboard plugin of the gnome-settings-daemon using gconf-editor:
  /apps/gnome_settings_daemon/plugins/keyboard
set active to False.

Arno Peters (awpeters) wrote :
Arno Peters (awpeters) wrote :

I have confirmed it this problem has the same solution as bug #199245: disable the keyboard plugin of the gnome-settings-daemon using gconf-editor:

  /apps/gnome_settings_daemon/plugins/keyboard

set active to False.

Charlie Kravetz (charlie-tca) wrote :

Thanks for your bug report. Please try to obtain a backtrace http://wiki.ubuntu.com/DebuggingProgramCrash and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in xrdp:
status: New → Incomplete
description: updated
Jeremy Austin-Bardo (ausimage) wrote :

I want to add that I have noticed the same behavior with tightvncserver. And no there is no crash... so there is no backtrace possible WTF Charlie Kravetz! :)

rsenger1 (ichthyosaurus-1) wrote :

I can confirm this bug on Ubuntu 8.04, while on Debian Lenny everything is fine.

Arno Peters (awpeters) on 2009-04-16
Changed in xrdp (Ubuntu):
status: Incomplete → Confirmed
Fastguy (erenoglu) wrote :

I confirm this bug in Ubuntu 9.04 updated as of 18/05/2009.

Keyboard layout is messed up completely. I also had to disable compiz to get it to update the screen.

Emre

ItFinallyWorks (a-c-programmer) wrote :

I also confirm on Ubuntu 9.04. By the way, its really hard to type gconf-editor with things messed up like this!

Another interesting quirk of this bug is that before I performed the workaround, my theme was not properly applied to the remote desktop sessions (real ones were fine). Even the ubuntu icons for the shutdown button/application launcher were wrong - they were the default gnome ones. If the appearance applet is launched, the right theme and icons are shown, but only while the applet is open.

As soon as I disabled the keyboard plugin, and logged back in, the theme works properly and everything looks right.

Just wanted to chime in as well, will try applying the workaround in a little while when I have direct access to my remote box..

Yeah, I get this too on 9.04. Disabling as described above fixes things.

If you need to set /apps/gnome_settings_daemon/plugins/keyboard active=false remotely, which I did, just use ssh -X user@hostname gconf-editor. You will need to log out, if you already logged in via rdesktop within xrdp, for the settings to take effect. Enjoy typing letters correctly!

Louis (louis-van-breda) wrote :

Hello,

I just noticed that the ^workarround^ disable the keyboard plugin of the gnome-settings-daemon using gconf-editor,
is changing the settings on user level, wher this is a system wide problem :>

In first instance I did not noticed and changed the setting as root (sudo su). I could not edit the setting there (I was surprised :>), but I never the less managed that by deleting the key and generating it again. What ever I did expect a system wide setting .......

So as a concequence, you have to login for every defined user (to which you might need remote access) to change the setting :>

Louis

I can confirm this bug on Debian sid (unstable), and the workaround works (disabling the keyboard plugin in gconf-editor, had to install gconf-editor manually).

Charlie Kravetz (charlie-tca) wrote :

Thanks for the information. Once again, lease try to obtain a backtrace http://wiki.ubuntu.com/DebuggingProgramCrash and attach the file to the bug report. This will greatly help us in tracking down your problem. You do not have to have a crash to obtain a backtrace. You just need to follow the procedures written.

Changed in xrdp (Ubuntu):
status: Confirmed → Incomplete
jandersen (james-j-andersen) wrote :

I've just tried this workaround in Ubuntu 9.10 and it doesn't seem to have any effect! I also tried de-activating the ally-keyboard plugin for good measure but no luck. My keyboard input is still totally garbled when logging in through xrdp. Any other ideas?

jandersen (james-j-andersen) wrote :

I'll see if I can provide a backtrace later this evening (US time)

jandersen (james-j-andersen) wrote :

I added the debug repos but didn't find one for xrdp

Jim Salter (jrssnet) wrote :

Fully documented workaround for Ubuntu Karmic is here: http://ubuntuwiki.net/index.php/Xrdp,_installing

Instructions at that page are full and complete for using xrdp to connect to currently logged in local user's session (with Vino) and to an arbitrary vnc-only session (with tightvncserver). Vino does not have the keyboard hashing problem at all; tightvncserver does but the disable active keyboard workaround DOES work - the important part is that you MUST run gconf-editor as the user who owns the vnc session, as it's a per-user preference, not a global one!

hanasaki (hanasaki-ubuntu) wrote :

lucid Beta with all current updates as of 2010-04-11
some keys bring up gnome-session applet menus (ex: 's' brings up the dropdown for the user [lockscreen|logout...] 'm' brings up the chat dropdown [setup chat|setup email|setup broadcast ...] tried removing tightvncserver and also setting the gconf-editor entries as in this ticket. No behavior changes in the keyboard.

Mr. Lim (mrlim) wrote :

Another data point on the behavior described by hanasaki in post #19. Under Lucid Beta 2, updates current up to 2010-04-24, Remote Desktop removed via Software Center, and tightvncserver installed in its place. Issues occur only when logged in remotely via VNC. Local keyboard works fine. Via VNC, I encounter the same behaviour: 's' = [Lock Screen...Shutdown...]. 'S' = works normally. I cannot confirm 'm' as I have removed evolution via Software Center, and the chat dropdown has no items in my environment, but 'm' does not produce any characters or output. Also, attempting to run System->Preferences->Keyboard causes the following segfault:

gnome-keyboard-[2548]: segfault at 18 ip 00007fc80dc70ea4 sp 00007fffc82c1460 error 4 in libxklavier.so.16.0.0[7fc80dc68000+1a000]

Attached is the xsession-error log.

hanasaki (hanasaki-ubuntu) wrote :

still having the same issues - lucid final release 10.4
Is this actively being worked on? Is there a work-around? None of the above fixed it for me.

LagMonster (lagguru) wrote :

Seeing the exact same behavior as described in #19, happened after the keyboard plugin was disabled. Using TightVNC 1.3.10, had to, as 1.3.9 crashed constantly and without warning.
Holding shift does allow you to type S/M, just gotta hope caps doesn't matter :(

hanasaki (hanasaki-ubuntu) wrote :

anyone had luck after removing the "indicator applet session"? Worked for me with rdp vnc

Charlie Kravetz (charlie-tca) wrote :

Thanks for all the input on this issue. I believe there is enough information for the developers to begin to resolve this issue, so I am marking this bug confirmed.

I will question whether this is a bug in "xrdp" or "tightvncserver" as comment #18 seems to suggest.

Changed in xrdp (Ubuntu):
importance: Undecided → Low
status: Incomplete → Confirmed
Luke Scharf (lukescharf) wrote :

I'd like to suggest an alternative workaround to this bug. I added the following section to /etc/xrdp/startwm.sh (after the bangline and before it sources the locale):
# Fix keyboard layout
/usr/bin/xmodmap -e 'keysym Alt_L = Alt_L'
/usr/bin/xmodmap -e 'keycode 255 = Meta_L'
/usr/bin/xmodmap -e 'keycode 254 = Meta_R'
/usr/bin/xmodmap -e 'keycode 253 = Super_L'
/usr/bin/xmodmap -e 'keycode 252 = Super_R'
/usr/bin/xmodmap -e 'add mod3 = Super_L Super_R'
/usr/bin/xmodmap -e 'add mod4 = Meta_L Meta_R

Theodotos Andreou (theodotos) wrote :

Same problem exists on 11.04 32 bit (Natty) with latest updates. I tried both suggestions (gconf-editor and startwm.sh) but they did not solved the issue.

David Benham (david-r-benham) wrote :

Confirmed the issue on 11.04.04 64 bit with latest updates. The solution in post #2 along with the advice in post 12 led me to run sudo gconf-editor, instead of just plain gconf-editor, the latter did not work. I was using tightVNCServer trying to get an HTML 5 VNC viewer called NoVNC up and running. Figured the problem was with the viewer for the longest time.

Arno Peters, this is not reproducible. If this is reproducible in a supported release, please file a new report via a terminal:
ubuntu-bug xrdp

Please feel free to subscribe me to it.

Changed in xrdp (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers