Cannot use xrdp to login to sesman-Xvnc after 0.6.1-2ubuntu0.1

Bug #1811122 reported by Henry Mozer on 2019-01-09
134
This bug affects 26 people
Affects Status Importance Assigned to Milestone
xrdp (Ubuntu)
Undecided
Paulo Flabiano Smorigo

Bug Description

After upgrading xrdp from 0.6.1-2 to 0.6.1-2ubuntu0.1, xrdp would fail when logging into sesman-Xvnc.

Log:
connecting to sesman ip 127.0.0.1 port 3350
sesman connect ok
sending login info to session manager, please wait...
xrdp_mm_process_login_response: login successful for display
started connecting
connecting to 127.0.0.1 5910
tcp connected
security level is 2 (1 = none, 2 = standard)
password failed
error - problem connecting

I tried deleting the old ~/.vnc, restarting xrdp, killing xvnc processes, rebooting the server, and manually regenerating sesman_{user}_passwd using vncpasswd, but still got "error - problem connecting" at every step. I downgraded xrdp back to 0.6.1-2, and it worked again. Upgrading back up to 0.6.1-2ubuntu0.1 reproduced the problem.

I'm on Ubuntu 16.04.5 LTS.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xrdp (Ubuntu):
status: New → Confirmed
Andreas Epple (sowaco) wrote :

Some additional information:

Downgrading to 0.6.1-2 fixes the problem for me,too.

Disabling "require-encryption" via "org.gnome.Vino" doesn't help.

When you run "xrdp -ns", there is only one message in case of the fault:
"loaded module 'libvnc.so' ok, interface size 4040, version 2

Guillaume (guillaume-desclaux) wrote :

Adding this in sesman.ini under [Xvnc] solved this issue for me :

param8=-SecurityTypes
param9=None

I was having the same issue and downgrading to 0.6.1-2 fixed the problem.
It would be nice to understand what is causing this.
What are param8 and param9?

Tobin Davis (gruemaster) wrote :

Tried adding the params Guillaume suggested in #3. Didn't work for my systems. Reverting to 0.6.1-2 does. Just hope unattended-updates doesn't overwrite it.

Alex Drott (amdrott) wrote :

Reverting for 0.6.1.2 worked for us but it seems like the unattended update reverted the package back to the one with the issue.

Rolled it back again and trying the sesman.ini edit to try and see if it happens again to have that in place.

chinson (chinsonyeh) wrote :

Add a new file into "/etc/apt/preferences.d/" with the following content can force the xrdp to pin on version 0.6.1-2.

Package: xrdp
Pin: version 0.6.1-2
Pin-Priority: 1000

Brad Kuhlman (bkuhl) wrote :

I also see this after upgrading xrdp from 0.6.1-2 to 0.6.1-2ubuntu0.1 when logging into xrdp module 'console'.

Connection Log:
started connecting
connecting to 127.0.0.1 5900
tcp connected
security level is 2
password failed
error - problem connecting

Josep Pujadas-Jubany (jpujades) wrote :

Lubuntu 16.04 LTS 64 bit up-to-date

Same issue!

Workaround #3 works with vnc4server, not with tightvncserver

tags: added: xenial

I fixed the issue in 0.6.1-2ubuntu0.2 that can be downloaded in the link bellow:

https://launchpad.net/~ubuntu-security-proposed/+archive/ubuntu/ppa/+delete-packages?field.name_filter=xrdp&field.status_filter=published&field.series_filter=

Please, test this new package and let me know it's working properly.

Changed in xrdp (Ubuntu):
assignee: nobody → Paulo Flabiano Smorigo (pfsmorigo)
Neil Hoggarth (neil-hoggarth) wrote :

I tried installing 0.6.1-2ubuntu0.2 from the ubuntu-security-proposed PPA, but the new version appears to have the same sort of problem as 0.6.1-2ubuntu0.1: the connection between the session manager and Xvnc fails with the "password failed", "error - problem connecting" messages in the connection log window.

Yes, I hit the error when I was doing the trusty version. It works if you install the original version and then this version. It's trick. I'm working on it.

Chou Chih Min (steven0928229) wrote :

I cannot download 0.6.1-2ubuntu0.2 from this link.

https://launchpad.net/~ubuntu-security-proposed/+archive/ubuntu/ppa/+delete-packages?field.name_filter=xrdp&field.status_filter=published&field.series_filter=

It shows as below.

Not allowed here
Sorry, you don't have permission to access this page or the information in this page is not shared with you.

New version with the fix (0.6.1-2ubuntu0.3):
https://launchpad.net/~ubuntu-security-proposed/+archive/ubuntu/ppa/+packages?field.name_filter=xrdp

Please, use this new package and let me know if it's working fine.

deehefem (deehefem) wrote :

0.6.1-2ubuntu0.3 package works well on fresh 16.04 install. Confirmed a local connection to the vnc server prompts for password now.

wget https://launchpad.net/~ubuntu-security-proposed/+archive/ubuntu/ppa/+build/16288483/+files/xrdp_0.6.1-2ubuntu0.3_amd64.deb
aptitude purge xrdp
dpkg -i xrdp_0.6.1-2ubuntu0.3_amd64.deb
aptitude install vnc4server

Bogus (bogus22) wrote :

Works for me too on Ubuntu 16.04.

Thanks for the fast fix.

Neil Hoggarth (neil-hoggarth) wrote :

I can confirm that the 0.6.1-2ubuntu0.3 version from the security-proposed PPA works on my test 16.04 system, both as an upgrade from 0.6.1-2, and as an upgrade from 0.6.1-2ubuntu0.1.

Chou Chih Min (steven0928229) wrote :

It is working with 0.6.1-2ubuntu0.3. Thanks.

Working fine for my Xubuntu 16.04 installation so far.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xrdp - 0.6.1-2ubuntu0.3

---------------
xrdp (0.6.1-2ubuntu0.3) xenial-security; urgency=medium

  * SECURITY REGRESSION: Fix conection problem (LP: #1811122).

 -- Paulo Flabiano Smorigo <email address hidden> Wed, 16 Jan 2019 22:26:35 -0200

Changed in xrdp (Ubuntu):
status: Confirmed → Fix Released

I am having the same issue with xrdp version 0.6.0-1ubuntu0.1

Adding this in sesman.ini under [Xvnc]:

param8=-SecurityTypes
param9=None

did work for some time but after some days I am unable to log-in into sesman-Xvnc again.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers