xrdp-build-pulse-modules fails due to incorrect use of dget

Bug #1809951 reported by Esten Rye on 2018-12-28
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
xrdp (Debian)
Fix Released
Unknown
xrdp (Ubuntu)
Undecided
Unassigned

Bug Description

See upstream bug: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=902004
My System Configuration: https://github.com/estenrye/ubuntu_desktop_bootstrap/tree/bf8b4b02443a37d211a7a4c9f94e618bd5c8f21f

esten@lab-ubuntu:~/bootstrap-linux$ sudo xrdp-build-pulse-modules
+ mktemp -d
+ tmp=/tmp/tmp.q1L9VwpRCv
+ cd /tmp/tmp.q1L9VwpRCv
+ dpkg-query -W -f=${source:Version} pulseaudio
+ pulseaudio_version=1:11.1-1ubuntu7.1
+ dpkg-query -W -f=${source:Upstream-Version} pulseaudio
+ pulseaudio_upstream_version=11.1
+ test -x /usr/bin/apt
+ apt show pulseaudio=1:11.1-1ubuntu7.1
+ set -- Package: pulseaudio Version: 1:11.1-1ubuntu7.1 Priority: optional Section: sound Origin: Ubuntu Maintainer: Ubuntu Developers <email address hidden> Original-Maintainer: Pulseaudio maintenance team <email address hidden> Bugs: https://bugs.launchpad.net/ubuntu/+filebug Installed-Size: 4,076 kB Depends: libapparmor1 (>= 2.7.0~beta1+bzr1772), libasound2 (>= 1.0.24.1), libc6 (>= 2.27), libcap2 (>= 1:2.10), libdbus-1-3 (>= 1.9.14), libgcc1 (>= 1:3.0), libice6 (>= 1:1.0.0), libltdl7 (>= 2.4.6), liborc-0.4-0 (>= 1:0.4.25), libpulse0 (= 1:11.1-1ubuntu7.1), libsm6, libsndfile1 (>= 1.0.20), libspeexdsp1 (>= 1.2~beta3.2-1), libstdc++6 (>= 4.1.1), libsystemd0, libtdb1 (>= 1.2.7+git20101214), libudev1 (>= 183), libwebrtc-audio-processing1, libx11-6, libx11-xcb1, libxcb1, libxtst6, adduser, lsb-base (>= 3.2-13), libasound2-plugins, pulseaudio-utils Recommends: rtkit Suggests: udev, pavumeter, pavucontrol, paman, paprefs, ubuntu-sounds Homepage: http://www.pulseaudio.org Task: ubuntu-desktop, kubuntu-desktop, kubuntu-full, xubuntu-core, xubuntu-desktop, lubuntu-desktop-share, lubuntu-gtk-desktop, lubuntu-desktop, lubuntu-qt-core, lubuntu-qt-desktop, lubuntu-qt-desktop, ubuntustudio-video, ubuntustudio-audio, ubuntukylin-desktop, ubuntu-mate-core, ubuntu-mate-desktop, ubuntu-budgie-desktop Supported: 5y Download-Size: 783 kB APT-Manual-Installed: yes APT-Sources: http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages Description: PulseAudio sound server PulseAudio, previously known as Polypaudio, is a sound server for POSIX and WIN32 systems. It is a drop in replacement for the ESD sound server with much better latency, mixing/re-sampling quality and overall architecture. . These are some of PulseAudio's features: . * High quality software mixing of multiple audio streams with support for more than one sink/source. May be used to combine multiple sound cards into one (with sample rate adjustment). . * Wide range of supported client libraries. ESD, ALSA, oss, libao and GStreamer client applications are supported as-is. Native PulseAudio plug-ins are also available for xmms and mplayer. . * Good low latency behaviour and very accurate latency measurement for playback and recording. Ability to fully synchronize multiple playback streams. . * Network transparency, allowing an application to play back or record audio on a different machine than the one it is running on. . * Extensible plug-in architecture with plug-ins for jackd, multicast-rtp lirc and avahi, just to name a few. . This package contains the daemon and basic module set.
+ mirror=pulseaudio
+ suite=Version:
+ test xpulseaudio = x
+ dget pulseaudio/pool/Version:/p/pulseaudio/pulseaudio_1:11.1-1ubuntu7.1.dsc
Usage: dget [options] URL ...
       dget [options] [--all] package[=version] ...

Downloads Debian packages (source and binary) from the specified URLs (first form),
or using the mirror configured in /etc/apt/sources.list(.d) (second form).
It is capable of downloading several packages at once.

   -a, --all Package is a source package; download all binary packages
   -b, --backup Move files that would be overwritten to ./backup
   -q, --quiet Suppress wget/curl output
   -d, --download-only
                   Do not extract downloaded source
   -x, --extract Unpack downloaded source (default)
   -u, --allow-unauthenticated
                   Do no attempt to verify source package signature
   --build Build package with dpkg-buildpackage after download
   --path DIR Check these directories in addition to the apt archive;
                   if DIR='' then clear current list (may be used multiple
                   times)
   --insecure Do not check SSL certificates when downloading
   --no-cache Disable server-side HTTP cache
   --no-conf Don't read devscripts config files;
                   must be the first option given
   -h, --help This message
   -V, --version Version information

Default settings modified by devscripts configuration files:
  (none)
+ cd pulseaudio-11.1
/usr/sbin/xrdp-build-pulse-modules: 40: cd: can't cd to pulseaudio-11.1

Esten Rye (esten.rye) wrote :

xrdp-build-pulse-modules is part of the xrdp-pulseaudio-installer package:

sudo apt install xrdp-pulseaudio-installer -y

Changed in xrdp (Debian):
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xrdp (Ubuntu):
status: New → Confirmed
Chris Guiver (guiverc) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command only once, as it will automatically gather debugging information, in a terminal:

apport-collect 1809951

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.