please apply forward securecy patch

Bug #1752514 reported by Koichiro IWAO
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xrdp (Ubuntu)
New
Undecided
Unassigned

Bug Description

Hi, I'm from xrdp upstream. I'd like you to apply forward securecy patch to your xrdp 0.9.5 package.

Upstream issues:
* https://github.com/neutrinolabs/xrdp/issues/1023
* https://github.com/neutrinolabs/xrdp/pull/1024

The patch ensures xrdp ECDHE- and DHE- cipher suites available. Upcoming 18.04 is a LTS, so it will
be used for a long time. I think enabling perfect forward securecy is worth for everyone.

We will make a new 0.9.6 release end of March but it will not be in time for 18.04 so I'd
appreciate if you apply the patch to 0.9.5.

The diff also can be seen in xrdp repo.

 git diff 793a418..1690950

Tags: patch
Revision history for this message
Koichiro IWAO (meta) wrote :
Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "patch-xrdp-0.9.5-pfs.txt" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers