Ubuntu 12.10 xrdp gets blank screen at login

Bug #1069272 reported by DaleEMoore on 2012-10-21
54
This bug affects 12 people
Affects Status Importance Assigned to Milestone
xrdp (Ubuntu)
Undecided
Unassigned

Bug Description

No panels, no fancy button flyout, just a pretty background.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: xrdp 0.5.0-2
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic i686
NonfreeKernelModules: wl
ApportVersion: 2.6.1-0ubuntu3
Architecture: i386
Date: Sat Oct 20 22:41:15 2012
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release i386 (20121017.2)
ProcEnviron:
 TERM=screen
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: xrdp
UpgradeStatus: No upgrade log present (probably fresh install)

DaleEMoore (daleemoore) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xrdp (Ubuntu):
status: New → Confirmed
Alex Peters (alex-peters) wrote :

May or may not be relevant:

http://c-nergy.be/blog/?p=2879

==== 8< ========================================================

Solving the “Empty Desktop Problem”

This problem was quite easy to solve. After some research on google, I’ve found out that I was not the only one having the issue. The solution was quite simple. In a few words, you have to force the xRDP software to use the ubuntu-2D (or the gnome-fallback) Desktop environment. To force that, you will need to create the .xsession file in your home directory and insert the following text in it

gnome-session –session=ubuntu-2d

or you can use a command line to perform exactly the same operation

[image]

This workaround allows you to have a workable desktop. On the other hand, you will be forced to use Ubuntu-2d (this is ok if you have chosen Unity as preferred desktop). But if you have configured gnome-shell as your preferred desktop, you will not be able to use it. I would say not a big deal, you can remotely connect to your system and in we hope that new release will fix this small issue.

DaleEMoore (daleemoore) wrote :

Thanks Alex for your prompt attention to this issue! Sadly putting "gnome-session –session=ubuntu-2d" in ~/.xsession had no effect here. Did it work for you?

kyssmegbak (deadales) wrote :

Ubuntu has removed unity 2d support in 12.10, so this will not work regardless.

Also tested with "gnome-fallback" instead of "ubuntu-2d."
Still the same issue.

DrQwill (10cn52) wrote :

Solution for me was to install xubuntu-desktop and force the use of xfce4 through the startwm.sh script

DaleEMoore (daleemoore) wrote :

Thanks DrQwill for your insights! Would you please provide a little more detail? I can see that "apt-get install xubuntu-desktop xfce4" will add the extra 160 MB of software you suggest, but; I'm unclear of your use of the startwm.sh script. What did you do there?

Rafael Rubio (rafa-rubio-s) wrote :

Hello, my workaround was installing "gnome-shell" and then you can write in your ~/.xsession file the gnome session you want from all located in /usr/share/xsessions/ (gnome-classic, gnome-fallback, etc.) and it works. The problem is that the "sessions" button has no elements, so you might create a script to log out from the session.

stefanhgm (stefanhegselmann) wrote :

Hello Rafael, I did how you described, but it looks like xrdp is just ignoring my .xsession file. I tried every "desktop" I've found in /usr/share/xsession/ but I always getting just the desktop with my icons, but no taskbar etc...
Im always connecting via "sesman-Xvnc", is that right? All other choices in the xrdp dialouge want an ip, but sesman-Xvnc an sesman-X11rdp. The latter is producing the follwing in the /var/log/xrdp-sesman.log and isnt working at all, so its no alternative either.

[20121114-12:18:42] [INFO ] scp thread on sck 7 started successfully
[20121114-12:18:42] [INFO ] granted TS access to user stefan
[20121114-12:18:42] [INFO ] starting X11rdp session...
[20121114-12:18:42] [CORE ] error starting X server - user stefan - pid 8146
[20121114-12:18:42] [DEBUG] errno: 2, description: No such file or directory
[20121114-12:18:42] [DEBUG] execve parameter list: 11
[20121114-12:18:42] [DEBUG] argv[0] = X11rdp
[20121114-12:18:42] [DEBUG] argv[1] = :13
[20121114-12:18:42] [DEBUG] argv[2] = -geometry
[20121114-12:18:42] [DEBUG] argv[3] = 1440x900
[20121114-12:18:42] [DEBUG] argv[4] = -depth
[20121114-12:18:42] [DEBUG] argv[5] = 16
[20121114-12:18:42] [DEBUG] argv[6] = -bs
[20121114-12:18:42] [DEBUG] argv[7] = -ac
[20121114-12:18:42] [DEBUG] argv[8] = -nolisten
[20121114-12:18:42] [DEBUG] argv[9] = tcp
[20121114-12:18:42] [DEBUG] argv[10] = (null)
[20121114-12:18:52] [ERROR] X server for display 13 startup timeout
[20121114-12:18:52] [INFO ] starting xrdp-sessvc - xpid=8146 - wmpid=8140
[20121114-12:18:52] [ERROR] X server for display 13 startup timeout
[20121114-12:18:52] [ERROR] another Xserver is already active on display 13
[20121114-12:18:52] [DEBUG] aborting connection...
[20121114-12:18:52] [INFO ] session 8138 - user stefan - terminated

Any advices? Is there a way to check if xrdp is using my .xsession correctly?

Benny Law (lawbenny) wrote :

Hi all, I am a newbie of Linux. But after fighting one day, I manage to connect my xp sp3 to ubuntu 12.10 with xrdp installed.. Here is my steps. Hope this help others

1. install xrdp
sudo apt-get install xrdp

2. install fallback
sudo apt-get install gnome-session-fallback

3. logout and login again by gnome theme. You can choose theme before log in..

4. open terminal by ctrl alt t , then input
echo "gnome-session --session=gnome" > ~/.xsession

5. sudo gedit /etec/xrdp/startwm.sh
. /etc/X11/Xsession
to
. /home/<user name>/.xsession

6. sudo /etc/init.d/xrdp restart

7. finished. Enjoy!

Benny

Collen (collen-ngubeni) wrote :

Benny you are the KIng Man

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers