Please sponsor xournal 0.4.1

Bug #137934 reported by Vincenzo Ciancia
12
Affects Status Importance Assigned to Milestone
xournal (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

Binary package hint: xournal

The new package will be uploaded to PPA shortly.

Related branches

Revision history for this message
Vincenzo Ciancia (vincenzo-ml) wrote : Fix in xournal (0.4.0.1)

A new version of xournal was uploaded to fix this bug.

To review the current version, please run

  dget -x http://ppa.launchpad.net/vincenzo-ml/ubuntu/pool/main/x/xournal/xournal_0.4.0.1.dsc

Changed in xournal:
status: New → Fix Committed
William Grant (wgrant)
Changed in xournal:
status: Fix Committed → Confirmed
Revision history for this message
Vincenzo Ciancia (vincenzo-ml) wrote : Re: Please sponsor xournal 0.4.0.1

Please don't sponsor xournal 0.4.0.1, it has a bad bug. I will contact upstream and refile when fixed.

Changed in xournal:
status: Confirmed → Invalid
Revision history for this message
Vincenzo Ciancia (vincenzo-ml) wrote :

xournal (0.4.0.1ubuntu1) gutsy; urgency=low

  * New upstream release.
  * debian/docs: Add html-doc.
  * debian/xournal.desktop: add mimetype application/pdf which is handled by xournal.
  * Fixes (LP: #95045)
  * Fixes (LP: #134475)
  * Fixes (LP: #137944)
  * Fixes (LP: #137934)
  * Fixes (LP: #137935)

 -- Vincenzo Ciancia <email address hidden> Fri, 07 Sep 2007 12:26:22 +0200

Changed in xournal:
status: Invalid → Fix Released
Revision history for this message
Vincenzo Ciancia (vincenzo-ml) wrote :

Just learning to use dput and similar tools. I think I still can't really ask for sponsorship in this upload, and the next one, didn't know dput would have commented here. There will be a next upload (ubuntu2), and this is still not apt to upload because there is one thing missing in the changelog (I forgot to mention a patch and changed build-dep to dpatch). I hope ubuntu3 will be good, which I will prepare later. Sorry for mistakes, I am still a novice with debian and ubuntu developer tools.

Changed in xournal:
status: Fix Released → New
Revision history for this message
Luke Yelavich (themuso) wrote :

Since we are in upstream version freeze, would you mind instead providing a fix for the appropriate problem
that you are experiencing? Alternatively, if you really think a new upstream version is necessary, please file
an UVF exception request. You can find out more at http://wiki.ubuntu.com/FreexeExceptionProcess an look at
the section about MOTU/Universe.

Changed in xournal:
status: New → Incomplete
Revision history for this message
Denis Auroux (auroux) wrote :

As the upstream developer for the software being discussed, let me say that I'm completely astonished to hear that Gutsy is supposed to be in upstream version freeze.

Gutsy seems to include unstable versions of various libraries (chiefly, GTK+ 2.11), as well as recent releases of utilities whose behavior is not backwards compatible with the "standard" versions (e.g., pdftoppm). This exposes a very large number of problems in existing software, which often requires significant upstream fixes -- at the last minute, because until a few weeks ago GTK+ 2.11 had virtually no user base.

Now, I don't actually care which version of Xournal makes it into Gutsy, since I'm a Fedora user, but my feeling is that Gutsy is still pretty much broken at this point. And I'd like to mention that more than half of the time I can spare to spend on development these days is currently spent on diagnosing and working around oddities in the unstable or even undocumented versions of libraries and base packages in Gutsy.

Anyway, whatever.

Revision history for this message
Vincenzo Ciancia (vincenzo-ml) wrote :

Luke, I seriously think that I am going to ask for an UVFe. I don't really have time to backport fixes, and since xournal seems to have very few users we discovered problems too late. Xournal 0.3.3 is really unusable in gutsy, I hope it's a good reason for an UVFe.

Revision history for this message
Wouter Stomp (wouterstomp-deactivatedaccount) wrote :

0.4.1 has been released which fixes more bugs directly related to gtk+ 2.11 which affect gutsy.

Changelog since version currently in ubuntu:

Version 0.4.1 (Sep 15, 2007):
  - bugfix: compatibility with new versions of pdftoppm (thanks to V. Ciancia)
  - GTK+ 2.11 event processing bugfix
  - minor bugfixes: hand tool, handling of filenames containing '&'
  - desktop and MIME files (thanks to Mathieu Bouchard) + updated installer
  - config options: left-handed scrollbar (contributed by Uwe Winter),
    hide some menu items (customizable in config file), auto-save preferences

Version 0.4.0.1 (Sep 3, 2007):
  - bugfixes for GTK+ 2.11 behavior (thanks to everyone who reported bugs)

Version 0.4 (Aug 15, 2007):
  - text tool (handles most TrueType and Type1 fonts)
  - font selection dialog and button
  - keyboard mappings (arrow keys)
  - menu mnemonics and shortcuts (suggestions by Jean-Baptiste Rouquier)
  - more responsive hand tool
  - bugfix for GTK+ 2.11 XInput behavior (thanks to Robert Gerlach)
  - various minor bugfixes and enhancements

Revision history for this message
Vincenzo Ciancia (vincenzo-ml) wrote :

I uploaded version 0.4.1 to my ppa. There, the changelog reflects the history of the package on ppa. I finally created an update for the official ubuntu sources with only one changelog entry describing all the changes I made, and without the ~ppa version number appended. You can find the debdiff attached, and testing packages in my ppa. Please review my debdiff and sponsor it.

UVFe Statement: bug #137944 and bug #134475 seriously break any xournal functionality in gutsy, which in turn means that there is no tablet-pc oriented application in this release. If the fix for the former bug could be backported to release 0.3.3, the latter seems a lot more complicated, and I personally don't have the time to do this. On the other hand, xournal is really useful now that we have tablet support out of the box for many tablet models. As an additional benefit of uploading new upstream release, we would fix bug #95045, which might be difficult to backport.

I am also going to attach diffstat and changelog for upstream sources as requested in "Exceptions for Universe/Multiverse" at

https://wiki.ubuntu.com/FreezeExceptionProcess

Revision history for this message
Vincenzo Ciancia (vincenzo-ml) wrote :
Revision history for this message
Vincenzo Ciancia (vincenzo-ml) wrote :
Revision history for this message
Vincenzo Ciancia (vincenzo-ml) wrote :
Revision history for this message
Vincenzo Ciancia (vincenzo-ml) wrote :
Revision history for this message
Scott Kitterman (kitterman) wrote :

Much to my suprise this late in the cycle, ack from me.

Changed in xournal:
assignee: nobody → motu-uvf
assignee: motu-uvf → nobody
Revision history for this message
Sarah Kowalik (hobbsee-deactivatedaccount) wrote :

+1

Changed in xournal:
status: Incomplete → Confirmed
Revision history for this message
Daniel Holbach (dholbach) wrote :

The package in the PPA is a native one. Please upload a version that includes .diff.gz .orig.tar.gz and .dsc

Changed in xournal:
status: Confirmed → Incomplete
Revision history for this message
Vincenzo Ciancia (vincenzo-ml) wrote :

I suppose I should upload to REVU in any case, also because of a PPA bug which causes launchpad to close "fixes: LP#BUGNO" even for PPAs.

Revision history for this message
Vincenzo Ciancia (vincenzo-ml) wrote :

Uploading to revu (via ftp to revu.tauware.de):
  xournal_0.4.1ubuntu1.dsc: done.
  xournal_0.4.1ubuntu1.tar.gz: done.
  xournal_0.4.1ubuntu1_source.changes: done.
Successfully uploaded packages.

Hope this is correct, and thanks all for following this request.

Revision history for this message
Vincenzo Ciancia (vincenzo-ml) wrote :

I think the following is what you wanted:

Uploading to revu (via ftp to revu.tauware.de):
  xournal_0.4.1-0ubuntu1.dsc: done.
  xournal_0.4.1.orig.tar.gz: done.
  xournal_0.4.1-0ubuntu1.diff.gz: done.
  xournal_0.4.1-0ubuntu1_source.changes: done.
Successfully uploaded packages.

Revision history for this message
Vincenzo Ciancia (vincenzo-ml) wrote :

xournal (0.4.1-0ubuntu1) gutsy; urgency=low

  * New upstream release
    Fixes (LP: #95045)
    Fixes (LP: #134475)
    Fixes (LP: #137934)
    Fixes (LP: #137944)
  * Replace ubuntu shipped .desktop file with the upstream provided one.
  * Install application and mimetype icons in proper directories
  * debian/docs: Add html-doc.

 -- Vincenzo Ciancia <email address hidden> Tue, 18 Sep 2007 14:04:07 +0200

Changed in xournal:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers